Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 1720 suspend/hibernate issues

  1. #1
    Join Date
    May 2008
    Beans
    16

    Unhappy 1720 suspend/hibernate issues

    I've got a inspiron 1720 and I'm currently on Ubuntu 8.04 and I'm having trouble with suspend and hibernate.

    I'm able to go into a suspend and hibernate state without any issues, however coming out of either state is where I run into trouble.

    When coming out from a suspend, all I see is a black screen, but with no keyboard input or hard drive activity; and I have to manually shut down and boot up to get back to Ubuntu.

    When it comes to hibernate, all I end up seeing is black background and a stretched Ubuntu logo. I do have keyboard input however the only thing that seems to do anything is ctrl-alt-del; and the function keys to dim my lcd work. Other than that, my laptop will sit on that screen for any length of time.

    I've searched on the forums and have come across a couple of posts of people, with the same laptop, who have had success with suspend and hibernate. One such post had something to do with updating video card drivers.

    I have a Geforce 8600M GT, but don't know what version of drivers is being used. Tried searching for nvidia-glx-new and I'm unable to find it when I use Synaptic Package Manager and if I go to System - Administration - Hardware Drivers I see nothing in the list.

    Anyone have any suggestions as to what I can try of fiddle around with?

    Thanks,

  2. #2
    Join Date
    May 2008
    Beans
    16

    Re: 1720 suspend/hibernate issues

    Does anyone have this problem? Or is it just me?

  3. #3
    Join Date
    Aug 2008
    Beans
    9
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: 1720 suspend/hibernate issues

    Try to set DOUBLE_CONSOLE_SWITCH parameter of /etc/default/acpi-support file to true. For me it works perfectly.

  4. #4
    Join Date
    Nov 2007
    Location
    NC, USA
    Beans
    829
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 1720 suspend/hibernate issues

    I have the same problem on my 1720. I'll try what dizcrypt suggested.
    Linux User #460341 || Ubuntu User #19510 || Unanswered Posts Team

  5. #5
    Join Date
    May 2005
    Location
    Amsterdam
    Beans
    33
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: 1720 suspend/hibernate issues

    Hi, I'm using the same graphicboard but even without the setting it works fine.
    System - Administration - Hardware , I can see the driver. This is my 3rd time installation but I've never encountered this kind of issue.

    Have you ugraded from the lower version? If so there might be some mis-interoperability between the version.

  6. #6
    Join Date
    May 2008
    Beans
    16

    Re: 1720 suspend/hibernate issues

    Quote Originally Posted by dizcrypt View Post
    Try to set DOUBLE_CONSOLE_SWITCH parameter of /etc/default/acpi-support file to true. For me it works perfectly.
    Hey dizcrypt. I uncommented that line in the file you mentioned. Unfortunately that didn't do the trick.

    Again I was able to get my laptop to suspend, but coming out of a suspend only showed a black screen. In fact when I initially get out of suspend I can see my num-lock light come on. Tried putting caps lock but nothing happens.

    However I'm able to press ctrl alt del and my laptop did reboot.

    Cavalierski, in response to your question, how have you upgraded your video drivers from a lower version? Because when I go to System - Administration - Hardware I see nothing in the list.

    Thanks for the replies, I'm hopeful for getting this working because some people already have theirs working.

  7. #7
    Join Date
    Jul 2008
    Beans
    32

    Re: 1720 suspend/hibernate issues

    i thought this was fixed with the new .21 kernel :S

  8. #8
    Join Date
    Aug 2008
    Beans
    9
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: 1720 suspend/hibernate issues

    I had similar symptoms before the fix. Sometimes it was possible to recover througth pressing ctrl-alt-f1 (switch to console) and then alt-f7 (back to X), sometimes not.

    Regarding the driver. After the installation, there was a message, whether to install proprietary driver or not.

    Do you have proposed updates enabled on your system? It enabled on mine and AFAIR there were some fixes for suspend / hibernate.

  9. #9
    Join Date
    May 2008
    Beans
    16

    Re: 1720 suspend/hibernate issues

    Quote Originally Posted by dizcrypt View Post
    I had similar symptoms before the fix. Sometimes it was possible to recover througth pressing ctrl-alt-f1 (switch to console) and then alt-f7 (back to X), sometimes not.

    Regarding the driver. After the installation, there was a message, whether to install proprietary driver or not.

    Do you have proposed updates enabled on your system? It enabled on mine and AFAIR there were some fixes for suspend / hibernate.
    Hey dizcrypt,

    Which update are you referring to by the way? I'm on release 8.04 (Hardy), kernel 2.6.24-19.

    My Hal gui keeps crashing (tried to re-install it to no avail) so I'm unable to find out specifically what video drivers I'm on.

    If it's possible would you be able to forward to me the link where you obtained the drivers for your video card? Or if there is a certain repo I should enabled, could you please let me know?

  10. #10
    Join Date
    Aug 2008
    Beans
    9
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: 1720 suspend/hibernate issues

    Hi number3,

    I have hardy-proposed updates enabled (Software Sources - Updates), so my kernel is 2.6.24-21.

    Do you have a checkbox "Proprietary drivers for devices (restricted)" enabled in Software Sources - Ubuntu Software?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •