Results 1 to 6 of 6

Thread: [SOLVED] ethernet not working - how do I fix

  1. #1
    Join Date
    Jun 2008
    Location
    Huntingdale, W Australia
    Beans
    475
    Distro
    Ubuntu 10.04 Lucid Lynx

    [SOLVED] ethernet not working - how do I fix

    Posting this for a friend who lives 70km away.

    I installed Hardy a couple of weeks ago and all was working fine till this morning.

    I was on phone talking them through wireless network problem, but in process uninstalled 'Network Manager' (NM) before installing 'wifi-radar'.

    Anyhow, upshot is there is now no ethernet connection, and as such can't download any packages, nor re-install NM.

    How do I get ethernet working again? (without installing Ubuntu from scratch).
    Gigabyte MA790FX-DS5 m/board + 3.0Ghz Phenom II X4 945 CPU + 4GB DDR2 RAM + Sapphire HD5770 1GB video + 1 pata & 3 sata drives (2000 GB) + 2 DVD burners + 2 x 19" LCD monitors ... July'08 -XP +Hardy, Dec'09 +Karmic, May'10 +Lucid

  2. #2
    Join Date
    Dec 2007
    Location
    The last place I look
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: ethernet not working - how do I fix

    Quote Originally Posted by charonred View Post
    Posting this for a friend who lives 70km away.

    I installed Hardy a couple of weeks ago and all was working fine till this morning.

    I was on phone talking them through wireless network problem, but in process uninstalled 'Network Manager' (NM) before installing 'wifi-radar'.

    Anyhow, upshot is there is now no ethernet connection, and as such can't download any packages, nor re-install NM.

    How do I get ethernet working again? (without installing Ubuntu from scratch).
    you can probably install network-manager off the live or alternate cds.
    just enable the source in your sources list.

  3. #3
    Join Date
    Jun 2008
    Location
    Huntingdale, W Australia
    Beans
    475
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: ethernet not working - how do I fix

    they tried that already - after adding CD source, Synaptic needs to reload repositories list, but with the ethernet offline it reports errors, and as such can't install NM - so need another way of installing/reinstalling NM.

    I'm not that familiar with using terminal scripts, but will give any recommended scripts a shot; but remember it's not me actually doing it, I have to instruct friend over the phone how to do this, and they have only been introduced to Linux 2 weeks ago, so as simple as possible advice please.
    Gigabyte MA790FX-DS5 m/board + 3.0Ghz Phenom II X4 945 CPU + 4GB DDR2 RAM + Sapphire HD5770 1GB video + 1 pata & 3 sata drives (2000 GB) + 2 DVD burners + 2 x 19" LCD monitors ... July'08 -XP +Hardy, Dec'09 +Karmic, May'10 +Lucid

  4. #4
    Join Date
    Dec 2007
    Location
    The last place I look
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: ethernet not working - how do I fix

    Quote Originally Posted by charonred View Post
    they tried that already - after adding CD source, Synaptic needs to reload repositories list, but with the ethernet offline it reports errors, and as such can't install NM - so need another way of installing/reinstalling NM.

    I'm not that familiar with using terminal scripts, but will give any recommended scripts a shot; but remember it's not me actually doing it, I have to instruct friend over the phone how to do this, and they have only been introduced to Linux 2 weeks ago, so as simple as possible advice please.
    have you tried disabling all repos except the disc?

  5. #5
    Join Date
    Jun 2008
    Location
    Huntingdale, W Australia
    Beans
    475
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: ethernet not working - how do I fix

    Thanks, going to try that next - tomorrow morning when I phone them.

    Also found the 2 NM packages at Ubuntu; downloaded them and forwarded to an email address they can access from nearby PC for downloading to a thumb drive - hopefully your suggestion of disabling other repositories will work first.
    Gigabyte MA790FX-DS5 m/board + 3.0Ghz Phenom II X4 945 CPU + 4GB DDR2 RAM + Sapphire HD5770 1GB video + 1 pata & 3 sata drives (2000 GB) + 2 DVD burners + 2 x 19" LCD monitors ... July'08 -XP +Hardy, Dec'09 +Karmic, May'10 +Lucid

  6. #6
    Join Date
    Jun 2008
    Location
    Huntingdale, W Australia
    Beans
    475
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: ethernet not working - how do I fix

    Update:
    tried both the suggested methods above, but system still tried to connect with web (even with everything but CD resource unticked); and the script resulted in same sort of error (couldn't check dependencies online or something).

    So friend then used Live CD to connect and accessed her email via webmail for the 2 NM files; transferred them to a thumb drive, then rebooted and ran them - fixed the problem - instant network, then she went off to try her hand at fixing the 2 boy's PCs wireless connection.

    Love the way the Live CD just works

    http://packages.ubuntu.com/hardy/net/network-manager

    http://packages.ubuntu.com/hardy/net...-manager-gnome
    Gigabyte MA790FX-DS5 m/board + 3.0Ghz Phenom II X4 945 CPU + 4GB DDR2 RAM + Sapphire HD5770 1GB video + 1 pata & 3 sata drives (2000 GB) + 2 DVD burners + 2 x 19" LCD monitors ... July'08 -XP +Hardy, Dec'09 +Karmic, May'10 +Lucid

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •