Results 1 to 9 of 9

Thread: aplay/startup sound works, but sound throughout system doesen't

  1. #1
    Join Date
    Jan 2007
    Beans
    160
    Distro
    Hardy Heron (Ubuntu Development)

    aplay/startup sound works, but sound throughout system doesen't

    Hey guys, let me describe my situation to you -

    * I have a Toshiba A215-???? laptop (can't remember the last four numbers, sorry)
    * Running Ubuntu 8.10 Intrepid kernel 2.6.27-4-generic. Upgraded from Hardy recently, in which sound worked perfectly.
    * The sound driver that has consistently works for me is snd-hda-intel, and ALSA.
    * The start up sound when I'm logging into the Ubuntu desktop plays fine
    * The command "aplay -vv whatever.mp3" works fine, I can hear the audio.
    * Sound seemes to be working in a virtual machine of mine using VmWare.
    * Sound throughout the system, however, does not work! (Firefox, Rythmbox, whatever)
    * I have everything set to Autodetect in System -> Preferences -> Sound.

    Any ideas why sound would not be working in Firefox, Rythmbox, and all other user applications?

    Andrew

    PS - In Hardy, one of the things I did was add -

    options snd-hda-intel model=toshiba

    To my /etc/modprobe.d/alsa-base file. I've done this in Intrepid as well (got erased).
    Last edited by AndrewTheArt; October 5th, 2008 at 08:35 PM.
    USE GOOGLE. It's your friend.

  2. #2
    Join Date
    Nov 2005
    Location
    Sweden
    Beans
    23
    Distro
    Hardy Heron (Ubuntu Development)

    Re: aplay/startup sound works, but sound throughout system doesen't

    I had this aswell on Intrepid, try disabling the startup/waring sound, that made alsa/pulse work again for me.

  3. #3
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: aplay/startup sound works, but sound throughout system doesen't

    Well, there have not been a lot of drastic changes in Intrepid as far as sound goes, but there is a thread on Intrepid sound fixes here:

    http://ubuntuforums.org/showthread.php?t=866965

  4. #4
    Join Date
    Jan 2007
    Beans
    160
    Distro
    Hardy Heron (Ubuntu Development)

    Re: aplay/startup sound works, but sound throughout system doesen't

    dogson - tired that, didn't seem to work.
    markbuntu - followed that guide, now my sound is completely broken. When I try to change the volume (for example) I get

    No volume control GStreamer plugins and/or devices found
    USE GOOGLE. It's your friend.

  5. #5
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: aplay/startup sound works, but sound throughout system doesen't

    Did you read the thread or just follow the OP?

  6. #6
    Join Date
    Jan 2007
    Beans
    160
    Distro
    Hardy Heron (Ubuntu Development)

    Re: aplay/startup sound works, but sound throughout system doesen't

    I read the OP at first, but at your suggestion I read (most) of the entire thread. The only additional info I got out of it was to install/run "padevchooser", but has not seemed to solve my problem. The options are a bit intimidating.
    USE GOOGLE. It's your friend.

  7. #7
    Join Date
    Jan 2007
    Beans
    160
    Distro
    Hardy Heron (Ubuntu Development)

    Re: aplay/startup sound works, but sound throughout system doesen't

    OK, guys, I'm sort of desperate here. Sound simply does not work at all for me anymore.
    USE GOOGLE. It's your friend.

  8. #8
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: aplay/startup sound works, but sound throughout system doesen't

    You can look in my guide here which is basic sound troubleshooting, should be pretty much the same for Intrepid:

    http://ubuntuforums.org/showthread.php?t=843012

  9. #9
    Join Date
    Jan 2007
    Beans
    160
    Distro
    Hardy Heron (Ubuntu Development)

    Re: aplay/startup sound works, but sound throughout system doesen't

    Quote Originally Posted by markbuntu View Post
    You can look in my guide here which is basic sound troubleshooting, should be pretty much the same for Intrepid:

    http://ubuntuforums.org/showthread.php?t=843012
    I looked at your guide, but I got stuck pretty quickly because I couldn't even successfully open the volume/sound control in the top system tray without getting errors.

    I fixed my sound problem though (running a Toshiba A215-???? laptop, kernel 2.6.27-4), by more or less directly following this guide -

    https://help.ubuntu.com/community/HdaIntelSoundHowto

    Essentially, I updated to the latest version of ALSA (by directly following the steps in the section "Update to the Latest Version of ALSA"). Note on that step - the latest version of ALSA will of course have the latest "Last Modified" date near it when you are downloading the files. After downloading the thee archives I proceeded to open the file "alsa-base" in gedit -

    Code:
    sudo gedit /etc/modprobe.d/alsa-base
    ...ensuring the line

    Code:
    options snd-hda-intel model=toshiba
    was at the bottom. If you're looking at this post are trying to troubleshoot for your laptop/desktop, you'll probably need to change the model you put in the file. The process for finding out your model is by running the following command to get the codec -

    Code:
    cat /proc/asound/card0/codec#* | grep Codec
    Next to Codec: will be the name of your soundcard. (For instance, I found Realtek ALC268, so I remembered "ALC268" and went on)

    Then the guide says to run through a file and look for a reference to this codec.

    The file (updated continuously I believe) is online, here -

    http://www.mjmwired.net/kernel/Docum...figuration.txt

    or locally on your machine it may be here -

    Code:
    /usr/src/modules/alsa-driver/alsa-kernel/Documentation/ALSA-Configuration.txt
    Safe bet is to use the one online.

    Open it up and search for references to the codec you found before. You should get a result, at which point you'll see a list of models that are associated with the codec. Pick the one that best describes your machine (in my caes, "toshiba" because my laptop is Toshiba ).

    Then I went to System -> Preferences -> Sound and made sure everything was on Autodetect.

    Then I rebooted. Everything worked at that point.
    Last edited by AndrewTheArt; October 5th, 2008 at 08:34 PM.
    USE GOOGLE. It's your friend.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •