Results 1 to 6 of 6

Thread: mathematica problem with XGL

  1. #1
    Join Date
    Sep 2006
    Beans
    4

    mathematica problem with XGL

    when i lauched the mathematica in XGL, it did not work, and X broke with it. i had to restart X.

    i have tried without XGL, it is ok.

    so, what's the problem? what should i do?

    thx for your suggestion.

    my system: ubuntu6.06lts
    Last edited by interskh; September 27th, 2006 at 07:44 AM.

  2. #2
    Rui Pais's Avatar
    Rui Pais is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Oct 2004
    Beans
    2,324

    Re: mathematica problem with XGL

    hi,

    some people seems to find a solution by exporting first:
    Code:
    export XLIB_SKIP_ARGB_VISUALS=1
    before running Mathematica.

    Hope it works with you.
    ___________________________________
    ESTRAGON: We've lost our rights?

  3. #3
    Join Date
    Sep 2006
    Beans
    4

    Re: mathematica problem with XGL

    thx
    i've done this before, but it does not work either

  4. #4
    Rui Pais's Avatar
    Rui Pais is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Oct 2004
    Beans
    2,324

    Re: mathematica problem with XGL

    uhmm, sorry to ear it.

    it didn't work with me too, but since i readed lot of people reporting success with that and you haven't mention it in your 1st post so i suggested...

    Another one.
    Do you really need XGL? Or maybe don't work with xgl on Mathematica sessions...
    Before i give up on Xgl, i've made 2 X servers, 0=Standard and 1=Xgl (on /etc/X11/gdm/gdm.conf-custom) so when i needed to use Mathematica (totem have the same problem) i simply press Ctrl+F7 and login there.
    Or lightly you can do the same using a nested login window (usually on gnome is on System menu) with a Standard server.

    Sorry, not solutions, only workarounds
    ___________________________________
    ESTRAGON: We've lost our rights?

  5. #5
    Join Date
    Sep 2006
    Beans
    4

    Re: mathematica problem with XGL

    emm, it seems a nice idea
    though it's better to do these all in one x server.
    anyway, thank u

    sry for my poor english.

  6. #6
    Join Date
    Feb 2006
    Location
    Champaign, IL
    Beans
    12
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: mathematica problem with XGL

    i was having some issues running mathematica in Edgy, but

    export XLIB_SKIP_ARGB_VISUALS=1

    worked great for me. thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •