Results 1 to 4 of 4

Thread: [SOLVED] exaile not running

  1. #1
    Join Date
    May 2008
    Beans
    45

    [SOLVED] exaile not running

    Hey, exaile's not running.
    Code:
    dan@dennis:~$ exaile
    Traceback (most recent call last):
      File "exaile.py", line 2634, in <module>
        main()
      File "exaile.py", line 2626, in main
        exaile = ExaileWindow(options, fr)
      File "exaile.py", line 125, in __init__
        self.database_connect()
      File "exaile.py", line 1091, in database_connect
        self.db = self.get_database()
      File "exaile.py", line 1078, in get_database
        database = db.DBManager(loc)
      File "/usr/share/exaile/xl/db.py", line 75, in __init__
        cur.execute("PRAGMA auto_vacuum=1")
    OperationalError: database is locked
    The only thing I can think of is running the program as root a few minutes ago, but all I did was play some music. Is there anything I can do to fix this short of reinstalling and losing my playlists?

  2. #2
    Join Date
    Oct 2006
    Location
    Central Florida
    Beans
    1,264
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: exaile not running

    Delete the .exaile folder from your home directory.
    Use Control-H in Nautilus so that you can see the folder (the . in front means it's hidden).

    This I found by googling "exaile locked database". If you ran as root you might have to take ownership first:
    Code:
    sudo chown danmeestwood /home/danmeetswood/.exaile -R
    changing both instances of danmeetswood to your actual user name.
    Why can't life have a sudo apt-get install -f command?
    Install VMWare Server 2 on a text-only system
    Need help getting your printer working in Linux?
    It's all about choice, right? Then stop flaming Windows users.

  3. #3
    Join Date
    May 2008
    Beans
    45

    Re: exaile not running

    Well, that did unlock it for sure. But now all the settings and playlists are gone. Oh well, spilled milk. Thanks for the reply, dog.

  4. #4
    Join Date
    Nov 2008
    Beans
    1

    Re: exaile not running

    you only need to delete "music.db" and "music.db-journal" although I'm not sure what "music.db-journal" is or if it realy needs to go.
    Deleating "music.db" may be all thats required.
    Delaete "music.db" first and see if that works.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •