Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: disable bluetooth on startup

  1. #1
    Join Date
    Aug 2005
    Beans
    795

    disable bluetooth on startup

    Im using ubuntu 8.04 on a thinkpad x61.
    The bluetooth light is always on.
    I have unchecked bluetooth in system->administration->services.
    I use powertop and it tells me to enter these commands to turn off bluetooth
    Code:
    hciconfig hci0 down
    rmmod hci_usb
    and this command turns bluetooth back on
    Code:
    modprobe hci_usb reset=1
    I do not use bluetooth. It seems to me that for me to have to turn it off it must have been turned on at some point during startup. I would like bluetooth not to turn on.

    I would also like to be able to turn on bluetooth without restarting or logging out.

    Does anybody know how I could go about setting this up?

    I wanted to make this post on an old thread here but it has been archived so this is a synopsis of most of the information there. http://ubuntuforums.org/showthread.p...luetooth+radio
    Last edited by zorkerz; September 24th, 2008 at 05:38 AM.

  2. #2
    Join Date
    Apr 2006
    Beans
    547

    Re: disable bluetooth on startup

    Can you disable bluetooth in the BIOS ?

  3. #3
    Join Date
    Feb 2007
    Location
    /dev/random
    Beans
    671
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: disable bluetooth on startup

    Hi,

    Is the BT indicator on immediately after power up, or does it turn on after the OS starts loading?

    If it's the first case, you're out of luck, it's a hardware default action.
    Main system: Dell 1420n - C2D T5250, 4GB RAM, 120GB SATA. Ubuntu 8.04.3.
    Assorted VMs (via VBox). Favorites: Fedora, FreeBSD, Solaris.

  4. #4
    Join Date
    Aug 2005
    Beans
    795

    Re: disable bluetooth on startup

    Its on as soon as I power up. Bummer. So I guess the best solution would be for me to see if i can turn it off in the bios? This way im not waisting power and if I ever do want bluetooth I can reinable it.

    Im thinking in windows though that the bluetooth light goes off. This would make me think there should be some way to turn it off.

    Ill investigate and reportback.

    Thanks

  5. #5
    Join Date
    Feb 2007
    Location
    /dev/random
    Beans
    671
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: disable bluetooth on startup

    Hi,

    Yep, see if the BIOS settings will let you disable the device / interface.

    About wasting power - if there's no software to actually "do Bluetooth", then the only power being used is that to light the LED, typically about 0.01 watt. Not much of an impact there Even if BT is active typical power draw is 0.3 to 0.5 watt, still not much of an impact on a system that consumes 50-plus watts in operation.
    Main system: Dell 1420n - C2D T5250, 4GB RAM, 120GB SATA. Ubuntu 8.04.3.
    Assorted VMs (via VBox). Favorites: Fedora, FreeBSD, Solaris.

  6. #6
    Join Date
    Aug 2005
    Beans
    795

    Re: disable bluetooth on startup

    So a quick check of my bios does not reveal any way to disable BT.

    Im not all that worried about the LED itself although if the light is just always on it seems very pointless to me. Im pretty sure it can turn off in windows. So there is probably something still running in ubuntu.

    As for my power consumption I actually average out around 15w with wireless enabled. When I disable the BT with the powertop commands its droped down to 14.8w. These are just quick checks I know it often runs around 20w.

    So is the best solution to just run the powertop BT commands at startup?
    I still think there must be a way to have ubuntu not start ubuntu instead of start it and the stop it.

  7. #7
    Join Date
    Aug 2005
    Beans
    795

    Re: [SOLVED] disable bluetooth on startup

    Solution found! I decided to head over to thinkwiki as i proabubly should have done from the start and found out that the fn+F5 key combination turns on/off wifi and bluetooth. There are four possible combinations that occur in this order.

    BT and wifi on
    neither on
    wifi on BT off
    BT on wifi off

    I also have a hardware switch that turns off wifi and bluetooth.

    These settings are saved after restart also. Note this also turns the BT led on and off with is superior even to the powertop recomended commands.

    here is the think wiki page http://www.thinkwiki.org/wiki/ThinkPad_Bluetooth_with_Enhanced_Data_Rate_(BDC-2)

    Thanks for all the input

  8. #8
    Join Date
    Aug 2005
    Beans
    795

    Re: [SOLVED] disable bluetooth on startup

    Ive upgraded to the intrepid beta and have discovered a new twist to this problem. Pressing fn+F5 once still turns off bluetooth and leaves wifi on, however, now I need to do this every time the computer starts up. I have disabled bluetooth in intrepid through system->preferences->sessions and system->administration->services still as found before neither of this touch the LED light.

    Is there a way I can find the script/command that is run when fn+F5 is pressed so that I can run it automatically on startup?

  9. #9
    Join Date
    Aug 2005
    Beans
    795

    Re: disable bluetooth on startup

    Im not sure I understand what you mean.

    By bluetooth setting do you mean system->preferences->bluetooth?
    The services tab here now shows no services because I have disabled them and the general tab does not appear to have a disable check box or some equivalent.

    What is service station?

  10. #10
    Join Date
    Jun 2006
    Beans
    20

    Re: [SOLVED] disable bluetooth on startup

    Quote Originally Posted by zorkerz View Post
    Ive upgraded to the intrepid beta and have discovered a new twist to this problem. Pressing fn+F5 once still turns off bluetooth and leaves wifi on, however, now I need to do this every time the computer starts up.
    same problem here. maybe you should report this bug on launchpad. i hate these regressions ...

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •