Results 1 to 8 of 8

Thread: Drupal

  1. #1
    Join Date
    Mar 2008
    Beans
    42

    Smile Drupal

    Hi every1.... as i've copied drupal to /var/www ,and then in /var/www/drupal/sites/default/ chmod 777 settings.php.Then as i've tried to install drupal its giving me this error..!! plz help me..
    "Your web server does not appear to support any common database types. Check with your hosting provider to see if they offer any databases that Drupal supports."

  2. #2

    Re: Drupal

    Have you installed and turned on mysql?
    Noli illegitimi carborundum

  3. #3
    Join Date
    Mar 2008
    Beans
    42

    Re: Drupal

    Yah brother.... Using other terminal i've started mysql ... But still the problem persists..

  4. #4
    Join Date
    Mar 2008
    Beans
    42

    Post Re: Drupal

    Plz help me with this....

  5. #5
    Join Date
    Apr 2006
    Beans
    424
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Drupal

    did you try installing drupal5 via apt? If you try via this method it may prove to be much easier
    Code:
    sudo apt-get install drupal5
    Registered Linux user number 438485.
    Machine registration number 344277.
    Ubuntu User number 10798.

  6. #6
    Join Date
    Mar 2008
    Beans
    42

    Angry Re: Drupal

    Yah... even that doesn't work... I've configured drupal perfectly i suppose...
    "Your web server does not appear to support any common database types. Check with your hosting provider to see if they offer any databases that Drupal supports." Even googling this isn't solving my pblm.... sumone plz help me with this....

    Problem might have been with mysql... or is php posing any problem..??
    I've opened up a another terminal and i've
    1.create database abc;
    2.use abc;

    still the error comes...plz.. help me..

  7. #7

    Re: Drupal

    Are you pointing to the correct database in the settings.php file? You will need to set the database name and the mysql user to connect with in this file. Should look something like this.
    Code:
    $db_url = 'mysql://user:pass@localhost/drupal-default';
    where user and pass states the username and password to be presented. @localhost states which host can connect and drupal-default is the name of the database. But to be honest the set up process should do this for you. Try adding this info manually into the settings.php to see what happens. Don't forget to swap your details for the username password and database.
    Noli illegitimi carborundum

  8. #8
    Join Date
    Mar 2008
    Beans
    42

    Talking Re: Drupal

    Yah... This really worked... Thnkx fr ur help... But i would like to know why didn't this happen automatically....

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •