Page 21 of 24 FirstFirst ... 111920212223 ... LastLast
Results 201 to 210 of 232

Thread: Conky Exaile Python Script

  1. #201
    Join Date
    Dec 2005
    Location
    world
    Beans
    25

    Re: Conky Exaile Python Script

    hi Kaivalgi

    for the script with Exaile I get continuous errors:

    Code:
    SyntaxError: invalid syntax
      File "/home/papio/.conky/scripts/conkyExaile.py", line 46
        self.parser.add_option("-t", "--template", dest="template", type="string", metavar="FILE", help=u"define a template file to generate output in one call. A displayable item in the file is in the form [--datatype=TI]. The following are possible options within each item: --datatype,--ratingchar. Note that the short forms of the options are not currently supported! None of these options are applicable at command line when using templates.")
    what is the problem ?

  2. #202
    Join Date
    Feb 2008
    Location
    52°38'41.6"N/1°19'43.6"E
    Beans
    Hidden!

    Re: Conky Exaile Python Script

    Quote Originally Posted by zyghom View Post
    what is the problem ?
    posted response above...

  3. #203
    Join Date
    Dec 2005
    Location
    world
    Beans
    25

    Re: Conky Exaile Python Script

    Quote Originally Posted by kaivalagi View Post
    posted response above...


    Code:
    09:36:03 papio@baboonsony:~$ python --version
    Python 3.1.3
    09:36:37 papio@baboonsony:~$

  4. #204
    Join Date
    Feb 2008
    Location
    52°38'41.6"N/1°19'43.6"E
    Beans
    Hidden!

    Re: Conky Exaile Python Script

    Quote Originally Posted by zyghom View Post
    Code:
    09:36:03 papio@baboonsony:~$ python --version
    Python 3.1.3
    09:36:37 papio@baboonsony:~$
    There's your problem, what is the conkyExaile script contents like?
    e.g. run "cat /usr/bin/conkyExaile" and post results, the script should handle this issue unless you haven't updated? How did you install the script?


    The latest version of conkyExaile, version 2.14, has this for the /usr/bin script which should handle if /usr/bin/python is linked to python3 as in your case:
    Code:
    #! /bin/sh
    cd /usr/share/conkyexaile/
    
    pythoncmd="/usr/share/conkyexaile/conkyExaile.py $@"
    
    if [ -f /usr/bin/python2 ]; then
    	cmd="/usr/bin/python2 $pythoncmd"
    elif [ -f /usr/bin/python2.7 ] ; then
    	cmd="/usr/bin/python2.7 $pythoncmd"
    elif [ -f /usr/bin/python2.6 ] ; then
    	cmd="/usr/bin/python2.6 $pythoncmd"
    else
    	# here's hoping!
    	cmd="/usr/bin/python $pythoncmd"
    fi
    
    exec $cmd
    Last edited by kaivalagi; December 9th, 2010 at 09:41 AM.

  5. #205
    Join Date
    Dec 2005
    Location
    world
    Beans
    25

    Re: Conky Exaile Python Script


  6. #206
    Join Date
    Feb 2008
    Location
    52°38'41.6"N/1°19'43.6"E
    Beans
    Hidden!

    Re: Conky Exaile Python Script

    Quote Originally Posted by zyghom View Post
    reinstall the script using the instructions in the first post of this thread...

    Unfortunately the authors of these packs do not know how to handle deb packages etc and so you have these issues, they should script the install from the repo in thier packages rather than included the scripts themselves...otherwise you get out of date packages easily...it really pees me off to be honest...

  7. #207
    Join Date
    Dec 2005
    Location
    world
    Beans
    25

    Re: Conky Exaile Python Script

    I installed conkyexaile-bzr and ran as in README:

    Code:
    09:50:00 papio@baboonsony:~$ conky -c /usr/share/conkyexaile/example/conkyrc
    Conky: /usr/share/conkyexaile/example/conkyrc: 47: no such configuration: 'border_margin'
    Conky: use_spacer should have an argument of left, right, or none.  'yes' seems to be some form of 'true', so defaulting to right.
    Conky: desktop window (100002b) is subwindow of root window (a9)
    Conky: window type - override
    Conky: drawing to created window (0x5e00001)
    Conky: drawing to double buffer
    Traceback (most recent call last):
      File "/usr/share/conkyexaile/conkyExaile.py", line 10, in <module>
        from PIL import Image
    ImportError: No module named PIL

  8. #208
    Join Date
    Feb 2008
    Location
    52°38'41.6"N/1°19'43.6"E
    Beans
    Hidden!

    Re: Conky Exaile Python Script

    Quote Originally Posted by zyghom View Post
    I installed conkyexaile-bzr and ran as in README:

    Code:
    09:50:00 papio@baboonsony:~$ conky -c /usr/share/conkyexaile/example/conkyrc
    Conky: /usr/share/conkyexaile/example/conkyrc: 47: no such configuration: 'border_margin'
    Conky: use_spacer should have an argument of left, right, or none.  'yes' seems to be some form of 'true', so defaulting to right.
    Conky: desktop window (100002b) is subwindow of root window (a9)
    Conky: window type - override
    Conky: drawing to created window (0x5e00001)
    Conky: drawing to double buffer
    Traceback (most recent call last):
      File "/usr/share/conkyexaile/conkyExaile.py", line 10, in <module>
        from PIL import Image
    ImportError: No module named PIL
    You running Arch?

    PIL / "python-imaging" needs installing...you've gotten further as the script is starting now

    Once you get that running you'll need to mess with the other download you did so it can run the script now it is in a different location
    Last edited by kaivalagi; December 9th, 2010 at 10:15 AM.

  9. #209
    Join Date
    Dec 2005
    Location
    world
    Beans
    25

    Re: Conky Exaile Python Script

    Quote Originally Posted by kaivalagi View Post
    You running Arch?

    PIL / "python-imaging" needs installing...you've gotten further as the script is starting now

    Once you get that running you'll need to mess with the other download you did so it can run the script now it is in a different location

    yes, Archlinux
    after installation of imaging it is OK now - thank you

    btw the whole package from gnome site was very nice, otherwise in Arch there are only single packages...

  10. #210
    Join Date
    Feb 2008
    Location
    52°38'41.6"N/1°19'43.6"E
    Beans
    Hidden!

    Re: Conky Exaile Python Script

    Quote Originally Posted by zyghom View Post
    yes, Archlinux
    after installation of imaging it is OK now - thank you

    btw the whole package from gnome site was very nice, otherwise in Arch there are only single packages...
    No problems, it is advised to install my scripts from the AUR so if things change you get the benefit, in this case you missed out on the fix to the /usr/bin/conkyExaile bash script to manage the execution of the script via python2. Since python3 was made the norm in Arch i.e. sym linked to /usr/bin/python lots of python2 scripts have been failing

    I currently have my sym links changed so lots still works e.g.:
    Code:
    ~]$ ls /usr/bin/python
    lrwxrwxrwx 1 root root 7 Dec  4 16:32 /usr/bin/python -> python2
    For the default install (and your system) it will be pointing to python3...

    Have fun

Page 21 of 24 FirstFirst ... 111920212223 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •