Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Ubuntu and ASUS M50 version notebooks

  1. #1
    Join Date
    Oct 2006
    Location
    Nashville, TN
    Beans
    62
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Exclamation Ubuntu and ASUS M50 version notebooks

    I've seen a few posts about this particular model. My son has one and i'm busy trying to get it to work correctly. Here are the problems i'm having with this.

    His laptop is Model: M50VM-X1
    Version: Hardy Heron 8.04.1

    I was able to install nVidia graphics drivers via EnvyNG only by going into console, typing "envyng -t" as root. ( sudo envyng -t )

    If you don't have envyng, i would suggest turning on the 3rd party repositories and at console type ( apt-get install envyng )

    I did the manual driver install, took a minute or two and it was done. Rebooted, all was well.

    Wireless does not work.

    Wired eth0 does not work. rmmod r8169 and then a modprobe r8169 reveals in the /var/log/messages that the driver does indeed load, but errors out with an Error -22. I assume that this driver is not correct. Proper googling on this particular issue reveals that the driver has not made it into 2.6.26 kernel but it is in the 2.6.27 kernel right now. I don't dare rebuild a kernel on Ubuntu.

    I'm going to load Gentoo on this to see if I can get 2.6.27 kernel on it and see what happens, i'll report back with my findings. If anyone else has anything to offer on this subject, please post your findings and what exact model you have.

    Thanks!

    EDIT: Update. Loaded Gentoo 2008.1 on it and with 2.6.24 kernel on the minimal isntall disc, it found the wired ethernet port just fine. Hrmm
    Last edited by cfaulkner; September 16th, 2008 at 05:24 PM. Reason: Updated info
    Gigabyte M57SLI-S4 Mobo (nForce 570)
    AMD Athlon64 X2 AM2 3800+ Windsor Dual-Core
    eVGA nVidia 7600GT 256mb x1 (No SLI)
    20" Starlogic WS LCD (1680x1050) - 19" Starlogic LCD (1280x1024)

  2. #2
    Join Date
    Oct 2006
    Location
    Nashville, TN
    Beans
    62
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Ubuntu and ASUS M50 version notebooks

    Ok, Tried to load Gentoo 2008.1 but it seems the ethernet comes and goes as it pleases. Had a little problem trying to load it so i'm going to try a few new things shortly.
    Gigabyte M57SLI-S4 Mobo (nForce 570)
    AMD Athlon64 X2 AM2 3800+ Windsor Dual-Core
    eVGA nVidia 7600GT 256mb x1 (No SLI)
    20" Starlogic WS LCD (1680x1050) - 19" Starlogic LCD (1280x1024)

  3. #3
    Join Date
    Sep 2008
    Beans
    1

    Re: Ubuntu and ASUS M50 version notebooks

    Hi! I am running Intrepid Beta on a M50Vm-B2 and I can confirm that wireless does indeed work with the 2.6.27 kernel. However, you will probably have to delete a file in /etc/acpi/start.d called something like '60-asuswirelessled.sh' as it causes the hardware RF kill switch to be permanently engaged.

    Everything works well for me except I am having a strange problem with the DVD-ROM drive 'hanging' and becoming unreachable, for example while trying to burn .iso files or trying to install ubuntu from cd. Sometimes it will work and sometimes not, and it is NOT a burn quality issue.

    Would be interested to know if you or anyone else has run into this issue, I am currently investigating it...

  4. #4
    Join Date
    Apr 2007
    Beans
    2

    Re: Ubuntu and ASUS M50 version notebooks

    Quote Originally Posted by cat bar View Post
    Hi! I am running Intrepid Beta on a M50Vm-B2 and I can confirm that wireless does indeed work with the 2.6.27 kernel. However, you will probably have to delete a file in /etc/acpi/start.d called something like '60-asuswirelessled.sh' as it causes the hardware RF kill switch to be permanently engaged.

    Everything works well for me except I am having a strange problem with the DVD-ROM drive 'hanging' and becoming unreachable, for example while trying to burn .iso files or trying to install ubuntu from cd. Sometimes it will work and sometimes not, and it is NOT a burn quality issue.

    Would be interested to know if you or anyone else has run into this issue, I am currently investigating it...
    About your DVD-Rom drive, it works for me : There is an option for the drive in the Bios (F2 at the startup), you must change it from "Enhanced" to "Compatible" and there won't be any problem from now

  5. #5
    Join Date
    Oct 2008
    Location
    France
    Beans
    12
    Distro
    Ubuntu Intrepid Ibex (testing)

    Re: Ubuntu and ASUS M50 version notebooks

    I'm experiencing this problem with my DVD on M50VM AS010C
    The otpion of bios switch SATA to IDE mode for both drives (hard disk and dvd rom). This worry me for hard disk.
    Any other fix for this bug?


    Thanks

  6. #6
    Join Date
    May 2006
    Beans
    6

    Re: Ubuntu and ASUS M50 version notebooks

    Are there bug reports about the wireless and dvd issues ?

    Thanks

  7. #7
    Join Date
    Oct 2008
    Location
    France
    Beans
    12
    Distro
    Ubuntu Intrepid Ibex (testing)

    Re: Ubuntu and ASUS M50 version notebooks

    I've made a bug report for dvd issue

    https://bugs.launchpad.net/ubuntu/+bug/289261

    gilles

  8. #8
    Join Date
    Nov 2006
    Beans
    49
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Ubuntu and ASUS M50 version notebooks

    does anyone have any updates on these issues now that intrepid has come out? i'm very much considering picking up one of these, despite the glossy screen.

  9. #9
    Join Date
    Jul 2008
    Beans
    24

    Re: Ubuntu and ASUS M50 version notebooks

    Basic functions work well. My M50VM's intel 5100 wifi works out of the box, light sensor also seems to work. The fingerprint sensor should work with fprint, but some people have advised against it so I haven't tried it. Also the "dual mode" thingie on the touchpad doesn't work

  10. #10
    Join Date
    Nov 2006
    Location
    New Zealand
    Beans
    6
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Ubuntu and ASUS M50 version notebooks

    RaZe42, are you able to give us the full model number of your M50VM? I'm looking at getting an M50VM-AS001G, but I was worried when I googled around before Intrepid's release by reports of the wireless not being supported. Is anybody able to shed some light on whether the M50VM-AS001G is any good under Intrepid?

    Cheers,
    Max

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •