Results 1 to 8 of 8

Thread: [SOLVED] Switching Thai to English Using Grave Accent Key (`)

  1. #1
    Join Date
    Sep 2008
    Location
    Phichit, Thailand
    Beans
    21
    Distro
    Ubuntu 8.04 Hardy Heron

    Lightbulb [SOLVED] Switching Thai to English Using Grave Accent Key (`)

    First off, I'm dreadfully new to Ubuntu, and to these forums, so forgive me if I faux pas a bit.

    I am interested in figuring how to toggle a language switch for the keyboard, in my case between Thai and English, using the grave accent key (`) that is in the upper left hand of the keyboard. There was a post about it some 2 years ago, but the issue never seems to have been resolved, and I can't reopen the old post.

    The post was titled "Would like to use Grave accent ( ` ) changing language " and here is the link:
    http://ubuntuforums.org/showthread.p...=keyboard+thai

    I tried to find a more effective way to refer to the last post, but I couldn't.

    I have successfully installed the Thai language support, and have found that there are a number of options for language toggling, involving the windows key, alt, control, shift, etc. However, I am trying to get Ubuntu to behave as much like Windows does as possible (otherwise I fear I will have a hard time convincing my coworkers to switch over), hence the interest in binding the specific key for language switching.

    Is this possible? I'd be willing to go through a little work to make the switch, but my skill set doesn't really go beyond copying and pasting a command into the terminal.

    Thanks

  2. #2
    Join Date
    Jul 2008
    Location
    $HOME
    Beans
    1,030
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Switching Thai to English Using Grave Accent Key (`)

    I use SCIM for complex-script support (e.g. Chinese). By default, Ctrl-` turns it on and off.

    As for simply changing between keyboard layouts, I can't find a way of making GNOME use the grave key. It offers a large range of possible shortcuts, but that's not one of them.
    If people were nicer, I'd answer more queries here!

  3. #3
    Join Date
    Sep 2008
    Location
    Phichit, Thailand
    Beans
    21
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Switching Thai to English Using Grave Accent Key (`)

    I appreciate your taking the time to get back to me. I'm now having a bit of trouble with SCIM (as in the languages don't really seem to switch anymore), so I think I need to do a bit of digging/exploring to see if I can figure out. Wish me luck.

  4. #4
    Join Date
    Sep 2008
    Beans
    3

    Re: Switching Thai to English Using Grave Accent Key (`)

    I want to use grave accent too.
    I have ever use previous version of Ubuntu(I can't remember version) It can use grave accent to change layout.

    Why I can't use grave accent to switch layout in 8.04LTS.

    Who know how to use patch or any other way to use grave
    PLEASE HELP ME!

  5. #5
    Join Date
    Sep 2008
    Location
    Phichit, Thailand
    Beans
    21
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Switching Thai to English Using Grave Accent Key (`)

    Something I came across while trying to solve another problem on another thread (http://ubuntuforums.org/showthread.php?t=920227) might be useful here. Is there a way you can change the /etc/X11/xorg.conf to do this? I'm thinking specifically the line like this:

    Option "XkbOptions" "grp:alt_shift_toggle"

    Which I assumed could be changed to "grp:grave_toggle." But that hasn't worked, and in fact now I can't run the gksu gpedit /etc/X11/xorg.conf to change anything back. But that's a different story. Is there a way this line can be changed to make that grave accent change happen?

  6. #6
    Join Date
    Sep 2008
    Location
    Phichit, Thailand
    Beans
    21
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Switching Thai to English Using Grave Accent Key (`)

    Alright,

    I figured out that if I "gksu gedit /etc/X11/xorg.conf" and add the following line:

    Option "XkbVariant" "winkeys"

    before the "XkbOptions" line, then I can change the "XkbOptions" line to:

    Option "XkbOptions" "lwin_toggle"

    And the left windows key will toggle between the languages. Without the "XkbVariant" "winkeys" line the "lwin_toggle" does nothing. So that says to me there's got to be a variant or some such that can be input to allow the grave accent key to do the language switching, as visarute and I (and I think, almost every Ubuntu user in Thailand) wants. I've been trying to find the relevant information in some Xkb Configuration Guides online, but its a bit over my head.

    Any suggestions?

  7. #7
    Join Date
    Sep 2008
    Location
    Phichit, Thailand
    Beans
    21
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Switching Thai to English Using Grave Accent Key (`)

    Figured it out, with the help of a Linux guy here in Thailand. There's a Debian Package available on the OpenTLE website which adds a "Grave Changes Group" checkbox to the "Layout Options" window off the "Layouts" tab of the "Keyboard Preferences." Here's the link:

    http://www.opentle.org/node/4944

    The text is all in Thai, but the download is available right at the top after the words "Download Package." Then the steps to take (which are pretty intuitive anyways) are laid out in picture format. The one thing I'm unclear on is whether it is necessary to alter your xorg.conf file as well as toggling the "Grave Changes Group" checkbox. I altered just the xorg.conf file first and it didn't work, but after I made the change on the Layout Options screen, the change appears to be permanent. I do assume the change to the xorg.conf file is necessary as it is written in at the bottom of the instructions. But I don't read Thai very well, so I'm not sure.
    Last edited by lorenbr; September 22nd, 2008 at 03:17 AM.

  8. #8
    Join Date
    Sep 2008
    Beans
    3

    Talking Re: [SOLVED] Switching Thai to English Using Grave Accent Key (`)

    Yeah!

    I gonna install Ubuntu again after delete it all after I can't find the way to use grave(`) to switch language.

    I hope it gonna work!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •