Results 1 to 6 of 6

Thread: development of c language

  1. #1
    Join Date
    Sep 2008
    Beans
    3

    development of c language

    Hi there . I am new at the linux community. So, here is a silly question.
    They asked me to built a server but the programmer told me to pay attention that the development of c language is below 4 (my english are pure, but i hope you understand what i am talking about)
    So here is my question
    Which version of ubuntu, shall i install ?
    or ?
    How i can find out which version is the development i am using , eg in my desktop
    Thanks in advance

  2. #2
    Join Date
    Jan 2008
    Location
    Auckland, New Zealand
    Beans
    3,134
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: development of c language

    Sorry I'm not quite sure what you mean. Do you mean what version of the GNU C Library are you using?

    If you are using Ubuntu 8.04 then this is libc6 version 2.7-10ubuntu3 (Version 6)

    To find that out I searched for the libc package and then looked at the version of libc6.

  3. #3
    Join Date
    Sep 2008
    Beans
    3

    Re: development of c language

    Quote Originally Posted by ad_267 View Post
    Sorry I'm not quite sure what you mean. Do you mean what version of the GNU C Library are you using?

    If you are using Ubuntu 8.04 then this is libc6 version 2.7-10ubuntu3 (Version 6)

    To find that out I searched for the libc package and then looked at the version of libc6.

    Thank you for your answer. I asked him again and told me again "the development of c language "
    I guess it is about GNU C Library
    So, if i want to use an elder version of it ,shall i install a previous version of ubuntu, ? (dapper for instance )

  4. #4
    Join Date
    Jan 2006
    Location
    Granada, Spain
    Beans
    224
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: development of c language

    I think you mean the C compiler, right?

    Ubuntu AFAIK comes with version 4, but you can install version 3.3 afterwards (search for gcc-3.3 in Synaptic).

    Cheers,
    Benedikt Bär - www.relamp.tk
    WARNING: Some commands can be harmful when executed, especially the ones starting with "rm". If you are in doubt what a certain command will do, please ask other members first before executing!

  5. #5
    Join Date
    Sep 2008
    Beans
    3

    Re: development of c language

    I wish i new for sure, but it dont think it can be something else
    Do i have to remove the version 4. before installing version 3 ?
    And not in synaptic , of course, because it is a sever install
    apt get-remove ..... and so on ..
    Thank you

  6. #6
    Join Date
    Jan 2006
    Location
    Granada, Spain
    Beans
    224
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: development of c language

    Quote Originally Posted by dimi911 View Post
    I wish i new for sure, but it dont think it can be something else
    Do i have to remove the version 4. before installing version 3 ?
    And not in synaptic , of course, because it is a sever install
    apt get-remove ..... and so on ..
    Thank you
    No, you can have both. And yes, it would be apt-get install <package name>, of course

    Cheers,
    Benedikt Bär - www.relamp.tk
    WARNING: Some commands can be harmful when executed, especially the ones starting with "rm". If you are in doubt what a certain command will do, please ask other members first before executing!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •