Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Using server to play video onto TV (yes, i know it's a strange setup)

  1. #1
    Join Date
    Jun 2008
    Beans
    81

    Smile Using server to play video onto TV (yes, i know it's a strange setup)

    I am running ubuntu server as a fileserver in my room. I use a standard resolution TV as a monitor (with hardware RCA output, which is pretty neat).

    That aside, since my server is connected to a TV I thought it would be cool to be able to play the videos on it through the TV, and so I have two questions:

    1. How to i install and configure MPlayer (noGUI)?

    2. How do I get sound to work?

    I havent changed any resolution settings.

    thanks

  2. #2
    Join Date
    May 2007
    Location
    Phoenix, Arizona USA
    Beans
    2,909
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Using server to play video onto TV (yes, i know it's a strange setup)

    www.pcchopshop.net

    Hard to find and obsolete PC and server parts. "If we can't find it, it probably doesn't exist"

  3. #3
    Join Date
    Jun 2008
    Beans
    81

    Re: Using server to play video onto TV (yes, i know it's a strange setup)

    ok cool

    i added vga=786 at the end of the kernel line in the /boot/grub/menu.lst

    how do i get video to scale itself full screen?

    Code:
    mplayer -vo fbdev -fs -vf scale=640:-3 FileName
    didn't do it

    also, how do i install codecs?

    and more importantly, how do i get sound to work?
    Last edited by markdavidoff; August 31st, 2008 at 11:25 AM.

  4. #4
    Join Date
    May 2007
    Location
    Phoenix, Arizona USA
    Beans
    2,909
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Using server to play video onto TV (yes, i know it's a strange setup)

    For the codecs and to play DVDs:

    Code:
    sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list
    
    sudo apt-get update && sudo apt-get install medibuntu-keyring && sudo apt-get update
    
    
    sudo apt-get install vlc libdvdcss2 ubuntu-restricted-extras w32codecs
    For sound, hmmmm.. you could try installing PulseAudio if it's in the repositories, I'm not sure. This may help:

    https://wiki.ubuntu.com/PulseAudio

    As for full screen, I don't have clue as I don't run anything GUI from any of my servers but your situation is different of course. Maybe someone out there has an idea.

    -Tim
    Last edited by windependence; August 31st, 2008 at 01:29 PM.
    www.pcchopshop.net

    Hard to find and obsolete PC and server parts. "If we can't find it, it probably doesn't exist"

  5. #5
    Join Date
    Jun 2008
    Beans
    81

    Re: Using server to play video onto TV (yes, i know it's a strange setup)

    medibuntu-keyring and w32codecs couldn't be found. I think there is a problem with that source file you directed me to.

    and i had to install ubuntu-restricted-extras and libdvdcss2 separately (each on its own apt-get install command) for some reason.

    Pulse Audio wasn't the answer - installing alsa works fine:

    first, i installed ALSA and alsa-utils:

    Code:
    sudo apt-get install alsa alsa-utils
    then i ran alsamixer and played around with the settings until i got sound output (tested using aplay <sound file>) and speaker-test (see http://alsa.opensrc.org/index.php/Speaker-test )

    I then modified a MPlayer config file i found on the net as follows:

    Code:
    #General setup
    
    ao="alsa" #audio out
    mixer-channel="Master"
    srate=48000
    
    vo="fbdev" #video out
    aid="1" #audio channel
    sid="0" #subtitle set
    
    fs=yes #Play Videos Full-Screen
    zoom="1" #Allow sofware scaling if I use x11 for vo
    monitoraspect="4:3" # Set to "16:9" for widescreen
    vf="scale=640:-3" #Scales the video, and keeps the video's aspect ratio. Change "640" to your screen's resolution width
    
    #Display
    
    #double="yes" #double buffering(recommended for subtitles)
    framedrop="1" # For slow machines
    hardframedrop="0" #Make sure hard frame drop is off but can turn on easily now
    
    #This sets the postprocessing into overdrive using all possible spare cpu cycles to make the movie look better
    #autoq=100
    #vf=pp=de,hqdn3d
    
    #Subtitles
    
    #Truetype fonts rock! (sudo apt-get msttcorefonts)
    #font=/usr/share/fonts/truetype/msttcorefonts/impact.ttf
    
    ffactor="10" #black outline
    sub-bg-alpha="0" #background color ala closed captions
    sub-bg-color="0" #black to white
    subfont-text-scale="3.7" #truetype font scaling
    subfont-blur="1" #Slight blur
    
    subpos="90" #By default subtitles are too low
    subalign="2"
    Last edited by markdavidoff; September 2nd, 2008 at 08:43 AM. Reason: Fixed scaling issue

  6. #6
    Join Date
    Jun 2008
    Beans
    81

    Re: Using server to play video onto TV (yes, i know it's a strange setup)

    ok i got medibuntu-keyring and w32codecs to install (the server must have been down for a while yesterday)

    still can't get my movie to play though:
    I don't have a problem with most other videos, and I can play it with VLC (although it is rendered in coloured ASCII )

    Code:
    MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
    CPU: AMD Athlon(tm) XP 2600+ (Family: 6, Model: 10, Stepping: 0)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
    Compiled with runtime CPU detection.
    
    Playing 300.avi.
    AVI file format detected.
    [aviheader] Video stream found, -vid 0
    [aviheader] Audio stream found, -aid 1
    VIDEO:  [XVID]  720x576  12bpp  25.000 fps  998.0 kbps (121.8 kbyte/s)
    Clip info:
     Software: MediaCoder 0.6
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
    ==========================================================================
    ==========================================================================
    Forced audio codec: mad
    Opening audio decoder: [libmad] libmad mpeg audio decoder
    AUDIO: 48000 Hz, 2 ch, s16le, 32.0 kbit/2.08% (ratio: 4000->192000)
    Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
    ==========================================================================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    SwScaler: reducing / aligning filtersize 5 -> 4
    SwScaler: reducing / aligning filtersize 5 -> 4
    SwScaler: reducing / aligning filtersize 1 -> 1
    SwScaler: reducing / aligning filtersize 5 -> 4
    [swscaler @ 0x886e8f0]SwScaler: BICUBIC scaler, from yuv420p to rgb32 using MMX2
    [swscaler @ 0x886e8f0]SwScaler: using 4-tap MMX scaler for horizontal luminance scaling
    [swscaler @ 0x886e8f0]SwScaler: using 4-tap MMX scaler for horizontal chrominance scaling
    [swscaler @ 0x886e8f0]SwScaler: using n-tap MMX scaler for vertical scaling (BGR)
    [swscaler @ 0x886e8f0]SwScaler: using MMX YV12->BGR32 Converter
    [swscaler @ 0x886e8f0]SwScaler: 720x576 -> 1024x576
    VO: [fbdev] 1024x576 => 1024x576 BGRA  [fs] [zoom]
    VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    VO: [fbdev] 1024x576 => 1024x576 BGRA  [fs] [zoom]
    FATAL: Could not initialize video filters (-vf) or video output (-vo).)
    Exiting... (End of file)
    Does anyone know how to get full-screen scaling to work?
    Last edited by markdavidoff; September 1st, 2008 at 10:34 AM.

  7. #7
    Join Date
    Jun 2008
    Beans
    81

    Re: Using server to play video onto TV (yes, i know it's a strange setup)

    Ok i figured out how to get full-screen scaling!

    in your mplayer config file (in /home/<user>/.mplayer)

    add/modify the following lines:

    Code:
    fs=yes #Play Videos Full-Screen
    zoom="1" #Allow sofware scaling if I use x11 for vo
    monitoraspect="4:3" # Set to "16:9" for widescreen
    vf="scale=640:-3" #Scales the video, and keeps the video's aspect ratio. Change "640" to your screen's resolution
    I changed the config file above to reflect these changes

    Still can't get the codec to work...unless it's a different problem.
    Last edited by markdavidoff; September 2nd, 2008 at 08:42 AM.

  8. #8
    Join Date
    Jun 2008
    Beans
    81

    Exclamation Re: Using server to play video onto TV (yes, i know it's a strange setup)

    *BUMP*

    Any help?

    I just need to get my video to play (missing codecs)

  9. #9
    Join Date
    Nov 2004
    Location
    Quebec
    Beans
    741
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Using server to play video onto TV (yes, i know it's a strange setup)

    i get fullscreen but really not sure how or why lol but here are the only 2 things different in out config..

    vga=0x0314 as boot option(for whatever reason vga=0x0317 won't work for me)
    and
    scale=800:-3 anything higher than 800 doesn't work for me

    no idea if this will help at all but i figured you wouldn't mind the bump

    EDIT: forgot to mention i have no config file in ~/.mplayer
    ~
    Desktop:ASRock P4i65GV/P4 2.8ghz 2gbram
    Laptop:Toshiba L350-PSLD8C Centrino64 dualcore 2ghz 4gbram

  10. #10
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Using server to play video onto TV (yes, i know it's a strange setup)

    To make sure you got all the codecs needed install the ubuntu-restricted extras meta package.

    Code:
    sudo aptitude install ubuntu-restricted-extras
    Jim

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •