Results 1 to 5 of 5

Thread: "kvm: disabled by bios" despite /proc/cpuinfo showing vmx flag

  1. #1
    Join Date
    Sep 2007
    Beans
    5

    "kvm: disabled by bios" despite /proc/cpuinfo showing vmx flag

    Hello!

    I'm attempting to set up kvm, and despite having virtualization enabled in my bios, I cannot load the kvm-intel kernel module. In the rest of my forum searching, I've only found people who have not turned on virtualization receiving this error, which is not my case. I'm not sure how to proceed on this one.

    Kernel uname -a:
    Linux epiphyte 2.6.24.19-generic #1 SMP Wed Aug 20 17:53:40 UTC 2008 x86_64 GNU/Linux

    Dmesg error line:
    [ 34.727695] kvm: disabled by bios

    I am attaching the output of 'cat /proc/cpuinfo' as well as the full dmesg output.

    Preemptive thanks!

    --Lim
    Attached Files Attached Files

  2. #2
    Join Date
    Sep 2007
    Location
    Pune, India
    Beans
    445
    Distro
    Kubuntu Development Release

    Re: "kvm: disabled by bios" despite /proc/cpuinfo showing vmx flag

    if you just now enabled it in the bios i think you have to shut down completely and power off, then restart, (cold boot) only then the change works.

    plus, you might need to add yourself to the kvm and/or libvirt groups (i forget the actual group name but you can search around)... HTH
    Desktop: Unbranded, Q6600 2.4 ghz CPU, Intel DP35DP mobo, 4 GB RAM, 500 GB HDD, 128 GB SSD, NVIDIA 8800GT, Dell E248WFP LCD.
    Laptop: HP Pavilion tx1302au Turion64 X2 TL-58 1.9 ghz CPU, NVIDIA GeForce Go 6150, 2 GB RAM, 64 GB SSD, Broadcom 4321 Wifi.

  3. #3
    Join Date
    Sep 2007
    Beans
    5

    Re: "kvm: disabled by bios" despite /proc/cpuinfo showing vmx flag

    Quote Originally Posted by vishalrao View Post
    if you just now enabled it in the bios i think you have to shut down completely and power off, then restart, (cold boot) only then the change works.

    plus, you might need to add yourself to the kvm and/or libvirt groups (i forget the actual group name but you can search around)... HTH
    Oh, forgot to mention I saw those things suggested during my search for more info, I restarted the machine several times (in the course of messing with it), and also added myself to the 'libvirtd' group.

  4. #4
    Join Date
    Sep 2007
    Beans
    5

    Re: "kvm: disabled by bios" despite /proc/cpuinfo showing vmx flag

    Now I'm thinking that despite the flag being reported in /proc/cpuinfo, the bios still has the VMX extension disabled.

    Since the damn bios doesn't support turning it on, I guess I'm going to have to hunt for the bit to flip manually. I hate Sony. I'll report here if I find it.

  5. #5
    Join Date
    Jan 2009
    Beans
    61

    Angry Re: "kvm: disabled by bios" despite /proc/cpuinfo showing vmx flag

    Sony, on many notebooks, including my Vaio SZ, have disabled ACPI and the VT-x extensions even though the Intel chips support these. Even when the system reports it, it cannot use it. This also applies to NCQ on SATA controllers on some Sony Vaio's as I have found out.


    There are some threads on a forum somewhere about how to manually flip the bit to enable this and it has been successful on many notebooks.

    My advise it not to buy Sony notebooks, and I offer this advise to myself
    Thank-you Sony.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •