Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: CPU frequency at 1.2Ghz for a 2.0 Core 2 Duo CPU.

  1. #11
    Join Date
    Aug 2008
    Beans
    50

    Re: CPU frequency at 1.2Ghz for a 2.0 Core 2 Duo CPU.

    Figures, you appear to be using a 'userspace' governor. In other words there is an application installed at your setup which controls the cpu speed, as opposed to the more usual 'ondemand' governor which is a stock kernel based governor. That application may have its own weird logic, f.e. capping the ceiling frequency when things get too hot.

    You either installed that userspace governor yourself or someone else did it for you, or your distribution uses it as default.

    The default 'ondemand' governor that Ubuntu uses does NOT cap ceiling frequency, I would know because I am using it in my Thinkpad with a Pentium M 2.0Ghz Banias CPU.

    In any case, it is useful to add the CPU Frequency Monitoring applet to a Gnome panel of your choice. Use the 'Add to panel..." panel context menu choice and find that applet, add it and it will not only show what frequency your CPU currently switches to, but also if you click on the applet it lets you change the governor and lock the CPU speed manually, for instance to 1.87Ghz.

    A governor is a program that decides and controls how to clock the CPU. Obviously different programs follow different logic.

    But maybe you know all this already?

    If you want to dig more, you can see what is contained in files in /sys/devices/system/cpu. Lots of info can be gathered from there, and in fact thats the interface everyone else uses in their software, as it is exported by the kernel and its modules.
    Last edited by amn108; March 26th, 2009 at 09:47 PM.

  2. #12
    Join Date
    Oct 2007
    Location
    Gent, Belgium
    Beans
    65
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: CPU frequency at 1.2Ghz for a 2.0 Core 2 Duo CPU.

    My systems used the ondemand governor as default, but I changed it from performance to userspace while fiddling around with the settings. Ondemand is a nice governor, but if you are into wine gaming, you'll find that it sometimes makes the performance of the game choppy and stuttering, while that isn't so when setting the cpu to the maximum frequency regardless of its stresslevel.

    This maximum frequency "fallback" I first noticed when I changed from ondemand to performance. After a while of gaming at the maximum frequency and thus a high temperature, I noticed the clock going down slowly at the predefined steps. I then suspected the performance governor for interfering with the clockspeed, so I used userspace governor (to no avail, unfortunately) by putting this line in my /etc/rc.local file:
    echo userspace > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor && cpufreq-selector -f 1870000 || exit 1

    I should add I noticed the drop in clockspeed because I already had the cpufreq applet on my taskbar, along with a system monitor applet to monitor the cpu-load, so nothing new there.

    I know there are a lot of files listed in the directory you mention, but I never got around to checking every file while suffering from forced clockdown. I'll get back to it later when I think about it a the right moment.

    Thanks for trying to help me out anyway!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •