Page 4 of 44 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 433

Thread: HowTo: Speed up ubuntu boot process - the way you can feel it.

  1. #31
    Join Date
    Nov 2004
    Beans
    177
    Distro
    Dapper Drake

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    Quote Originally Posted by GoldBuggie
    Really nice guide...I love the tool you recommended to use. I used the tool BUM(boot-up-mgr) before but I can't turn everything off and it isn't nearly as flexible. Thank you.

    About readahead...the project is called readahead-list and it preloads files into the page cache to accelerate program loading. The files it caches are stored in /etc/readahead/readahead.

    Maybe experimenting with it can make firefox load faster hmmm...something to check into for me I think.

    Anyway...thx again for a nicely written guide. I like it cause it tweaks the existing system to your needs instead of replacing it with something new.
    Yes, the readahead thing is something that I am not sure. I didn't feel a whole lot faster though by stopping or starting it... so I am not sure if it really that promising...

  2. #32
    manicka Guest

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    I have added this how-to to the Ubuntu Document Storage Facility

    http://doc.gwos.org/index.php/Speed_up_boot

  3. #33
    Join Date
    Nov 2004
    Beans
    177
    Distro
    Dapper Drake

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    Quote Originally Posted by manicka
    I have added this how-to to the Ubuntu Document Storage Facility

    http://doc.gwos.org/index.php/Speed_up_boot
    Thank you very much sir!

  4. #34
    Join Date
    Jun 2005
    Beans
    89

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    I made the suggested changes and it gave an error , unable to start halt, so I went bacjk and enable it and when rebooted happens that the process starts ok but after passing the part of "loading extra binaries" in the splash boot the computers goes off all the time. Bottom line is I cannot acces the ubuntu box anymore, any thoughs in how to rollback someway?
    ________________________________

    We know Major Tom's a junkie ...

  5. #35
    Join Date
    Nov 2004
    Beans
    177
    Distro
    Dapper Drake

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    Quote Originally Posted by crispingatiesa
    I made the suggested changes and it gave an error , unable to start halt, so I went bacjk and enable it and when rebooted happens that the process starts ok but after passing the part of "loading extra binaries" in the splash boot the computers goes off all the time. Bottom line is I cannot acces the ubuntu box anymore, any thoughs in how to rollback someway?
    Ok, sounds like you enabled halt on all runlevels. The halt service can only be enabled at runlevel 0 which is to shutdown the computer. You can use Live CD to change it back but let's try to boot to single mode first. When you see the grub menu, hit "e" to edit the default boot line. After you hit "e", you will see the detail boot options. Go to the kernel line and hit "e" again, then you can edit the kernel options, at the end of the line, input "single", then "enter", after that hit "b" to boot. If you can boot to the single mode, then try to run sysv-rc-conf again to change the halt to only start at runlevel "0". Let me know if this works or not.
    Linux user #392733
    -------------------------------------
    You want to know what a computer really is, try Linux!

  6. #36
    Join Date
    Oct 2005
    Location
    Southeast Asia
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    This was a good how-to and I'm sure it works for a lot of folks. But this is the only how-to I have gone through that actually broke gnome. Granted that it was partially my fault for not taking screenshots noting of all the runlevels I changed, it still should have been stated in the how-to about totally screwing up my perfect ubuntu install.

    Now I'm stuck with this windows OS till I this ^%&% fixed. So damn frustrating. I thought I would safe at least 20 seconds of boot time, but ended up trying to fix what's broken for 5 damn hours.

    Now to my problem, I back stepped the how-to and renamed all the k* back to K*, uncommitted this lines in the inittab file. The only thing I could not fix was the runlevel. I can boot all the way to gnome but the splash screen does not show and neither does the desktop. Only the brown Ubuntu background and the cursor. How do I set the runlevel back to default?

  7. #37
    Join Date
    Nov 2004
    Beans
    177
    Distro
    Dapper Drake

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    Quote Originally Posted by domino
    This was a good how-to and I'm sure it works for a lot of folks. But this is the only how-to I have gone through that actually broke gnome. Granted that it was partially my fault for not taking screenshots noting of all the runlevels I changed, it still should have been stated in the how-to about totally screwing up my perfect ubuntu install.

    Now I'm stuck with this windows OS till I this ^%&% fixed. So damn frustrating. I thought I would safe at least 20 seconds of boot time, but ended up trying to fix what's broken for 5 damn hours.

    Now to my problem, I back stepped the how-to and renamed all the k* back to K*, uncommitted this lines in the inittab file. The only thing I could not fix was the runlevel. I can boot all the way to gnome but the splash screen does not show and neither does the desktop. Only the brown Ubuntu background and the cursor. How do I set the runlevel back to default?
    Sorry to hear that your box was broken by tuning the boot process. I want to help you out to get it back. I am sure there must have some misconfigurations in the runlevels. Ok, your default GUI runlevel should be at 2. So check your xorg-common service and make sure its up at runlevel 2. Also, check to make sure your /home/yourname dir is not residing in any lvm or raid devices cause in my HowTo, those services were turned off since I don't use them, but it might be a different case in your situation. If you didn't backup your /etc dir, its hard now to back step to the original status. Post your problems here and I will try to help out as much as I can. And I can tell you that this can be fixed.
    Linux user #392733
    -------------------------------------
    You want to know what a computer really is, try Linux!

  8. #38
    Join Date
    Oct 2005
    Location
    Southeast Asia
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    I'm able to boot straight into user land by fallowing this how-to:

    InitNG: http://ubuntuforums.org/showthread.p...t=boot+process

    Before that, I could only boot into root land via "recovery mode". I added InitNG to my boot menu. I still have the original boot options though. I'm having a lot of other issues with InitNG, more than I'd like to dedicate my time on. So, I just want to get my runlevels back to where they were and boot into user land as before.

    Sorry to hear that your box was broken by tuning the boot process.
    My luck had to run out sooner or later.

    Ok, your default GUI runlevel should be at 2. So check your xorg-common service and make sure its up at runlevel 2.
    My xorg-common service is set to S. I'll change to 2 and reboot. I'll post back with what ever happens.

    Also, check to make sure your /home/yourname dir is not residing in any lvm or raid devices cause in my HowTo, those services were turned off since I don't use them, but it might be a different case in your situation.
    My home dir is still where it is at. I don't have raid or lvm set up.

    If you didn't backup your /etc dir, its hard now to back step to the original status. And I can tell you that this can be fixed.
    That's the first thing I would have done had I known . I know better now.

    If there is any information I can provide, let me know.

  9. #39
    Join Date
    Oct 2005
    Location
    Southeast Asia
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    After setting xorg-common service from S to 2, I still couldn't get into user destop. Still stuck at the brown background with only a pointer. I know most of the names I had changed runlevels on. Is there a list of default runlevels? Or does it vary between boxes on evry fresh install?

    acpid
    alsa / alsa-utils
    apmd
    bluez-util
    cupsys
    dbus
    dns-clean
    evms
    fetchmail
    hotkey-se$
    hotplug / hotplug-n$
    hplip
    lvm
    mdadm / mdadm-raid
    pcmcia
    powernowd
    ppp / pppd-dns
    readahead
    rsync
    xorg-common (was set to S, but I never touched it)

  10. #40
    Join Date
    Nov 2004
    Beans
    177
    Distro
    Dapper Drake

    Re: HowTo: Speed up ubuntu boot process - the way you can feel it.

    Quote Originally Posted by domino
    After setting xorg-common service from S to 2, I still couldn't get into user destop. Still stuck at the brown background with only a pointer. I know most of the names I had changed runlevels on. Is there a list of default runlevels? Or does it vary between boxes on evry fresh install?

    acpid
    alsa / alsa-utils
    apmd
    bluez-util
    cupsys
    dbus
    dns-clean
    evms
    fetchmail
    hotkey-se$
    hotplug / hotplug-n$
    hplip
    lvm
    mdadm / mdadm-raid
    pcmcia
    powernowd
    ppp / pppd-dns
    readahead
    rsync
    xorg-common (was set to S, but I never touched it)
    xorg-common turned on at runlevel S is fine. I just want to make sure its there. Also, turn on your favorite logon manger, either GDM or KDM, so that you can go directly to GUI. I don't see you cron daemon there, its bad to turn that off. I don't see any of your log daemons on, such as bootlogd, sysklogd, etc. If you don't have lvm and raid at all, no need to leave lvm and mdadm/mdadm-raid on. I don't see udev/udev-mtab on, that's not good. I don't see vbesave on. Please look carefully and make sure.
    Linux user #392733
    -------------------------------------
    You want to know what a computer really is, try Linux!

Page 4 of 44 FirstFirst ... 2345614 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •