Results 1 to 4 of 4

Thread: how do you downgrade libraries? (specifically qt libraries)

  1. #1
    Join Date
    Aug 2008
    Beans
    4

    how do you downgrade libraries? (specifically qt libraries)

    Not sure if this is the right category to post this problem, sorry if it's not!

    I had hardy-backports checked in hardy, and i must have installed the newest version of the qt libraries (4.4) without being aware of it. This has caused some problems for me (primarily with skype video), so I'd like to downgrade to 4.3.4 (see http://ubuntuforums.org/showthread.php?t=795676 for why). The only way i can think of doing this is uninstalling them, unchecking backports, reloading, then installing the old version. the only problem is there are a lot of qtlib packages and I'm not sure which ones to uninstall. can anyone help?

    also, is there any easier way to downgrade?

    thanks!
    Shawna
    Last edited by shein; August 19th, 2008 at 03:13 AM.

  2. #2
    Join Date
    Jan 2007
    Location
    Melbourne, Australia
    Beans
    5,096

    Re: how do you downgrade libraries? (specifically qt libraries)

    Can you force an earlier version in synaptic? Open synaptic and search for the qt package you want to downgrade then highlight it and select "Package" then "force version" then choose the version you want to use.
    Ubuntu Newbie Help: irc: #beginners-help on network irc.freenode.net
    Help others, mark your threads solved.

  3. #3
    Join Date
    Aug 2008
    Beans
    4

    Re: how do you downgrade libraries? (specifically qt libraries)

    thanks, it looks like i can choose that option for libqt4-core, but when i try to do it it gives me this error:

    E: /var/cache/apt/archives/libqt4-core_4.3.4-0ubuntu3_i386.deb: trying to overwrite `/usr/share/qt4/translations/qt_ar.qm', which is also in package libqtcore4

    I figured this might mean i need to downgrade libqtcore4 as well, but when i look at that the "Force version" option is greyed out.

  4. #4
    Join Date
    Aug 2008
    Beans
    4

    Re: how do you downgrade libraries? (specifically qt libraries)

    oh also i tried the force version for libqt4-gui, and it says a bunch of packages need to be removed including kdebase-runtime as well as others...

    is this ok? (sorry if this is a dumb thing to ask, just dont want to mess up my entire windows manager)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •