Results 1 to 3 of 3

Thread: Keyboard Layout Switching

  1. #1
    Join Date
    May 2008
    Beans
    43
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Keyboard Layout Switching

    The keyboard shortcut for switching my keyboard layout isn't working. It is supposed to be switching from Englgish to Russian but it stays in English no matter what I do.
    Viva la Vida

  2. #2
    Join Date
    Jul 2006
    Location
    Sweden
    Beans
    34
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Keyboard Layout Switching

    Yeah, it's broken I believe. I had the same problem and a bunch of other ones after "upgrading" to hardy, and I've seen other people commenting as well.

    If you know what xorg.conf is you could try editing it.
    If you don't I strongly suggest you don't, because it's easy to mess things up.

    If you do, look for a section like this one:

    Code:
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    and change XkbLayout from "us" to "ru" or add it if you don't have it.

    And always remember to backup xorg.conf no matter how small changes you make

  3. #3
    Join Date
    Jul 2008
    Location
    United States
    Beans
    138
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Keyboard Layout Switching

    as a little added measure, you may need to change the value of

    Option "XkbVariant" "some_value_here"

    if it still doesn't work properly after modifying xkblayout
    The best way to predict the future is to invent it ~ Alan Kay

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •