Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: PC will shutdown but won't power off

  1. #1
    Join Date
    Feb 2007
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    PC will shutdown but won't power off

    Hi,

    I have this Pentium 4 800 MHz running Xubuntu 8.04 (Fully updated as of 8-8-2008) that - when told to shutdown - does the shutdown stuff and then freezes in the shutdown graphic screen (you know, the same one you see when starting up).

    Then I hear a click; I THINK the hard drive is shutting down. But the fans keep blowing and the screen keeps showing. Back when it was running XP, it did power off, so I know it's got the proper hardware for that.

    Also, sometimes (looks random to me) when told to shutdown, it partially reboots, showing me a 'what to do next' screen. Also sometimes, it just goes back to the login manager, as if I restarted X by ctrl+alt+backspace. In both cases, I disipline the computer by switching the power (at the back of the computer) off, because if I wanted to play games I wouldn't tell it to shut down.

    PS - I remember my P2 266MHz had the exact same problem a million years ago with Red Hat 5. It was fixed when I installed Xubuntu 6.
    Windows 7 for Media Production, Ubuntu 12.04/Cinnamon for other work.
    Xubuntu 12.04 as Media Center, CentOS 5.6 as server.
    Linux Mint on my casual laptop, Maemo 5 on my Nokia N900.

  2. #2
    Join Date
    Mar 2008
    Beans
    4,715
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: PC will shutdown but won't power off

    Redsandro, do you use any special kernel options to boot -- such as "acpi=off"? ACPI is usually in charge of powering off the machine, if for some reason ACPI is not working, there is a workaround, which is to use the apm module instead. (See below).

  3. #3
    Join Date
    Mar 2008
    Beans
    4,715
    Distro
    Ubuntu 9.10 Karmic Koala

    How to shutdown using apm instead of acpi


    1. Code:
      gksu gedit /etc/modules
      Add 'apm' to the bottom of the file. Save.
    2. Create the file /etc/modprobe.d/power:
      Code:
      gksu gedit /etc/modprobe.d/power
      Add the line
      Code:
      options apm power_off=1 realmode_power_off=1
      Save and quit.
    3. Now try booting again, but this time with kernel option "apm=on". (See below for how to boot with a kernel option)


    This information comes from: http://ubuntuforums.org/showthread.php?t=237264
    Last edited by unutbu; August 14th, 2008 at 02:50 PM.

  4. #4
    Join Date
    Mar 2008
    Beans
    4,715
    Distro
    Ubuntu 9.10 Karmic Koala

    How to boot with a kernel option

    There are two ways to boot with kernel options:
    • The temporary way:
      This method inserts the kernel boot option for only a single boot session. When you reboot, the kernel boot option will be gone. This is good for testing new options.
      1. When you power up the machine, first a BIOS or manufacturer's splash screen usually appears. Wait for that to disappear.
      2. The next screen is mostly black, with a bit of text in the upper left corner. This is a sign that GRUB has taken over the boot process. Press the escape (ESC) key. You usually have about 3 seconds to press the ESC key before GRUB decides to boot the default OS.
      3. You should now be at the GRUB menu. Each line of the GRUB menu represents a different OS to boot. Press 'e' to edit the boot options for a particular OS. (Use the up/down arrows to select the OS)
      4. You should now see something like this:
        Code:
        root		(hd0,2)
        kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=03a507ee-cdac-4bd9-b438-eccd616b66ed ro quiet splash
        initrd		/boot/initrd.img-2.6.22-14-generic
        Use the down arrow to select the line that begins with the word "kernel"
      5. Press 'e' to edit the kernel line
      6. Press End (or use the arrow keys) to move to the end of the kernel line.
      7. Type in the new kernel option, e.g. "apm=on", then press return. The new kernel line should now look like this:
        Code:
        kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=03a507ee-cdac-4bd9-b438-eccd616b66ed ro quiet splash apm=on
      8. Press 'b' to continue the boot process
    • The permanent way:
      This is the method to use once you are confident you want to use a particular boot option.
      1. Code:
        gksu gedit /boot/grub/menu.lst
        About 2/3 of the way down you'll see lines that look somewhat like this:
        Code:
        title		Ubuntu 7.10, kernel 2.6.22-14-generic
        root		(hd0,2)
        kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=03a507ee-cdac-4bd9-b438-eccd616b66ed ro 
        initrd		/boot/initrd.img-2.6.22-14-generic
        quiet
        Look familiar? Again go to the line which begins with the word "kernel", and add your kernel option (e.g. "apm=on") to the end of the line.
      2. Save and quit. The next time you boot the machine, the kernel option will be used.
    Last edited by unutbu; February 8th, 2009 at 05:24 PM.

  5. #5
    Join Date
    Aug 2008
    Location
    Madagascar
    Beans
    14
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: PC will shutdown but won't power off

    Quote Originally Posted by Redsandro View Post
    Hi,

    I have this Pentium 4 800 MHz running Xubuntu 8.04 (Fully updated as of 8-8-2008) that - when told to shutdown - does the shutdown stuff and then freezes in the shutdown graphic screen (you know, the same one you see when starting up).

    Then I hear a click; I THINK the hard drive is shutting down. But the fans keep blowing and the screen keeps showing. Back when it was running XP, it did power off, so I know it's got the proper hardware for that.

    Also, sometimes (looks random to me) when told to shutdown, it partially reboots, showing me a 'what to do next' screen. Also sometimes, it just goes back to the login manager, as if I restarted X by ctrl+alt+backspace. In both cases, I disipline the computer by switching the power (at the back of the computer) off, because if I wanted to play games I wouldn't tell it to shut down.

    PS - I remember my P2 266MHz had the exact same problem a million years ago with Red Hat 5. It was fixed when I installed Xubuntu 6.
    Just to say that I've the same problem SOMETIMES with my EEE PC (not exactly the same problem but it is analogue, I think).

    After shutting it down, my laptop won't power off. The fans keep blowing and the little light showing that it is plugged doesn't switch off (even if I've unplugged it and it runs on my battery). But the screen doesn't show anything else anymore. And if I try to switch on my computer it won't switch on (I have to reset it ).

    I've no idea where does the problem come from and how to fix it ?

  6. #6
    Join Date
    Feb 2007
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: PC will shutdown but won't power off

    Hey unutbu,

    Thanks for your extremely elaborate response. There was no need to be so explicit, but I appreciate you took the time!
    While checking the bootoptions, I rediscovered something and it's VERY stupid that I forgot about it! I manually added acpi=off some time ago after upgrading from Xubuntu 7 to 8 because the PC suffered random crashes (hangs) with it turned on. After that I went on a vacation and I totally forgot about it. I forgot about it so hard that I was sure I had no extra boot options applied and I didn't find it necessary to take a look.

    I've turned it back on, gonna let it run a few days to see if some update fixed the issue already. (I think not - I rarely see bugs that only affect older computers fixed.) If I catch it hanging again, I will switch to apm. You showed me how to do that - thanks!

    botokely, maybe you should check the above presented option to see if it works for you. I've seen an 10" EEE PC and it's something really cool. Could you tell me, how is it to run Linux off of it? I really love linux on my server and media center because it's really versatile. But to be honest, I've never seen any of my computers boot Ubuntu less than twice as slow as Win XP, and the one place I actually do care about boot times is on my laptop. So I ditched Ubuntu for XP on my laptop.
    Windows 7 for Media Production, Ubuntu 12.04/Cinnamon for other work.
    Xubuntu 12.04 as Media Center, CentOS 5.6 as server.
    Linux Mint on my casual laptop, Maemo 5 on my Nokia N900.

  7. #7
    Join Date
    Mar 2008
    Beans
    4,715
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: PC will shutdown but won't power off

    Hello Redsandro,
    Glad to hear you've got the problem pretty much solved. Sorry if my response was too much. Although I wanted to help you, I'm also getting tired of typing similar things over and over, so I'm now trying to post in a form that I hope will be reusable in the future.

  8. #8
    Join Date
    Feb 2007
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: PC will shutdown but won't power off

    Hi,

    That's actually a very good idea. There isn't really room for question (how do I ...) in your explenation so I bet is very reusable.

    I tried your method anyway because I had some more problems with APCI. Unfortunately I found that it didn't work (computers shuts down but doesn't power off) in this case. So back to APCI I have the problem that coming back from suspend-to-memory or suspend-to-ram leaves my monitor off even if I switch to a terminal. I can ssh to the computer from another one to tell it to reboot, and then it's okay.

    I tried adding SAVE_VBE_STATE=false and POST_VIDEO=false to /etc/default/acpi-support but no success.
    Last edited by Redsandro; August 15th, 2008 at 09:08 AM.
    Windows 7 for Media Production, Ubuntu 12.04/Cinnamon for other work.
    Xubuntu 12.04 as Media Center, CentOS 5.6 as server.
    Linux Mint on my casual laptop, Maemo 5 on my Nokia N900.

  9. #9
    Join Date
    Mar 2008
    Beans
    4,715
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: PC will shutdown but won't power off

    Hm. Sorry to hear it didn't work. It seems to work for some machines (http://ubuntuforums.org/showpost.php...4&postcount=20), but apparently not for others. Did you try "apm=on" alone or in conjunction: "acpi=off apm=on"?

    If neither work, then I'm out of ideas...

  10. #10
    Join Date
    Feb 2007
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: PC will shutdown but won't power off

    yes, I tried a bunch of them
    Code:
    acpi=off apm=on
    acpi=off apm=on noapic nolapic
    noapic nolapic
    acpi=on noapic nolapic
    etc. but no luck.

    Thanks for helping anyway! At the moment I've postponed solving this problem because after an update my sound is gone, and on a mediacenter that's even more crucial!

    I guess this just ain't my day on linux
    Windows 7 for Media Production, Ubuntu 12.04/Cinnamon for other work.
    Xubuntu 12.04 as Media Center, CentOS 5.6 as server.
    Linux Mint on my casual laptop, Maemo 5 on my Nokia N900.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •