Results 1 to 6 of 6

Thread: Grub Issue After Vista Install

  1. #1
    Join Date
    Feb 2008
    Beans
    17

    Grub Issue After Vista Install

    Ok, so I had ubuntu installed, and then i installed vista, no problem there.

    I restored the grub loader, and thought I modified the menu.lst correctly to put vista on the list. and it does in fact come up on the list.

    However, when I choose vista from the grub list the screen just flashes and it's still on the grub loader, and the only thing that works is booting to ubuntu...

    Code:
    title		Ubuntu 8.04.1, kernel 2.6.24-19-generic
    root		(hd0,0)
    kernel		/boot/vmlinuz-2.6.24-19-generic root=UUID=8675417c-d0c2-43b6-8ec8-2765da75eb64 ro quiet splash
    initrd		/boot/initrd.img-2.6.24-19-generic
    quiet
    
    title		Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
    root		(hd0,0)
    kernel		/boot/vmlinuz-2.6.24-19-generic root=UUID=8675417c-d0c2-43b6-8ec8-2765da75eb64 ro single
    initrd		/boot/initrd.img-2.6.24-19-generic
    
    title		Ubuntu 8.04.1, kernel 2.6.24-16-generic
    root		(hd0,0)
    kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=8675417c-d0c2-43b6-8ec8-2765da75eb64 ro quiet splash
    initrd		/boot/initrd.img-2.6.24-16-generic
    quiet
    
    title		Ubuntu 8.04.1, kernel 2.6.24-16-generic (recovery mode)
    root		(hd0,0)
    kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=8675417c-d0c2-43b6-8ec8-2765da75eb64 ro single
    initrd		/boot/initrd.img-2.6.24-16-generic
    
    title		Ubuntu 8.04.1, memtest86+
    root		(hd0,0)
    kernel		/boot/memtest86+.bin
    quiet
    
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    
    title		Windows Vista
    root		(hd0,3)
    makeactive
    chainloader+1
    and my partition list

    Code:
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1               1        9726    78124063+  83  Linux
    /dev/sda2            9727       10334     4883760   82  Linux swap / Solaris
    /dev/sda3   *       10335       19068    70154240+   b  W95 FAT32
    /dev/sda4           19068       36484   139892736    7  HPFS/NTFS
    Am I missing something somewhere?

  2. #2
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Grub Issue After Vista Install

    try

    root (0,2)
    maybe vista put it's boot files on the fat32 partition

  3. #3
    Join Date
    Feb 2008
    Beans
    17

    Re: Grub Issue After Vista Install

    Quote Originally Posted by logos34 View Post
    try



    maybe vista put it's boot files on the fat32 partition
    no dice, same thing

    no matter what i change it to it does the same thing, althoguh i didn't try changing it to 0 since I know that is where ubuntu is
    and changing it to 4 says no partition

  4. #4
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Grub Issue After Vista Install

    I see what it is now--typo:

    title Windows Vista
    root (hd0,3)
    makeactive
    chainloader+1
    Need a space--make it

    chainloader +1

  5. #5
    Join Date
    Feb 2008
    Beans
    17

    Re: Grub Issue After Vista Install

    that did it.

    thanks man

  6. #6
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •