Page 3 of 73 FirstFirst 123451353 ... LastLast
Results 21 to 30 of 723

Thread: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

  1. #21
    Join Date
    Jan 2006
    Location
    perth aust
    Beans
    24
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    what can i say this is awesome ...

  2. #22
    Join Date
    Aug 2006
    Beans
    15

    Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    d2g,

    below is the xorg.conf that gives me 3d on the left and middle via twinview, no 3d on the 3rd. all screens behaving like they should when you maximize, and xgl is disabled. this is as far as i managed to get it along before i had to duck out for the weekend. as far as the CRT bit, 2 of the monitors are using standard vga cables, not DVI. also i had a thought about this... could the issues be from the cards not being identical? or even possibly the motherboard? (intel BOXD975XBXLKR - link goes to newegg)

    thanks again

    --
    kai

    Code:
    Section "ServerLayout"
    	Identifier	"Layout0"
    	Screen		0  "Screen0" 0 0
    	Screen		1  "Screen1" RightOf "Screen0"
    	InputDevice	"Keyboard0" "CoreKeyboard"
    	InputDevice	"Mouse0" "CorePointer"
    	Option	   	"RenderAccel" "true"
    	Option 	   	"AllowGLXWithComposite" "true"
    EndSection
    
    Section "Files"
        RgbPath         "/etc/X11/rgb"
        FontPath	    "/usr/share/fonts/X11/misc"
        FontPath	    "/usr/share/fonts/X11/util"
        FontPath	    "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath	    "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath	    "/usr/share/fonts/X11/Type1"
        FontPath	    "/usr/share/fonts/X11/100dpi"
        FontPath	    "/usr/share/fonts/X11/75dpi"
        FontPath	    "/usr/share/fonts/X11/encodings"
        FontPath	    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
        FontPath	    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load            "dbe"
    	Load            "extmod"
    	Load            "type1"
    	Load            "freetype"
    	Load            "glx"
    #        Load		"dri"
    EndSection
    
    Section "ServerFlags"
    	Option         	"Xinerama" "1"
    EndSection
    
    
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       30.0 - 110.0
        VertRefresh     50.0 - 150.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       30.0 - 110.0
        VertRefresh     50.0 - 150.0
    #    Option         "DPMS"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor2"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       30.0 - 110.0
        VertRefresh     50.0 - 150.0
    #    Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     	"Videocard0"
        Driver        	"nvidia"
        VendorName     	"NVIDIA Corporation"
        BoardName      	"GeForce 8500 GT"
        BusID          	"PCI:1:0:0"
        Option 	   "AllowGLXWithComposite" "true"
        Option         "UseCompositeWrapper" "true"
        Option	   "XAANoOffscreenPixmaps"
        Option	   "NoLogo" "true"
        Option	   "backingstore" "true"
        Option         "TripleBuffer" "true"
        Option	   "AddARGBGLXVisuals"	"true"
        Screen         	0
    EndSection
    
    Section "Device"
        Identifier     	"Videocard1"
        Driver         	"nvidia"
        VendorName     	"NVIDIA Corporation"
        BoardName      	"GeForce 8500 GT"
        BusID          	"PCI:1:0:0"
        Option 	   "AllowGLXWithComposite" "true"
        Option         "UseCompositeWrapper" "true"
        Option	   "XAANoOffscreenPixmaps"
        Option	   "NoLogo" "true"
        Option	   "backingstore" "true"
        Option         "TripleBuffer" "true"
        Option	   "AddARGBGLXVisuals"	"true"
        Screen          	1
    EndSection
    
    Section "Device"
        Identifier     	"Videocard2"
        Driver         	"nvidia"
        VendorName     	"NVIDIA Corporation"
        BoardName      	"GeForce 7600 GT"
        BusID          	"PCI:2:0:0"
        Option 	   "AllowGLXWithComposite" "true"
        Option         "UseCompositeWrapper" "true"
        Option	   "XAANoOffscreenPixmaps"
        Option	   "NoLogo" "true"
        Option	   "backingstore" "true"
        Option         "TripleBuffer" "true"
        Option	   "AddARGBGLXVisuals"	"true"
        #Screen         	0
    EndSection
    
    
    Section "Screen"
    	Identifier     "Screen0"
    	Device         "Videocard0"
    	Monitor        "Monitor0"
    	DefaultDepth    24
            Option 	       "AllowGLXWithComposite" "true"
            Option         "UseCompositeWrapper" "true"
            Option	       "AddARGBGLXVisuals" "true"
    	Option         "TwinView" "1"
    	Option         "metamodes" "DFP-0: 1280x1024 +0+0, CRT-0: 1280x1024 +1280+0"
    	SubSection     "Display"
    		Depth       24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier     "Screen1"
    	Device         "Videocard2"
    	Monitor        "Monitor2"
    	DefaultDepth    24
            Option 	       "AllowGLXWithComposite" "true"
            Option         "UseCompositeWrapper" "true"
            Option	       "AddARGBGLXVisuals" "true"
    	Option         "TwinView" "1"
    #	Option         "metamodes" "CRT-0: 1280x1024 +0+0"
    	SubSection     "Display"
    		Depth       24
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Mode 0666
    EndSection
    
    Section "Extensions"
        Option  "Composite" "Enable"
    EndSection

  3. #23
    Join Date
    Dec 2007
    Location
    Tampa, FL
    Beans
    1,087
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    Crap... now you're going to get me in trouble with my wife simply because I'm going to have to get me one of those!!! Nice job!
    "There are 10 types of people: Those who read binary and those who don't"
    >>>"who is general failure and why is he reading my files"<<<
    The Ubuntu Counter Project - user number # 22367
    Howto automount NTFS - My wallpaper

  4. #24
    Join Date
    Aug 2008
    Beans
    198

    Smile Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    Quote Originally Posted by Victormd View Post
    Crap... now you're going to get me in trouble with my wife simply because I'm going to have to get me one of those!!! Nice job!
    Thanks! And just tell the wife like I told the girlfriend - Look at how you can have an online store open on each monitor and compare all these great deals on purses, clothing, etc at once

    Of course if that doesn't work - you can just set her up her own 2 screen workstation like I ended up doing



    - Shane

  5. #25
    Join Date
    Aug 2008
    Beans
    198

    Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    kai,

    Hmm - As long as the cards are Nvidia they should be "OK" - I had the exact same situation as you did before enabling xserver-xgl - as soon as i enable that - all 3 monitors had 3D enabled across them.. what happens in that current settup as soon as you enable xserver-xgl?

    also if you disable twinview on "Screen1" and enable that metamodes option - what happens? - Although I would see about just enabling that xserver-xgl first -

    - Thanks!

    Shane Menshik
    D2 GLOBAL INC

  6. #26
    Join Date
    Sep 2008
    Beans
    10

    Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    [QUOTE=d2globalinc;5550577]FIRST OF ALL! Thanks to the community for the support to make this happen! I did a lot of surfing and reading on this project!

    I'd settle for two monitors working!

  7. #27
    Join Date
    Jun 2007
    Beans
    30

    Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    this is my config file, im trying to set up 4 screens but i cant seem ti get it to work! what am i doing wrong!
    I am running 2 - Nvidea cards Geforce 8500, trying to see it on 4 - 22" Dell screens

    this is what my current config file looks like:


    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by failsafeDexconf, using
    # values from the debconf database and some overrides to use vesa mode.
    #
    # You should use dexconf or another such tool for creating a "real" xorg.conf
    # For example:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"nvidia"
    	Option		"NoLogo"	"True"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Configured Video Device"
    	Monitor		"Configured Monitor"
    	SubSection "Display"
    		Modes		"800x600"
    	EndSubSection
    	Defaultdepth	24
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen 0 "screen1" 0 0
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"v4l"
    EndSection
    Section "device" #  
    	Identifier	"device1"
    	Boardname	"NVIDIA GeForce 8 Series"
    	Busid		"PCI:2:0:0"
    	Driver		"nv"
    	Screen	0
    	Vendorname	"NVIDIA"
    EndSection
    Section "screen" #  
    	Identifier	"screen1"
    	Device		"device1"
    	Defaultdepth	24
    	Monitor		"monitor1"
    	SubSection "Display"
    		Depth	24
    		Modes		"800x600@56"	"800x600@72"	"640x480@75"	"800x600@75"	"640x480@72"	"800x600@60"	"640x480@60"	"832x624@75"	"1024x768@75"	"1024x768@70"	"1024x768@60"	"1152x864@75"	"1280x1024@75"	"1280x960@60"	"1280x1024@60"	"1280x960@75"	"1400x1050@60"	"1400x1050@75"	"1600x1200@65"	"1600x1200@60"	"1792x1344@60"
    	EndSubSection
    EndSection
    Section "monitor" #  
    	Identifier	"monitor1"
    	Vendorname	"Dell"
    	Modelname	"Dell E228WFP"
    	Horizsync	30.0-83.0
    	Vertrefresh	56.0-75.0
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
      modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
      modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
      modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
      modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
      modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
      modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
      modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
      modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
      modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
      modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
      modeline  "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
      modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
    	Gamma	1.0
    EndSection
    Section "device" #  
    	Identifier	"device2"
    	Boardname	"NVIDIA GeForce 8 Series"
    	Busid		"PCI:3:0:0"
    	Driver		"nv"
    	Screen	0
    	Vendorname	"NVIDIA"
    EndSection
    Section "screen" #  
    	Identifier	"screen2"
    	Device		"device2"
    	Defaultdepth	24
    	Monitor		"monitor2"
    EndSection
    Section "monitor" #  
    	Identifier	"monitor2"
    	Gamma	1.0
    EndSection
    Section "ServerFlags"
    EndSection

  8. #28
    Join Date
    Jun 2007
    Beans
    30

    Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    *bumb* any1?

  9. #29
    Join Date
    Aug 2008
    Beans
    198

    Smile Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    I'm taking a look at your xorg.conf and will post back my findings today - I have been busy re-doing my own PC and creating a HOWTO so I've not been able to check in on the forums as much as I would like

    Should have something soon!

    - Thanks!

    Shane Menshik
    D2 GLOBAL INC

  10. #30
    Join Date
    Aug 2008
    Beans
    198

    Re: 6 Monitors - Ubuntu 8.04 - Compiz Fusion - XGL NVIDIA Working! (Video Included)

    Quote Originally Posted by wizekid View Post
    trying to see it on 4 - 22" Dell screens
    All 4 dell's at same resolution I take it and all DVI? I noticed right off the bat you are using the opensource NV driver - have you downloaded / installed and then used the EnvyNG utility to update your drivers to the latest nvidia? if not goto system -> administration -> Synaptic Package Manager and search for envyng-gtk and install it and its dependency. Then once installed go under Applications -> System Tools -> EnvyNG and select nvidia, then the latest driver series and install! - Once you install those - it should ask you to reboot your machine - do that - after reboot - post your xorg.conf here. and I'll hook you up!

    If you have already installed xserver-xgl as per my former instructions above - remove it until after we get your monitors / xscreens working -

    Thanks!

    Shane Menshik
    D2 GLOBAL INC

Page 3 of 73 FirstFirst 123451353 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •