Results 1 to 5 of 5

Thread: Laptop display not being recognized as such

  1. #1
    Join Date
    Aug 2008
    Beans
    5

    Laptop display not being recognized as such

    Hi, well, I can't change the brightness of my laptop display, as it's not being recognized like it, whenever I try to move it lower, it tells me:

    #~: xbacklight -set 50
    No output have backlight property



    Since I need this laptop for movility, and display is one huge powertaking device, I need to solve this...
    I've tried searching through the schemes with gconf-editor, but it doesn't allow me to edit the schemes.
    Only place where I've been able to find something similar is in a bugtrack and for MacBook users, however I tried the workaround, still it didn't work.

    My graphic card is nVidia GeForce Go! 6150, running Hardy Heron.
    In the same Laptop, I've got another partition with Debian running, where I actually can deal with brigthness, so I guess it's Ubuntu specific problem.

    Can anybody point me in the right direction?

  2. #2
    Join Date
    Jun 2008
    Location
    England
    Beans
    2,567
    Distro
    Ubuntu Development Release

    Re: Laptop display not being recognized as such

    64-Bit User-Group // Twin-View AMD64 X2 6000+|Geforce 9500GT 1024 MB|8GB PC2-6400 DDR2|500GB Seagate SATA // AMD64 X2 4400+|Geforce 8600GTS |4GB PC2-6400 DDR2|360GB Samsung SATA // Ubuntu 9.04 & 9.10 64-Bit

  3. #3
    Join Date
    Aug 2008
    Beans
    5

    Re: Laptop display not being recognized as such

    Quote Originally Posted by tuxxy View Post
    Thanks for the fast reply, still both solutions explained there didn't work at all.
    Related mainly to the second script the diference with ATIM, where such thing does not exist in my system at all.
    Tryied modifing it to set it to match mine, but still no effect.

    Also, setting gamma lower does work, but I don't know how much of powersaving that is.
    Edit: In order to give further info, under /proc/acpi, VIDEO does not exist in my system.
    Second edit: the lacking of VIDEO is because of a tested workaround that didn't work (blacklisted VIDEO)
    Still, it's not working.
    Last edited by Lappymode; August 4th, 2008 at 03:41 PM.

  4. #4
    Join Date
    May 2007
    Beans
    18

    Re: Laptop display not being recognized as such

    Quote Originally Posted by Lappymode View Post
    Thanks for the fast reply, still both solutions explained there didn't work at all.
    Related mainly to the second script the diference with ATIM, where such thing does not exist in my system at all.
    Tryied modifing it to set it to match mine, but still no effect.
    ATIM is laptop dependent. you need to follow the path in Nautilus. You may find yours is something along the lines of /proc/acpi/video/VGA/LCD/brightness. Dig around in the /proc/acpi/video/ directory to find the exact match.

    You will more than likely need to alter the numeric values of the script to alter your brightness calibration. To find out what they are, you need to run "cat /proc/acpi/video/ATIM/LCD/brightness" from the terminal (without quotes), remembering to insert the exact path for your laptop.

    My script was altered to accommodate my particular laptop. The attached script may work better for you. Remember to follow the instructions (marked by a # within the script itself. Open it with a text editor to read them.)

    Hope that works.

    As a side, the brightness issue seems to be being caused by the ACPI (Advanced Configuration Power Interface). If you boot the kernel with the acpi=off option, you regain control over the Fn keys and your screen brightness. This however is not a viable solution as you lose control over the other power saving features such as CPU frequency scaling.

    Cheers

    Phil
    Attached Files Attached Files

  5. #5
    Join Date
    Aug 2008
    Beans
    5

    Re: Laptop display not being recognized as such

    Tried, but still whichever value I assing it from the ones that pops, do not work.
    Either way I went back to Debian and I do not have this problem, so maybe the tittle should be set to solved.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •