Results 1 to 2 of 2

Thread: NFS stutter

  1. #1
    Join Date
    Dec 2005
    Beans
    67

    NFS stutter

    I'm trying to offload some video from my myth box's internal HDD to a Freenas server via NFS. I have mounted a NFS share in /var/lib/mythtv/videos/Podcast and am playing back H.264 video from revision3.com. the video plays great locally but stutters when played over NFS. this is a bit puzzling since the video is consuming only ~3Mbps over a 1000Mbps connection as measured by the Freenas gui.

    Any NFS tuning variables that will help me out? Here's my mount from /etc/fstab:

    freenas.local:/mnt/BIGUN/mythtv/Podcast /var/lib/mythtv/videos/Podcast nfs suid,dev,exec 0 0

    I just followed the syntax from other nfs mounts in fstab which i think were created by webmin but i don't remember.

    thx
    matt

  2. #2
    Join Date
    May 2007
    Beans
    2,334

    Re: NFS stutter

    Hi,

    Have a look here http://docs.hp.com/en/B1031-90061/ch05s04.html, maybe there are afew tips you can try.

    In my tests I actually got better performance using Samba/CIFS than NFS on exactly the same hardware (Frontend C2D 1.6GHz, Backend Quad C2D 2.4GHz over a 1Gb network).

    Regards
    Ian Dobson
    Walking on water and writing software to specification is easy if they're frozen.

    My corner of the internet http://www.planet-ian.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •