Results 1 to 5 of 5

Thread: [SOLVED] Hardy: how to disable AppArmor????

  1. #1
    Join Date
    Sep 2005
    Beans
    359

    Question [SOLVED] Hardy: how to disable AppArmor????

    It seems that Hardy has silently introduced AppArmor and now I am unable to run mysql like I want anymore. The problem is that obviously AppArmor prevents mysql from using files that reside on a different disk.

    However, because of size and backup considerations I need to have parts of mysql on various other disks!

    I am desperately trying to re-create the installation I had running under Gutsy under a freshly installed Hardy and this is one of the major stumbling blocks!

    I also read that there are problems with cups and AppArmor -- so instead of tinkering with it, can I just disable it entirely? I definitely dont need it, thank you very much.

  2. #2
    Join Date
    Sep 2006
    Beans
    3,470

    Re: Hardy: how to disable AppArmor????

    You can disable the AppArmor framework with (from AppArmor: Ubuntu Community Documentation):
    Code:
    sudo /etc/init.d/apparmor kill
    sudo update-rc.d -f apparmor remove
    Haven't tried it myself. Instead, I just purged all AppArmor packages. Didn't have any problems, but I haven't been using mySQL.

  3. #3
    Join Date
    Sep 2005
    Beans
    359

    [Solved] Re: Hardy: how to disable AppArmor????

    Thank you that did it.

  4. #4
    Join Date
    Jul 2007
    Location
    Sweden
    Beans
    24

    Re: [SOLVED] Hardy: how to disable AppArmor????

    I ended up here having the same trouble as the threadstarter (mysql db on non-default location).

    I wanted to add that you can instead set mysql to complain mode in apparmor, which will allow but log instead of blocking (default).

    sudo aa-complain /usr/sbin/mysqld

    This will result in a working mysql and apparmor.

  5. #5
    Join Date
    Jul 2009
    Beans
    3

    Re: [SOLVED] Hardy: how to disable AppArmor????

    Thanks for the sudo aa-complain suggestion.

    How would I put this in my startup sequence so I don't have to type this each time? I've never messed with init.d before, but I think that's where I would go.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •