Page 5 of 5 FirstFirst ... 345
Results 41 to 44 of 44

Thread: Wireles Running Slowly

  1. #41
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireles Running Slowly

    Wow, this is being pretty crazy...it's like nothing on your machine will work the way it's supposed to.

    Anyway, since we know the file definitely exists, try:
    Code:
    cd /etc/init.d
    sudo update-rc.d wifi-fix.sh defaults
    Maybe that will help because you won't be giving it the full path to the file. It seems to me that there's some bug with update-rc.d that's making it interpret the command-line arguments incorrectly, which is why it's repeating '/etc/init.d.'

    If it still doesn't work, you can update the init scripts by default--basically you just have to symlink some things together, which is all that update-rc.d does--but hopefully that won't be necessary, as it's tedious.

    And no, unfortunately there's no GUI that I know of for writing boot scripts--although it would be a nice feature that would be trivially easy to write, I think. Gnome has a GUI at System>Preferences>Sessions to run commands when you log into Gnome, which we could use to call the wifi-fix.sh script, but it would be a lot cleaner and better to have init deal with it.

  2. #42
    Join Date
    Mar 2008
    Beans
    168
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireles Running Slowly

    Success!!

    Code:
    joshua@SNKNGSHPS:~$ cd /etc/init.d
    joshua@SNKNGSHPS:/etc/init.d$ sudo update-rc.d wifi-fix.sh defaults
     Adding system startup for /etc/init.d/wifi-fix.sh ...
       /etc/rc0.d/K20wifi-fix.sh -> ../init.d/wifi-fix.sh
       /etc/rc1.d/K20wifi-fix.sh -> ../init.d/wifi-fix.sh
       /etc/rc6.d/K20wifi-fix.sh -> ../init.d/wifi-fix.sh
       /etc/rc2.d/S20wifi-fix.sh -> ../init.d/wifi-fix.sh
       /etc/rc3.d/S20wifi-fix.sh -> ../init.d/wifi-fix.sh
       /etc/rc4.d/S20wifi-fix.sh -> ../init.d/wifi-fix.sh
       /etc/rc5.d/S20wifi-fix.sh -> ../init.d/wifi-fix.sh
    It looks like it worked. Now I guess the only things that would be helpful would be..
    1. A guide to switching over to ethernet in case I ever need it.
    2. A guide to checking on that new driver in October.
    3. A guide for switching back to ndiswrapper in case the updated driver doesn't work any better.

    By the way, I reached speeds slightly over 400 earlier, so it's definitely working much better. I appreciate all your help, without people like you Ubuntu would be a pain in the neck sometimes.
    Running Ubuntu Jaunty 9.04 on a Dell Inspirion 1501 | DUAL CORE AMD x64 1.8 TURION |Video Card: ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP] | Sound Card: ATI Technologies Inc SBx00 Azalia | 2 Gigs of Ram

  3. #43
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireles Running Slowly

    Alright, I'm glad it's finally all straightened out now.

    To switch back to ethernet, run these commands (which modify the wifi-fix script as needed, remove the modules 'ssb' and 'b44' from the blacklist, and insert those modules):
    Code:
    sudo -s
    sed 's/rmmod b44/#line1/' /etc/init.d/wifi-fix.sh #deletes 'rmmod b44' from wifi-fix.sh (and replaces it with a comment) so that b44 is no longer unloaded at boot
    sed 's/rmmod ssb/#line2/' /etc/init.d/wifi-fix.sh #ditto for ssb
    sed 's/blacklist ssb//' /etc/modprobe.d/blacklist
    sed 's/blacklist b44//' /etc/modprobe.d/blacklist
    modprobe b44
    modprobe ssb
    ifconfig eth0 up
    To switch from ndiswrapper to the native Broadcom driver, b43 (this will also enable your ethernet at the same time, which isn't necessary to make b43 work, but you may as well do it):
    Code:
    sudo -s
    sed 's/rmmod b44/#line1/' /etc/init.d/wifi-fix.sh #deletes 'rmmod b44' from wifi-fix.sh (and replaces it with a comment) so that b44 is no longer unloaded at boot
    sed 's/rmmod ssb/#line2/' /etc/init.d/wifi-fix.sh #ditto for ssb
    sed 's/blacklist b44//' /etc/modprobe.d/blacklist
    sed 's/blacklist b43 ssb//' /etc/modprobe.d/blacklist
    sed 's/blacklist b43//' /etc/modprobe.d/blacklist
    sed 's/blacklist b43legacy//' /etc/modprobe.d/blacklist
    sed 's/blacklist ssb//' /etc/modprobe.d/blacklist
    echo 'blacklist ndiswrapper' >> /etc/modprobe.d/blacklist
    rmmod ndiswrapper
    modprobe b44
    modprobe b43
    modprobe ssb
    ifconfig wlan0 up
    (these commands modify the wifi-fix script as needed, remove the modules 'b43,' 'ssb' and 'b43legacy' from the blacklist, add ndiswrapper to the blacklist, unload the ndiswrapper module, and load the b43 driver).
    Code:
    sudo rmmod b44
    sudo rmmod ssb
    sudo rmmod ndiswrapper
    sudo modprobe ndiswrapper
    sudo ifconfig wlan0 up
    And to switch back to ndiswrapper if b43 doesn't work:
    Code:
    sudo -s
    sed 's/#line1/rmmod b44' /etc/init.d/wifi-fix.sh #tells wifi-fix.sh to remove the b44 module, if it isn't already 
    sed 's/#line2/rmmod ssb' /etc/init.d/wifi-fix.sh #same as above for ssb
    echo 'blacklist b43' >> /etc/modprobe.d/blacklist
    echo 'blacklist b43legacy' >> /etc/modprobe.d/blacklist
    echo 'blacklist b43 ssb' >> /etc/modprobe.d/blacklist
    echo 'blacklist ssb' >> /etc/modprobe.d/blacklist
    echo 'blacklist b44' >> /etc/modprobe.d/blacklist
    sed 's/blacklist ndiswrapper//' /etc/modprobe.d/blacklist
    rmmod b43
    rmmod b43legacy
    rmmod b44
    rmmod ssb
    rmmod ndiswrapper
    modprobe ndiswrapper
    ifconfig wlan0 up
    (this modifies the wifi-fix script as needed, adds 'b43,' 'b43legacy,' 'ssb' and 'b44' to the blacklist, removes ndiswrapper from the blacklist, unloads the b43 and b44 modules and their friends, then loads the ndiswrapper module)

    Each of these scripts should apply the requested change permanently (through reboots), and each one should work no matter what the current state of the networking situation is on your machine. There's a lot going on here and I could have missed something, but I proofread at least and think all these commands should work. Also, I know that all of these commands may be cryptic to you, so if you want to know what exactly these scripts are doing, I'll explain. But I wanted to write everything as a bash command (instead of giving you instructions like "open this file, find line X, replace it with Y, then scroll down to line Z...") so that you can run these things as scripts if you want, which should be convenient--just have three scripts, enable-ethernet.sh, enable-native-broadcom.sh and enable-ndiswrapper.sh, that you can run quickly whenever you want to switch.

    Finally, keep in mind that the commands are all based on the way Hardy behaves; I can't guarantee that Ubuntu 8.10 won't deal with the Broadcom drivers in a different way and throw all of this off. But feel free to contact me in October if you have any trouble.
    Last edited by pytheas22; August 3rd, 2008 at 02:41 AM.

  4. #44
    Join Date
    Mar 2008
    Beans
    168
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireles Running Slowly

    Awesome, thanks so much. I've booted my machine a few times and haven't had any issues, so I guess we're officially done. Thanks again for all of your help!
    Running Ubuntu Jaunty 9.04 on a Dell Inspirion 1501 | DUAL CORE AMD x64 1.8 TURION |Video Card: ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP] | Sound Card: ATI Technologies Inc SBx00 Azalia | 2 Gigs of Ram

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •