Results 1 to 5 of 5

Thread: Proxy exceptions not being set

  1. #1
    Join Date
    Sep 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Proxy exceptions not being set

    Hi,

    My university has a local ubuntu repository, which I use, along with some other repositories for some other software, which are on the internet.

    Trouble is, we use a proxy for connecting to the internet. Setting the proxy in the network proxy area seems to do the trick, but I'd like ubuntu to ignore the proxy for 10.3.140.50, and use it for everything else.

    In the "advanced configuration" tab of the proxy settings, I've added "10.3.140.50" to the ignore host list, but it doesen't seem to help.

    I even tried 10.0.0.0/8 and 10.*.*.*, neither seems to be working.
    I'd also like to write a shell script to set this. export HTTP_PROXY="myproxyort" seems to work fine, so how do I manually add it to the ignore list?

    Thanks
    With Oden on our side, we are victorious.

  2. #2
    Join Date
    Sep 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Proxy exceptions not being set

    I'm not able to set the option in KDE either. Should I reinstall?
    With Oden on our side, we are victorious.

  3. #3
    Join Date
    Jun 2006
    Beans
    9

    Re: Proxy exceptions not being set

    Quote Originally Posted by prototype_angel View Post
    Hi,

    My university has a local ubuntu repository, which I use, along with some other repositories for some other software, which are on the internet.

    Trouble is, we use a proxy for connecting to the internet. Setting the proxy in the network proxy area seems to do the trick, but I'd like ubuntu to ignore the proxy for 10.3.140.50, and use it for everything else.

    In the "advanced configuration" tab of the proxy settings, I've added "10.3.140.50" to the ignore host list, but it doesen't seem to help.

    I even tried 10.0.0.0/8 and 10.*.*.*, neither seems to be working.
    I'd also like to write a shell script to set this. export HTTP_PROXY="myproxyort" seems to work fine, so how do I manually add it to the ignore list?

    Thanks
    I hate to bring up a 2+ year old topic, but I'm having the same issue. I can't seem to figure out what the proxy exception format is for this section. I tried the formats described above (Firefox uses the first one, IE uses the other), but it's not working.

  4. #4
    Join Date
    Nov 2007
    Location
    Quebec
    Beans
    26
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Proxy exceptions not being set

    And it's even worse in Oneiric Ocelot (11.10) .. the exception tab and fields have disappeared !!!

    The data has to be set using the dconf-editor tool, under the key /system/proxy/ignore-hosts
    Last edited by qwill; October 14th, 2011 at 09:13 PM.

  5. #5
    Join Date
    Oct 2011
    Beans
    3

    Re: Proxy exceptions not being set

    Configuring advanced proxy settings is unfortunately cumbersome and error-prone in Oneiric Ocelot (11.10). I thought I had understood the quirks to make it work properly, but I'm forced to use workarounds:
    • Firefox: I use manual proxy configuration
    • apt-get/Update Manager: I use /etc/apt/apt.conf.d/99proxy, which I created with contents (adapt to your own proxy):
      Code:
      Acquire::http::Proxy "http://proxy.mycompany.ch:8080";
      Acquire::https::Proxy "https://proxy.mycompany.ch:8080";
    Last edited by jllarden; October 21st, 2011 at 02:25 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •