Page 2 of 64 FirstFirst 12341252 ... LastLast
Results 11 to 20 of 635

Thread: Lenovo Ideapad Y510 is Go (Continued / NEW)

  1. #11
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Beans
    136
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    On another thread, (here) there is someone having the same problem as us on a different laptop, in regards to the webcam image being upside down. Apparently, the fix for this is to add a parameter to the driver when the module is loaded, like so:
    Code:
    modprobe xxxx_driver_name_xxx invert=1
    ...but neither I nor the origonal poster know how to do that in such a way that it happens automagically at boot. This is progress at least.
    Last edited by evets25; July 29th, 2008 at 08:50 PM. Reason: ...
    Visit my blog! -> tuxrant.blogspot.com
    Help fix my bugs! Bug #251142 & Bug#255393.

    .evets, Ubuntard #23275

  2. #12
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Quote Originally Posted by evets25 View Post
    On another thread, (here) there is someone having the same problem as us on a different laptop, in regards to the webcam image being upside down. Apparently, the fix for this is to add a parameter to the driver when the module is loaded, like so:
    Code:
    modprobe xxxx_driver_name_xxx invert=1
    ...but neither I nor the origonal poster know how to do that in such a way that it happens automagically at boot. This is progress at least.
    Hum..... Well the script could look like this...

    #!/bin/bash

    modprobe xxxx_driver_name_xxx invert=1

    In KDE there is a Autostart folder, I don't know about Gnome I bet there is. The other way of makeing it run at startup is puting it in your startup daemons. I have that "alsascript" run at startup by puting it in my daemons. I have my script to turn the brightness up in my Autostart folder in KDE because KDE starting is what turns down the brightness.

    ((
    NOTE, when I first installed Archlinux I had no problems with brightness... I installed Xorg and had no problems with brightness using only Xorg. I installed KDEbase and then I started haveing the prblems with the screen not as bright as it could be and diming at start.
    ))

    ((
    Also, Now after the BIOS update. I put in the Ubuntu7.10 Live CD and the screen will not get as bright as it did. I press the Fn+up/down. The GUI brightness bar on the screen go's 10 steps but after the 6th step it dosn't get any brighter.... I guess when I Flashed the BIOS with the brightness at that level it thought that that was as bright as the screen could get and now will not get any brighter nomader what the programming... I will do more looking into this I mite be wrong. I would sugjest that you put in a Ubuntu7.10 Livecd to turn the brightness up all the way. Then reboot and do the BIOS Flash.... Just to make sure.
    ))

    Anyway back to the web cam fix.... To put it in the daemons you need to... I don't know terditional Linux setup... But in BSD an Archlinux you put the script in /etc/rc.d folder and then add the name to the deamons array in /etc/rc.conf... Dose any one know what folder you list stuff to start in normal Linux???

    If that dosn't work i.e. Gnome starting is what is messing it up. Then you have to put it in the Autostart folder..... Owe hay I found a grate Wiki on the Gentoo sight here is a link...

    http://gentoo-wiki.com/HOWTO_Autostart_Programs

    If you need root privleges to use Modeprobe then you have to give your user the ability to exicute the "webcamscript" with no password. You do this by adding this line to the sudoers file (to edit the sudoers file just type... sudo visudo)

    # Same thing without a password
    # %groupname ALL=(ALL) NOPASSWD: ALL
    username ALL=(root) NOPASSWD: path/to/script/webcamscript

    Then you have to write at new script to put into the auto start folder...

    #!/bin/bash

    sudo webcamscript


    Check out how I did my Backlight bright on startup Workaround and I guess in is EZ to do it in Gnome to so you don't have to turn it up by hand every time you strat your computer...

    http://ubuntuforums.org/showthread.p...deapad&page=19
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

  3. #13
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    DO NOT USE KDE4 !!!!!!!!!!!

    It looks like it will be cool in like 3 more Years.... Mybe KDE5 will work???

    --------------------------

    Well, OpenBox IS all it is cracked up to be Way better then KDE4. I think I even like it better then KDE3.5.9
    Last edited by HunterThomson; July 31st, 2008 at 09:15 AM.
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

  4. #14
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Beans
    136
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Quote Originally Posted by HunterThomson View Post
    Hum..... Well the script could look like this...

    #!/bin/bash

    modprobe xxxx_driver_name_xxx invert=1

    In KDE there is a Autostart folder, I don't know about Gnome I bet there is. The other way of makeing it run at startup is puting it in your startup daemons. I have that "alsascript" run at startup by puting it in my daemons. I have my script to turn the brightness up in my Autostart folder in KDE because KDE starting is what turns down the brightness.
    Well, this isn't something you want done when the user logs in, this needs to happen at the point when the driver is initially loaded, which is rather early in the boot process, and certainly long before X starts and GDM pops up.

    I know how to make a program start on log in, but this is on a whole different level; this is happening when the driver is initially loaded as a module in to the kernel.

    EDIT: Also, the proper way to allow the user to run such a script would be to simply have gnome/kde's autostart run "sudo /path/to/webcamscript" (as opposed to just running the script without sudo) instead of editing sudoers to allow a user to run that particular script... that way, the whole process that the script creates is elevated to root privilges (which is okay because it's loading a kernel module, not just running some random program). Otherwise, the script might still fail because even if that particular user is allowed to run the script without sudo, modprobe still needs root access to actually work. However, you are thinking along the right lines.
    Last edited by evets25; July 30th, 2008 at 06:41 PM. Reason: addendum
    Visit my blog! -> tuxrant.blogspot.com
    Help fix my bugs! Bug #251142 & Bug#255393.

    .evets, Ubuntard #23275

  5. #15
    Join Date
    Jul 2008
    Beans
    30

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    I found this after typing dmesg in the command line :
    Code:
    [   42.152568] usbcore: registered new interface driver hci_usb
    [   42.375623] Linux video capture interface: v2.00
    [   42.485825] uvcvideo: Found UVC 1.00 device Lenovo EasyCamera (046d:09b6)
    [   42.488790] usbcore: registered new interface driver uvcvideo
    [   42.488800] USB Video Class driver (v0.1.0)
    and this after typing lsmod | grep uvc :
    Code:
    uvcvideo               58116  0 
    compat_ioctl32          2304  1 uvcvideo
    videodev               29440  1 uvcvideo
    v4l1_compat            15492  2 uvcvideo,videodev
    v4l2_common            18304  2 uvcvideo,videodev
    usbcore               146028  5 uvcvideo,hci_usb,ehci_hcd,uhci_hcd
    So I think the driver module is uvcvideo, and since I spent much time trying to make this webcam work with some softwares, now I'm sure it is a v4l2 compatible webcam.

    I checked uvcvideo parameters in /sys/modules/uvcvideo/ but I could only find one : trace, which seems to be a verbose option.

    I also found these configuration lines in /etc/modprobe.d/options file :
    Code:
    # Enable double-buffering so gstreamer et. al. work
    options quickcam compatible=2
    but I don't think it is related to the upside-down problem.

    Oh, and I should hae mentioned that everything works fine for me : no upside-down or other problems. It works at least with cheese, luvcview, vlc and amsn.
    Lenovo Y510 | Ubuntu 8.10 - 32 bits | 1.6 GHz Pentium dual T2330 | 2 Go RAM | Nvidia 8400M GS | 160GB 5400 RPM HDD

  6. #16
    Join Date
    Jul 2008
    Beans
    30

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Solution for the webcam :

    Someone wrote a patch for upside-down image problem from UVC webcam. You'll find a howto to install it on this page :

    http://ubuntuforums.org/showthread.php?t=838210

    I found it on this thread :
    http://ubuntuforums.org/showthread.php?t=561433
    Lenovo Y510 | Ubuntu 8.10 - 32 bits | 1.6 GHz Pentium dual T2330 | 2 Go RAM | Nvidia 8400M GS | 160GB 5400 RPM HDD

  7. #17
    Join Date
    Jan 2005
    Location
    Charlottesville, VA
    Beans
    520
    Distro
    Ubuntu

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Quote Originally Posted by winnibob View Post
    Suspend/Hibernate :
    In the beginning, I couldn't hibernate at all, every time I tried to wake it up, Ubuntu was just booting normally, as if it has just been powered off.
    Suspend to ram was doing well 9 times on 10, and when it was buggy, it woke up with a full black screen, and I was unable to recover the system even with Ctrl+Alt+F2 : nothing happened.
    For what it's worth, the latest kernel (2.6.24-20) has a suspend issue, and there are bugs filed against it. I just found this out yesterday; not sure if I still have the bugs (sorry, teaching summer classes, running between rooms right now).

    You may want to try 2.6.24-19; people report that going back to that kernel solved the suspend issue.

    To get that, either edit grub by commenting out the 2.6.24-20 entries (in /boot/grub/menu.lst), or just press escape, I believe, at boot so you can enter the grub options and choose a different kernel.

    By the way, the 2.6.24-20 kernel also has some wireless issues I'm messing with. This isn't specific to our hardware. The problem is wireless is showing it's on when you boot, but doesn't automagically connect to networks it once did, often asking for passwords over and over again.

    The quick fix: If you're experiencing this problem, note that the wireless light doesn't actually turn on, even though the wireless switch on the front of the machine is set to "on." If you switch that switch to "off" and back to "on," it connects again.

    I thought I had a fix and posted it here, but so far that fix has only worked for me once.
    Last edited by wyth; July 31st, 2008 at 12:16 AM.
    Lenovo Y510 | Ubuntu 14.04 | 1.6 GHz Pentium Dual T2330 | 4 gig RAM | Intel X3100 gfx | 250GB 5400 RPM hard drive.

    Gunga galunga...gunga- gunga lagunga.

  8. #18
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Quote Originally Posted by evets25 View Post
    Well, this isn't something you want done when the user logs in, this needs to happen at the point when the driver is initially loaded, which is rather early in the boot process, and certainly long before X starts and GDM pops up.

    I know how to make a program start on log in, but this is on a whole different level; this is happening when the driver is initially loaded as a module in to the kernel.

    EDIT: Also, the proper way to allow the user to run such a script would be to simply have gnome/kde's autostart run "sudo /path/to/webcamscript" (as opposed to just running the script without sudo) instead of editing sudoers to allow a user to run that particular script... that way, the whole process that the script creates is elevated to root privilges (which is okay because it's loading a kernel module, not just running some random program). Otherwise, the script might still fail because even if that particular user is allowed to run the script without sudo, modprobe still needs root access to actually work. However, you are thinking along the right lines.
    I didn't think you were right but WOW you are. I just typed... nano brightscript and then added a # and it let me save it. So, I moved it to root's /bin to see if that would lock editing of the file but no it didn't. I moved it back to /usr/bin. Then I adden visudo to the end of it and when I ran brightscript it opened the sudoers file as ROOT!!!! WOW that is not cool.....

    I thought it only let me run the program but the fact that it was in a restricted folder would stop the editing of the script so it was not a secruity risk.

    I guess I could use AppArmer to set it up like that.
    Last edited by HunterThomson; July 31st, 2008 at 05:02 AM.
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

  9. #19
    Join Date
    Jul 2008
    Beans
    30

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Originally Posted by wyth
    For what it's worth, the latest kernel (2.6.24-20) has a suspend issue, and there are bugs filed against it. I just found this out yesterday; not sure if I still have the bugs (sorry, teaching summer classes, running between rooms right now).

    You may want to try 2.6.24-19; people report that going back to that kernel solved the suspend issue.
    Actually, I'm using 2.6.24-19 kernel. 2.6.24-20 is not yet installed on my machine, maybe because I didn't activate hardy-proposed repository.
    Anyway, I had these problems with suspend to ram on all kernels since 2.6.24-16.

    About your networking problem, I experienced the same with 2.6.24-16 and 2.6.24-17, and it seemed the problem was in nm-applet. Many people reported that these strange behaviours while connecting disappeared after suppressing NetworkManager for an other soft.
    Lenovo Y510 | Ubuntu 8.10 - 32 bits | 1.6 GHz Pentium dual T2330 | 2 Go RAM | Nvidia 8400M GS | 160GB 5400 RPM HDD

  10. #20
    Join Date
    Feb 2008
    Beans
    27

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    I'm using Ubuntu 7.10 32-bit version,

    Sound: same issues, haven't tried to fix yet
    Brightness: worked out of the box

    The problem I'm having is with the webcam. Neither Skype nor Cheese can even find the webcam. Has anyone else run into this?

Page 2 of 64 FirstFirst 12341252 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •