Page 1 of 3 123 LastLast
Results 1 to 10 of 635

Thread: Lenovo Ideapad Y510 is Go (Continued / NEW)

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Lenovo Ideapad Y510 is Go (Continued / NEW)

    This is a Thread to continue the "Lenovo Ideapad Y510 is GO by wyth" do to the fact that the thread is now "Read Only"

    http://ubuntuforums.org/showthread.php?t=687663


    I am happy to see that both Google and Ubuntuforums are showing this thread is search results. The fact that wyth's thread was so good was a major reson I got this laptop. I didn't want to see the tread die. I hope this tread takes over were wyth's thead ended. Whith all the GUN community spirit & development. Keeping all the fixes & info related to the Lenovo Ideapad in one place.

    Keep up the good work everyone

    bwsmith7 Found a fix for the Webcam Upside down problem !!!
    check below for the fix.
    Attached Images Attached Images
    Last edited by HunterThomson; December 7th, 2009 at 02:33 AM.
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

  2. #2
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    How To get the Webcam To work "right side up"

    (This is only a problem with some laptops. try it first. If the image is upside down. then do this.)

    bwsmith7 Found a fix for this YA!


    Well Just follow this link and do what it says to do.
    On page 55 of this tread bwsmith7 said this worked for him.

    http://radu.cotescu.com/2009/11/05/f...ubuntu-webcam/






    How to get the sound working

    Copy of wyth's post on Page 15 of this thread


    http://ubuntuforums.org/showthread.php?t=870681&page=15

    Okay, I'm just basically reposting what is already on this Ubuntu help page and on the previous Lenovo Ideapad Y510 is GO page, but with some new tweaks. This guide is using the 1.0.18rc3 ALSA drivers, but this will/should work for other drivers.

    First, you need to make sure you have the right stuff installed:

    Code:

    Code:
      sudo aptitude install build-essential libncurses-dev gettext linux-headers-`uname -r`
    Next get the latest ALSA drivers; they'll be downloaded to wherever your default downloads go, but you're going to move them to a new directory. For this case, I'll use the Desktop.


    * alsa-driver
    * alsa-lib
    * alsa-utils

    From here...
    http://www.alsa-project.org/main/index.php/Main_Page

    Next step is to create a /usr/src/alsa directory for the files and copy the tar.bz2 files to that directory; you may have this directory of you've rolled your own drivers in the past:

    Code:

    Code:
    sudo mkdir -p /usr/src/alsa
    cd /usr/src/alsa
    sudo cp ~/Desktop/alsa* .
    sudo tar xjf alsa-driver*.bz2
    sudo tar xjf alsa-lib*.tar.bz2
    sudo tar xjf alsa-utils*.tar.bz2
    * Compile and install alsa-driver

    Code:

    Code:
    cd alsa-driver* 
    sudo ./configure --with-card-options=hda-codec-realtek,hda-codec-analog,hda-codec-sigmatel,hda-codec-via,hda-codec-atihdmi,hda-codec-conexant,hda-codec-cmedia,hda-codec-si3054,hda-generic
    sudo make
    sudo make install
    * Compile and install alsa-lib

    Code:

    Code:
    cd ../alsa-lib* 
    sudo ./configure 
    sudo make 
    sudo make install
    * Compile and install alsa-utils

    Code:

    Code:
    cd ../alsa-utils* 
    sudo ./configure 
    sudo make 
    sudo make install
    Next find out what sound card you're using:

    Code:

    Code:
    cat /proc/asound/card0/codec#* | grep Codec
    The Y510 uses RealTek ALC888, so look for that. (This may be different if you have a newer version of the Y510 with some different hardware.)

    Next you can check the ALSA-Configuration for specifics on the sound card. I found it at
    Code:

    Code:
    /usr/src/alsa/alsa-driver*/alsa-kernel/Documentation/ALSA-Configuration.txt
    Look for the section titled ALC883/888. There are many possible options, and some work better than others.

    ‣ 3stack-6ch
    ‣ 3stack-6ch-intel
    ‣ lenovo-101e (Lenovo 101E)
    ‣ lenovo-nb0763 ( Lenovo NB0763)
    ‣ lenovo-ms7195-dig (Lenovo MS7195)
    ‣ lenovo-sky (Lenovo Sky)
    ‣ auto (Gets the information from BIOS)

    Next to tell alsa-base what to do:
    Code:

    Code:
    sudo nano /etc/modprobe.d/alsa-base
    at the end of that file, add:
    Code:

    Code:
      options snd-hda-intel model=MODEL
    For model=MODEL, use one of the options from above, such as:

    ‣ options snd-hda-intel model=lenovo-sky

    I found model=lenovo-sky worked beautifully and then you will have no problem with the speakers muteing with you plug in headphones.

    You will want to reboot now...

    Code:
    sudo reboot
    Then you will want to set up the default sound settings by doing this...

    Open a shell and swich to the root user:

    Code:
    sudo su
    Then set the sound up to the way you would like it at startup:
    (Hint, make sure headphone is NOT muted, Frount to 100%, Surround 100%, Center 100%, LFE 100%, Side 100%, and I like to have Master set to 50% at startup.)

    (Hint, use the arow keys and the "Esc" key to exit)

    Code:
    alsamixer
    After exiting the Alsamixer, run this command to save your sound settings:

    Code:
    alsactl store
    Then reboot:

    Code:
    reboot
    Reboot and see if it's working. In the past, kernel updates did not break this. The surround sound features are present, the system sounds work, and the headphones automatically mute all speakers when plugged in.

    __________________________________________________ ___________________________________



    How to get the sound working in Arch Linux

    In the shell:

    pacman -S alsa-oss alsa-utils alsa-lib

    Then add this line to the end of /etc/modprobe.conf

    Code:
    sudo nano /etc/modprobe.conf
    Code:
    options snd-hda-intel model=lenovo-sky
    reboot or restart the alsa daemon

    Code:
    sudo reboot
    Then you will want to set up the default sound settings by doing this...

    Open a shell and swich to the root user:

    Code:
    sudo su
    Then set the sound up to the way you would like it at startup:
    (Hint, make sure headphone is NOT muted, Frount to 100%, Surround 100%, Center 100%, LFE 100%, Side 100%, and I like to have Master set to 50% at startup.)

    (Hint, use the arow keys and the "Esc" key to exit)

    Code:
    alsamixer
    After exiting the Alsamixer, run this command to save your sound settings:

    Code:
    alsactl store
    Reboot and all well be working
    Last edited by HunterThomson; December 7th, 2009 at 02:26 AM.
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

  3. #3
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Lenovo Ideapad Y510 is Go Summary, Linux Compatibility List

    I will update this and add new sections as needed. All Page #'s are in reference to wyth's thread found here;

    http://ubuntuforums.org/showthread.php?t=687663

    Web cam= mite be upside down.... bwsmith7 fond a FIX ! check it out on this web site.
    http://radu.cotescu.com/2009/11/05/f...ubuntu-webcam/


    Backlight= Fixed in 2.6.28 Kernel
    Backlight= YA, Big Thanks to chrismulderza . He fixed the backlight by fixing errors in the DSDT (( a file which is part of the BIOS and tells the ACPI module in the Kernel what kind of hardware the computer is made out of and how to use it i.e. backlight and what is up/down and max bright and all that stuff))
    You can find his fix on page 21 of this thread.
    http://ubuntuforums.org/showthread.php?t=870681&page=21


    HDD Load_Cycal_Count= Page 16-17...Install Laptop-mode-tools and set the powersaveing setting to 254 on AC and Bat... Read up on Laptop-mode-tools there are a lot of options.

    Sound= All better now Big Thanks to Wyth. For Pwning up this problem form the git go. He has now come up with some new driver compolation flags to build the alsa driver better. He also spent the time to go though the new ALSA relece to find a new Module for our laptop "lenovo-sky" head phones mute now and sound is better.

    Hibernation= Works again now in Ubuntu 8.10

    Suspend to ram= Works again now in Ubuntu 8.10

    BIOS Update
    New BIOS out 06CN33WW.ROM so this is out of date untill we get more feed back

    The newest BIOS vertion that works well is ***31.ROM

    . Page=3-4 Of "This Thread". There is a "CRITICAL BIOS UPDATE" for all the Ideapad laptops. Lenovo only lets you download a .exe for Vi$ta. You mite want to do that before you install Linux. However you can update the BIOS in Linux look at P20 for the links and stuff. I Flashed my BIOS from my 1GB USB dirve. You can see my HOW TO below. I have also writen a description of what the BIOS is on page=3 Of "This" thread.

    To make things really EZ, I have writen a script to make a USB Thumb Dirve that you can use to flash your BIOS. It works vary well. It takes all the guess work and effort out of flashing your BIOS. You can find it on page=4 of this thread
    http://ubuntuforums.org/showthread.p...37#post5552537

    CD/DVD Just Works... No problems at all. THE Y710 with the BlueRay drive dosn't work right now. But I have hope we will fix it at some point.

    Multi Card Reader Well the SD cards work I have not tried MMC or MS.....

    VGA Port Just Works... No problems at all.

    S-Video Port I don't konw.... PM me if you know.

    RJ-45 Ethernet Port Just Works...No problems at all.

    FireWire Just Works... No problems at all.

    Bluetooth Just Works... May need to use something other then NetworkManager.

    WiFi Just Works... No problems at all. Got to love intel's OpenSource commitment.

    Media Buttons Just Works in Ubuntu. Or in archlinux I justed maped them in VLC an my Mediaplayer.

    Fn Keys Just Works...
    Last edited by HunterThomson; December 7th, 2009 at 02:29 AM.
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

  4. #4
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)


    MY info quite probably could be out of date. I don't own this laptop anymore and My post were talking about the First model of this laptop. As you can see in the pic's in the first post. The NEW Y510 you probably have doesn't look like this. However, the hardware is probably close to the same. Heck probably all Lenovo hardware is close to the same.
    ================================================== ==
    ++++++++++++++++++++++++++++++++++++++++++++++++++ ++
    ================================================== ==



    Lenovo Ideapad Y510 Flash BIOS "HOW TO"

    New BIOS 06CN33WW.ROM

    NOTE: If this all looks vary confusing and/or you don't want to wast 30-40min's doing all of this then just run the script I wrote on page=4 of this thread

    Bash Script >>>>>>>>>>>>>
    http://ubuntuforums.org/showthread.php?t=870681&page=4


    This is what I did. I take no resposability if your compuer turns into a coster. If your BIOS gets messed up or if ANYTHING goses wrong with the BIOS Flashing your computer with not even start, it will be worthless!!!!! You should read more about it if this is new to you.

    You can also check out this link for more info and options

    http://ubuntuforums.org/showthread.php?t=694513

    Downloaded the .ROM file posted by me

    http://ubuntuforums.org/attachment.p...2&d=1231117384

    Save it to your home folder and unpack it with this comand

    Code:
    cd ~
    tar xvf 06CN31WW.bios.update.tar.gz
    Then put a USB thumb dirve in your box and used gparted to format it to FAT32

    Then install "mbr"

    in Ubuntu=
    Code:
    sudo apt-get install mbr
    In Archlinux= You have to get it from Aur. I just edited the PKGBUILD file to read ARCH='x86_64' insted of ARCH='i686'.

    To write boot sector on the thumb drive I issued the following command.. Make sure to change the /dev/sdX as needed

    Code:
    sudo install-mbr --enable A1 --partition 1  --force --timeout 0  /dev/sdX
    ((
    Replace the "sdx" in /dev with the corect device. On my box it was "/dev/sdb1". You can find out what it is by mounting the the USB thumb drive and using the df comand. Look for the drive that has the same size as the thumb drive or look for the new one. d

    df output with thumb drive mounted

    ilesystem 1K-blocks Used Available Use% Mounted on
    /dev/sda3 20807216 3951644 15806932 20% /
    none 1025920 0 1025920 0% /dev/shm
    /dev/sda1 132221 16147 109247 13% /boot
    /dev/sda4 220285256 68871332 140312208 33% /home
    /dev/sdb1 1002056 198852 803204 20% /media/disk
    ))

    You will need image of a bootable Floppy...(I don't think you really need to do this step because you are not booting into the USB drive... But it is your BIOS so don't mess around)

    The file here http://www.fdos.org/bootdisks/autogen/FDOEM.144.gz contains bootable image of a basic (OEM) Freedos floppy disk, this version does not contain himem.sys so it is suitable for flashing bios. I have extracted it into home directory using Ark but you can use anything you like
    Or just type in command

    Code:
    cd ~
    gunzip FDOEM.144.gz
    (I have put "cd ~" to make sure that your terminal is located in the user's home folder, I also assume that you have saved the file in the home folder).

    Create new folder in your home folder, either from GUI or by issuing the following command

    Code:
    cd ~
    mkdir fdoem144
    Then mount the image FDOEM.144 into the folder you have created above by issuing following commands

    Code:
    cd ~
    modprobe loop
    sudo mount -o loop FDOEM.144 fdoem144
    Now you can just use dolphin/GNOME Konqueror/KDE. Open a few windows for /fdoem144, the usb sick (just click on the desktop icon), and the BIOS .ROM file. Drag and drop all the files from ~/fdoem144 and the .ROM file to the USB thumb drive.

    Or you can just run these 2 comands in the shell (( LOOK, These commands copy the files to the "Mount Point" where the thumb drive is mounted you can find the corect mount point with the df command))

    Code:
    cp ~/fdoem144/* /media/disk
    cp ~/06CN29WW.ROM /media/disk
    Now clean up the junk

    Code:
    sudo sync
    sudo unmount ~/fdoem144
    rmdir ~/fdoem144
    rm ~/06CN31WW.ROM
    rm ~/06CN31WW.bios.update.tar.gz
    Then reboot with the USB thumb drive in and hit F2 when the "Lenovo Logo" BIOS POST screen appears to enter the CMOS. Go over to BOOT tab and go down to HardDrive (Not Boot Order) then select the USB Thumb Drive as the 1st hard drve. Then F10 and yes to save changes. Then when the Lenovo BIOS POST Screen appers on reboot hit F4 to enter the BIOS FLASHING program. The USB Thumb Drive will be seen as the C: drive. Select the .ROM file in the list on the Right of the screen and start the BIOS FLASH. (NOTE: Your hart may stop beating... This is normal) Pray to any God you know of and your computer should restart just like normal. Hit F2 and the BIOS will now stay it is 06CN29WW. You will need to set the boot order to the way you like it and other things if you need to because they have been changed to the default.

    Thanks To wyth For the .ROM file. That takes a big pain in the *** step out of it

    Well, for some reson I am haveing problems compressing the new .ROM fiel. but you can just use wine to extract it.in the meen time
    Attached Files Attached Files
    Last edited by HunterThomson; December 7th, 2009 at 02:31 AM.
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

  5. #5
    Join Date
    Jun 2007
    Beans
    11,152

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    I have a script that installs ALSA 1.0.17 http://ubuntuforums.org/showthread.php?t=820959

    If you folks find a certain model= keyword works better than others, let me know so I can add it to the list (in the thread linked above).
    Last edited by Temüjin; July 31st, 2008 at 11:15 AM.

  6. #6
    Join Date
    Jan 2008
    Beans
    13

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    did the bios update improve performance or fix any problems? i don't really want to mess with my bios unless it's gonna solve something.

  7. #7
    Join Date
    Nov 2006
    Location
    London
    Beans
    12
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Quote Originally Posted by Temüjin View Post
    I have a script that installs ALSA 1.0.17 http://ubuntuforums.org/showthread.php?t=820959

    If you folks find a certain model= keyword works better than others, let me know so I can add it to the list (in the thread linked above).
    Not sure if you got the answer already..
    model=6stack-dell works with alsa right out of the box. The headphones work and mute the speakers and 5.1 works.

    Got it from here: http://techspalace.blogspot.com/2009...in-ubuntu.html

    My mic still doesn't work with skype
    If anyone can get it working too, then lenovo y530(y510) has really no reason for me to switch to windows.

    Also what is the status of suspend/hibernate? Doesn't work for me

    Cheers,
    Arun
    Last edited by akarun; June 24th, 2009 at 01:02 PM. Reason: Forgot to add more details

  8. #8
    Join Date
    Mar 2009
    Beans
    4

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Has anyone figured out how to get the microphone working on their Y510, and if so can you post step-by-step instructions or point me to ones that already exist? My sound is working beautifully. I just need my microphone to work.

    Thanks!
    Last edited by vonmars; July 19th, 2009 at 07:28 PM.

  9. #9
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Quote Originally Posted by vonmars View Post
    Has anyone figured out how to get the microphone working on their Y510, and if so can you post step-by-step instructions or point me to ones that already exist? My sound is working beautifully. I just need my microphone to work.

    Thanks!
    you need to open the ALSAmixer and find where it has the mic options. You need to set both mic's to "Front mic".
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

  10. #10
    Join Date
    Mar 2009
    Beans
    4

    Re: Lenovo Ideapad Y510 is Go (Continued / NEW)

    Quote Originally Posted by HunterThomson View Post
    you need to open the ALSAmixer and find where it has the mic options. You need to set both mic's to "Front mic".
    I have tried just about every combination I can imagine in the Alsa mixer. I have three sliders relating to microphone. Plain old microphone, front microphone and mic boost. Microphone seems to do nothing. I have it set to front mic. When I raise the mic boost slider it produces some pretty irritating feedback, but when I test the audio recording the mic is still not working. Any other ideas? Thanks for your help.
    Last edited by vonmars; July 20th, 2009 at 07:07 PM.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •