Page 68 of 68 FirstFirst ... 1858666768
Results 671 to 680 of 680

Thread: How-To: Creative X-Fi

  1. #671
    Join Date
    Aug 2011
    Location
    Wales
    Beans
    33
    Distro
    Ubuntu 11.04 Natty Narwhal

    Unhappy Re: How-To: Creative X-Fi

    I just got a brand-new custom system with a Creative X-Fi Xtreme Audio card. Output is excellent, but several microphones I've tried don't work at all. I gather that there's a problem with FlexiJack, and that the driver's probably the source of the trouble. I know nothing.

    Anyone know how to get a working driver for this thing? Does one even exist?

    I'm running Ubuntu 11.04 with all updates.

  2. #672
    Join Date
    Apr 2010
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How-To: Creative X-Fi

    Stratoliner,

    I just wanted to thank you for your help in trying to get my sound card working. All I end up doing is getting hunk errors everywhere. Maybe because I have one of the original X-Fi Titanium PCI-e (not the HD, even though it still is the 20k2 chip) is part of the reason it's not working, but I doubt it. For now, I'm going back to 10.04.

    I also wanted to thank everybody else here that has tried to and sometimes successfully get me up and running. This thread has been the most open to helping people with problems, and it seems if you go elsewhere, the first thing they do is redirect you here. I've tried both Launchpad and the ALSA sites, and that's what they did, unfortunately offering very little more assistance.

    I'll have to give 11.10 a shot when it officially comes out to see if anything works and if it does for me, I'll post back.

    Thank you all again,

    notacluenoob

  3. #673
    Join Date
    Apr 2007
    Beans
    21

    Re: How-To: Creative X-Fi

    Well, 11.10 officially kills any working Creative X-Fi Titanium card.

    Had it nice and working in 11.04, guess 11.10 breaks it ALL over again with no chance to fit it this time though.

    If anyone know how to get it working on 11.10 please let us know.

  4. #674
    Join Date
    Sep 2007
    Beans
    572
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: How-To: Creative X-Fi

    Quote Originally Posted by terran4000 View Post
    Well, 11.10 officially kills any working Creative X-Fi Titanium card.

    Had it nice and working in 11.04, guess 11.10 breaks it ALL over again with no chance to fit it this time though.

    If anyone know how to get it working on 11.10 please let us know.

    Mine worked out of the box in 11.10. Then I ran some update, rebooted, and voila! No sound.

    The system recognizes the card and it THINKS it's working, but I have no sound output.

  5. #675
    Join Date
    Sep 2007
    Beans
    572
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: How-To: Creative X-Fi

    Just for grins, tried this with 11.10 and it won't compile. Make spits out errors.

  6. #676
    Join Date
    Apr 2007
    Beans
    21

    Talking Re: How-To: Creative X-Fi

    So I finally wrote up the tutorial about how I got the X-Fi tamed and working under 11.04. Good luck yee to venture into 11.10, no easy alsa upgrades for you.

    Hope this will help some people get their X-Fi (titanium) working AND with 5.1 digital surround sound!

    http://www.piotrkrzyzek.com/creative...und-on-ubuntu/

  7. #677
    Join Date
    May 2008
    Beans
    113

    Re: How-To: Creative X-Fi

    Quote Originally Posted by kooldino View Post
    Mine worked out of the box in 11.10. Then I ran some update, rebooted, and voila! No sound.

    The system recognizes the card and it THINKS it's working, but I have no sound output.
    Me too, I was just trying to install some PulseAudio equalizer, so I added some PPAs to get it, apt-get-updated it, and now my X-fi sound card is greyed out in the sound preferences. This is on Kubuntu, but I guess the kernel is the same.

  8. #678
    Join Date
    Mar 2011
    Beans
    156
    Distro
    Ubuntu Development Release

    Re: How-To: Creative X-Fi

    Something has to work because as deaf as I am, I am pretty sure that I am hearing something that sounds pretty good out of my speakers. (not titanium though) and not 11.10. I just think that there has to be some way for things that worked fine in 11.04 to also work in 11.10. I do not care if I have to do a bit of work to get things working but would like to do something to make it work.
    Dell XPS 8300, Intel core I7-2600, 12 GB ram, 2 TB HDD, AMD Radeon 6770, Soundblaster X-fi Xtreme, Dell 24" monitor, Ubuntu 12.04 and 12.10-testing

  9. #679
    Join Date
    Apr 2007
    Beans
    21

    Talking Re: How-To: Creative X-Fi

    After playing around with some code, and lots of research I did manage to get the Titanium X-Fi working on Ubuntu 11.10 and it even works on the latest kernel 3.0.0-16 in x64.

    http://www.piotrkrzyzek.com/solved-c...-ubuntu-11-10/

  10. #680
    Join Date
    Dec 2007
    Beans
    14

    Re: How-To: Creative X-Fi

    Is terran4000's fix still valid for 12.04?

Page 68 of 68 FirstFirst ... 1858666768

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •