Results 1 to 5 of 5

Thread: boot flag set unused ntfs partition

  1. #1
    Join Date
    Jul 2008
    Beans
    33

    boot flag set unused ntfs partition

    Thread title pretty much explains it. Windows is installed in ide drive /dev/sda1 (ntfs fs). Sata drive #1 is /dev/sdb and splits an ntfs partition with a fat32. Ubuntu is on Sata drive #2 with a root, boot, home partition and a swap. I uncheck the Sata #1 ntfs boot flag and boot up.

    Windows complains NTLDR is missing and fails to boot.

    My ubuntu partition manager finds a boot flag in the Sata #1 ntfs partition which has no OS (it does have archival stuff) and I unmount the partition, unset the flag and quit.

    Launch again and same thing happens, so I ctl+alt+del and go into ubuntu and ya know, the frikkn boot flag has been set again in the 2nd ntfs partition. Windows doesn't even load yet it's setting a boot flag in the wrong partition.

    /boot/grub/menu.lst hasn't changed. Before downloading 'gnash' a flash plugin is the last launch before discovering this. Before that I updated to kernel 2.6.24-20-generic and all seemed well. I got back into Ubuntu, right? Now I am stumped. Anyone know how this is happening and how to correct it?

  2. #2
    Join Date
    Apr 2008
    Beans
    10,345

    Re: boot flag set unused ntfs partition

    And you're doing this in Gparted, aka Partition Editor, and you're clicking "apply" and waiting until it's applied?

    I'll tell you partitioning is touchy! Even changing "boot" flags.

    You can't "apply" changes in a "mounted" partition and have them actually "apply" so maybe you just need to use a Live CD

  3. #3
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: boot flag set unused ntfs partition

    Sounds like your windows stanza in menu.lst is pointing to the ntfs data partition on sdb, and the 'makeactive' option is setting the boot flag each time.

    gksudo gedit /boot/grub/menu.lst

    If sda is the Bios boot disk, your windows root line should be (hd0,0). If sdb is the boot disk, then (hd1,0) + map lines.

  4. #4
    Join Date
    Jul 2008
    Beans
    33

    Re: boot flag set unused ntfs partition

    k thank youse guys, I'm on it. brb with the latest headlines ;p

  5. #5
    Join Date
    Jul 2008
    Beans
    33

    Re: boot flag set unused ntfs partition

    I went into root user and did a quick update-grub from there. The indications were that, even taking into account the observations you guys have rightly made, that the system settings were okay and I probably did the update-grub incorrectly (from the wrong account).

    The update-grub seems to have taken well, a last look inside the partition table showed no flag in /dev/sdb afterward and I quickly looked at bios nothing changed in there.

    I soulmarked Logos for a x1 thanks, the info clarified a hazy area for me. Grats ;p

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •