Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Grub not booting error loading operating system

  1. #11
    Join Date
    May 2008
    Beans
    791
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: Grub not booting error loading operating system

    Quote Originally Posted by Pumalite View Post
    Post your menu.lst
    Here is my menu.lst:

    # menu.lst - See: grub(8 ), info grub, update-grub(8 )
    # grub-install(8 ), grub-floppy(8 ),
    # grub-md5-crypt, /usr/share/doc/grub
    # and /usr/share/doc/grub-doc/.

    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not change this entry to 'saved' or your
    # array will desync and will not let you boot your system.
    default 0

    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout 10

    # Pretty colours
    color cyan/blue white/blue

    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line) and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    # password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret

    #
    # examples
    #
    # title Windows 95/98/NT/2000
    # root (hd0,0)
    # makeactive
    # chainloader +1
    #
    # title Linux
    # root (hd0,1)
    # kernel /vmlinuz root=/dev/hda2 ro
    #

    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below

    ## DO NOT UNCOMMENT THEM, Just edit them to your needs

    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specific kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    ## kopt_2_6_8=root=/dev/hdc1 ro
    ## kopt_2_6_8_2_686=root=/dev/hdc2 ro
    # kopt=root=/dev/sda1 ro vga=791 splash=silent

    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd1,0)

    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ## alternative=false
    # alternative=true

    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ## lockalternative=false
    # lockalternative=false

    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=

    ## should update-grub lock old automagic boot options
    ## e.g. lockold=false
    ## lockold=true
    # lockold=false

    ## Xen hypervisor options to use with the default Xen boot option
    # xenhopt=

    ## Xen Linux kernel options to use with the default Xen boot option
    # xenkopt=console=tty0

    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ## altoptions=(single-user) single
    # altoptions=(single-user mode) single

    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ## howmany=7
    # howmany=all

    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ## memtest86=false
    # memtest86=true

    ## should update-grub adjust the value of the default booted system
    ## can be true or false
    # updatedefaultentry=false

    ## ## End Default Options ##

    title 64studio, kernel 2.6.21-1-multimedia-486
    root (hd1,0)
    kernel /boot/vmlinuz-2.6.21-1-multimedia-486 root=/dev/sda1 ro vga=791 splash=silent
    initrd /boot/initrd.img-2.6.21-1-multimedia-486
    savedefault

    title 64studio, kernel 2.6.21-1-multimedia-486 (single-user mode)
    root (hd1,0)
    kernel /boot/vmlinuz-2.6.21-1-multimedia-486 root=/dev/sda1 ro vga=791 splash=silent single
    initrd /boot/initrd.img-2.6.21-1-multimedia-486
    savedefault

    title 64studio, kernel memtest86
    root (hd1,0)
    kernel /boot/memtest86.bin

    title 64studio, kernel memtest86+
    root (hd1,0)
    kernel /boot/memtest86+.bin

    ### END DEBIAN AUTOMAGIC KERNELS LIST

    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title Other operating systems:
    root


    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1
    title Microsoft Windows XP Home Edition
    root (hd0,0)
    savedefault
    makeactive
    chainloader +1



    Since I did a full reinstall of both operating systems, I CAN get into them both from the F12 boot menu, but Grub will NOT load up on machine start up. It always yeilds an "Error: Cannot Load Operating System" message.

    I did look over this menu.lst carefully and I didn't see anything in regards to where Grub is set up to appear upon bootup.

    According to my BIOS it SHOULD appear on the IDE Master Drive C:, but it instead appears on my Primary Master Drive. The F12 menu list has these listed separately and, yes, if I select IDE Master Drive C (or Normal boot) I will get the infamous error message above.

    So it would see though from the error message, Grub moved something that it shouldn't have. I am wondering if that is something that can be fixed or if not, if it is possible to delete Grub and use a different boot loader.

    Thanx,
    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  2. #12
    Join Date
    Feb 2007
    Location
    Maryland, USA
    Beans
    3,396
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub not booting error loading operating system

    One thought about your BIOS choices. It is a little strange that your BIOS gives you the choice of a C: drive. That is the name of a partition, in DOS/Windows format. Unless you specifically installed grub to that partition, there would not be a boot loader there. Usually, the default is to install grub to the MBR of the boot disk, which is not a part of any partition.

    There is some confusion about this, because many Windows users have only one partition, and they are used to thinking of C: as a disk. But it is really a partition. And, some BIOSes have the capacity to boot a partition, so it makes sense.

    Maybe you could figure out which partition is C: and re-install grub there. It might them make your BIOS happy, even though it is a bit non-standard. I would think you should be able to tell your BIOS to boot the "Primary Master Hard Drive", which probably means the MBR of one of the drives, by some part of its menu. Since it works if you pick this from the F12 boot choices, you know that grub is installed correctly somewhere, probably the MBR of one of the disks. Look for a BIOS menu choice that lets you designate the Primary Master drive, and see if you can change it.

  3. #13
    Join Date
    Mar 2007
    Location
    Here & Now
    Beans
    16,549
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Grub not booting error loading operating system

    You have a mix of SATA and IDE. Search in the Forum for Dualbooting Two Hard Drives. BTW, Super Grub is a great disk to have around and you'll never 'waste' a CD with it.
    Last edited by Pumalite; July 25th, 2008 at 08:38 PM.

    Dr. Fernando Duran Dollenz
    Libertad 584
    6824871

  4. #14
    Join Date
    May 2008
    Beans
    791
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: Grub not booting error loading operating system

    Quote Originally Posted by dstew View Post
    One thought about your BIOS choices. It is a little strange that your BIOS gives you the choice of a C: drive. That is the name of a partition, in DOS/Windows format. Unless you specifically installed grub to that partition, there would not be a boot loader there. Usually, the default is to install grub to the MBR of the boot disk, which is not a part of any partition.
    Well, I will say that Dell created the Bios and for the most part (and up until recently) they only been using Windows. So it could very be they set up the Bios to look for a C: partition to boot from.

    Maybe you could figure out which partition is C: and re-install grub there. It might them make your BIOS happy, even though it is a bit non-standard.
    Ahhh, now that is the weird thing. On my IDE primary hard drive there are only two partitions that I know about. One is set (by me) as a FAT32 for storage, so there is only ONE partition left. Something is wrong with boot table, that is what I think.

    I would think you should be able to tell your BIOS to boot the "Primary Master Hard Drive",
    Perhaps, that would make sense, but keep in mind, this is a Dell machine, so they are doing to do what THEY want with the Bios, not what is considered standard. According to my Bios, it will ONLY boot from a drive that is designated as IDE Primary C:. I will not boot from secondary drives.

    . Since it works if you pick this from the F12 boot choices, you know that grub is installed correctly somewhere, probably the MBR of one of the disks. Look for a BIOS menu choice that lets you designate the Primary Master drive, and see if you can change it.
    I don't think it can be changed. I looked several times. It is also true that I am not 100% sure what the master primary drive is. I am guessing that it is the C: drive, but I could be wrong about that. For some reason on the boot menu they are separting the C: designation from the master primary drive. The C designation IS in the boot up list for primary boot up device, however, if I click on this in the Boot Menu, I get the error message. So it would seem that some how Grub moved the MBR away from the C: designated drive. And because I can't re-assign the boot up through Bios...I'm stuck.

    Now the really really weird thing is that with straight Ubuntu, I didn't have this problem. Grub worked.

    I will say that Grub does look different from when I went to Ubuntu to Ubuntu Studio and now I am on 64Studio.

    Anyway I want to try a trick. Is there a way I can turn off Grub, I want to see if my machine will boot back directly to Windows.

    EDIT:

    Ok, I went back into Bios and I confirmed that in the boot order for the drives the Choices are IDE Hard Disk C:, Floppy, IDE CD-Rom, and USB. The Hard disk designation CANNOT be changed. Over in the F12 menu there is the IDE Hard Disk C label as well and if I click on that I get the error. More then likely on a normal boot, this is the drive the Bios is pointing to. So if I pick Primary Master Drive (which by the way isn't giving a clear indication if this is the IDE drive or the SATA drive) it works.

    So my guess is if Grub is working on THIS Primary Master Drive, it moved the MBR to this drive as well. So it would make sense if the MBR and Grub were moved back to the C: designated drive, my machine should boot normally.

    So this all is confirming Grub did something it shouldn't have. However, the thing is this...where is Grub?

    Thanx,

    Geo
    Last edited by jukingeo; July 25th, 2008 at 11:00 PM.
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  5. #15
    Join Date
    Feb 2007
    Location
    Maryland, USA
    Beans
    3,396
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub not booting error loading operating system

    Without doing any experiments, it seems your BIOS will only boot the IDE drive, unless you use the F12 boot menu. It is calling the IDE drive "C:" even though this is not really correct, since C: really is a name for a Windows or DOS partition, and not a proper disk name.

    The MBR (Master Boot Record) is a region of a hard disk that is set aside for a boot loader and a disk partition table. It is part of the first track on the disk, and not part of any partition. An MBR may or may not have a boot loader in it, but it will have a partition table, if there are any file systems on the disk.

    However, the thing is this...where is Grub?
    There is a way to see if grub is in the MBR of a particular disk. You can use the program lde (Linux Disk Editor) to get a data dump of sector 0 on a drive. If grub is there, you will see the brief messages it contains in the ASCII translation of the data dump for that sector. Here is the data dump of sector 0 (the Master Boot Record) on my first hard disk:
    Code:
    0x00000000  EB 48 90 D0 BC 00 7C FB : 50 07 50 1F FC BE 1B 7C  .H....|.P.P....|
    0x00000010  BF 1B 06 50 57 B9 E5 01 : F3 A4 CB BD BE 07 B1 04  ...PW...........
    0x00000020  38 6E 00 7C 09 75 13 83 : C5 10 E2 F4 CD 18 8B F5  8n.|.u..........
    0x00000030  83 C6 10 49 74 19 38 2C : 74 F6 A0 B5 07 B4 03 02  ...It.8,t.......
    0x00000040  FF 00 00 20 01 00 00 00 : 00 02 FA 90 90 F6 C2 80  ... ............
    0x00000050  75 02 B2 80 EA 59 7C 00 : 00 31 C0 8E D8 8E D0 BC  u....Y|..1......
    0x00000060  00 20 FB A0 40 7C 3C FF : 74 02 88 C2 52 BE 7F 7D  . ..@|<.t...R..}
    0x00000070  E8 34 01 F6 C2 80 74 54 : B4 41 BB AA 55 CD 13 5A  .4....tT.A..U..Z
    0x00000080  52 72 49 81 FB 55 AA 75 : 43 A0 41 7C 84 C0 75 05  RrI..U.uC.A|..u.
    0x00000090  83 E1 01 74 37 66 8B 4C : 10 BE 05 7C C6 44 FF 01  ...t7f.L...|.D..
    0x000000A0  66 8B 1E 44 7C C7 04 10 : 00 C7 44 02 01 00 66 89  f..D|.....D...f.
    0x000000B0  5C 08 C7 44 06 00 70 66 : 31 C0 89 44 04 66 89 44  \..D..pf1..D.f.D
    0x000000C0  0C B4 42 CD 13 72 05 BB : 00 70 EB 7D B4 08 CD 13  ..B..r...p.}....
    0x000000D0  73 0A F6 C2 80 0F 84 EA : 00 E9 8D 00 BE 05 7C C6  s.............|.
    0x000000E0  44 FF 00 66 31 C0 88 F0 : 40 66 89 44 04 31 D2 88  D..f1...@f.D.1..
    0x000000F0  CA C1 E2 02 88 E8 88 F4 : 40 89 44 08 31 C0 88 D0  ........@.D.1...
    0x00000100  C0 E8 02 66 89 04 66 A1 : 44 7C 66 31 D2 66 F7 34  ...f..f.D|f1.f.4
    0x00000110  88 54 0A 66 31 D2 66 F7 : 74 04 88 54 0B 89 44 0C  .T.f1.f.t..T..D.
    0x00000120  3B 44 08 7D 3C 8A 54 0D : C0 E2 06 8A 4C 0A FE C1  ;D.}<.T.....L...
    0x00000130  08 D1 8A 6C 0C 5A 8A 74 : 0B BB 00 70 8E C3 31 DB  ...l.Z.t...p..1.
    0x00000140  B8 01 02 CD 13 72 2A 8C : C3 8E 06 48 7C 60 1E B9  .....r*....H|`..
    0x00000150  00 01 8E DB 31 F6 31 FF : FC F3 A5 1F 61 FF 26 42  ....1.1.....a.&B
    0x00000160  7C BE 85 7D E8 40 00 EB : 0E BE 8A 7D E8 38 00 EB  |..}.@.....}.8..
    0x00000170  06 BE 94 7D E8 30 00 BE : 99 7D E8 2A 00 EB FE 47  ...}.0...}.*...G
    0x00000180  52 55 42 20 00 47 65 6F : 6D 00 48 61 72 64 20 44  RUB .Geom.Hard D
    0x00000190  69 73 6B 00 52 65 61 64 : 00 20 45 72 72 6F 72 00  isk.Read. Error.
    0x000001A0  BB 01 00 B4 0E CD 10 AC : 3C 00 75 F4 C3 00 00 00  ........<.u.....
    0x000001B0  00 00 00 00 00 00 00 00 : 76 7A 07 00 00 00 80 01  ........vz......
    0x000001C0  01 00 07 FE FF FF 3F 00 : 00 00 AF C7 45 04 00 FE  ......?.....E...
    0x000001D0  FF FF 83 FE FF FF EE C7 : 45 04 0C F1 02 00 00 FE  ........E.......
    0x000001E0  FF FF 83 FE FF FF FA B8 : 48 04 C0 14 2A 01 00 FE  ........H...*...
    0x000001F0  FF FF 05 FE FF FF BA CD : 72 05 C4 5A DD 03 55 AA  ........r..Z..U.
    0x00000200  52 56 BE 03 21 E8 2A 01 : 5E BF F8 21 66 8B 2D 83  RV..!.*.^..!f.-.
    0x00000210  7D 04 00 0F 84 CA 00 80 : 7C FF 00 74 3E 66 8B 1D  }.......|..t>f..
    0x00000220  66 31 C0 B0 7F 39 45 04 : 7F 03 8B 45 04 29 45 04  f1...9E....E.)E.
    0x00000230  66 01 05 C7 04 10 00 89 : 44 02 66 89 5C 08 C7 44  f.......D.f.\..D
    0x00000240  06 00 70 50 66 31 C0 89 : 44 04 66 89 44 0C B4 42  ..pPf1..D.f.D..B
    0x00000250  CD 13 0F 82 9F 00 BB 00 : 70 EB 56 66 8B 05 66 31  ........p.Vf..f1
    0x00000260  D2 66 F7 34 88 54 0A 66 : 31 D2 66 F7 74 04 88 54  .f.4.T.f1.f.t..T
    0x00000270  0B 89 44 0C 3B 44 08 7D : 74 8B 04 2A 44 0A 39 45  ..D.;D.}t..*D.9E
    0x00000280  04 7F 03 8B 45 04 29 45 : 04 66 01 05 8A 54 0D C0  ....E.)E.f...T..
    0x00000290  E2 06 8A 4C 0A FE C1 08 : D1 8A 6C 0C 5A 52 8A 74  ...L......l.ZR.t
    0x000002A0  0B 50 BB 00 70 8E C3 31 : DB B4 02 CD 13 72 46 8C  .P..p..1.....rF.
    0x000002B0  C3 8E 45 06 58 C1 E0 05 : 01 45 06 60 1E C1 E0 04  ..E.X....E.`....
    0x000002C0  89 C1 31 FF 31 F6 8E DB : FC F3 A4 1F BE 14 21 E8  ..1.1.........!.
    0x000002D0  60 00 61 83 7D 04 00 0F : 85 3C FF 83 EF 08 E9 2E  `.a.}....<......
    0x000002E0  FF BE 16 21 E8 4B 00 5A : EA 00 22 00 00 BE 19 21  ...!.K.Z.."....!
    0x000002F0  E8 3F 00 EB 06 BE 1E 21 : E8 37 00 BE 23 21 E8 31  .?.....!.7..#!.1
    0x00000300  00 EB FE 4C 6F 61 64 69 : 6E 67 20 73 74 61 67 65  ...Loading stage
    0x00000310  31 2E 35 00 2E 00 0D 0A : 00 47 65 6F 6D 00 52 65  1.5......Geom.Re
    0x00000320  61 64 00 20 45 72 72 6F : 72 00 BB 01 00 B4 0E CD  ad. Error.......
    0x00000330  10 46 8A 04 3C 00 75 F2 : C3 00 00 00 00 00 00 00  .F..<.u.........
    0x00000340  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x00000350  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x00000360  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x00000370  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x00000380  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x00000390  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x000003A0  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x000003B0  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x000003C0  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x000003D0  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x000003E0  00 00 00 00 00 00 00 00 : 00 00 00 00 00 00 00 00  ................
    0x000003F0  00 00 00 00 00 00 00 00 : 02 00 00 00 0F 00 20 02  .............. .
    You can see the "Loading stage 1.5" message in the ASCII (text translation) column, which shows that there is a grub boot loader there. You could do this to figure out where your grub went. You would need to boot a Live CD, install lde using Synaptic, and in a terminal issue the command
    Code:
    sudo lde -b 0 /dev/sda | more
    This assumes your disks are named sda, sdb etc. If they are named hda etc, use those names. You can look at a raw data dump of the MBR of each disk this way.

    This is just my experimental brain at work. More directly, you should just re-install grub to the IDE drive. Here are instructions on doing that.
    Last edited by dstew; July 26th, 2008 at 06:02 PM.

  6. #16
    Join Date
    May 2008
    Beans
    791
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: Grub not booting error loading operating system

    Quote Originally Posted by Pumalite View Post
    You have a mix of SATA and IDE. Search in the Forum for Dualbooting Two Hard Drives. BTW, Super Grub is a great disk to have around and you'll never 'waste' a CD with it.
    Guess what? I got the best of both worlds. I found out that the Super Grub installations has USB and Floppy versions as well. I very rarely use my floppy drive, so I downloaded the Super Grub .iso and downloaded it to a Floppy.

    Now here is something else I found out this afternoon. The Grub bootloader on the 64Studio installation WILL NOT WORK, even booting from a floppy, it STILL manipulates the MBR on the Windows drive. In fact this afternoon it blew out my Windows so bad, I could use the repair option on the Windows installation disk, I had to redo Windows ALL OVER again.

    Now I have a question for you about Super Grub before I use it.

    1) Will it stay AWAY from my Windows MBR?
    2) I don't care if I need a floppy to boot up 64Studio or Ubuntu for that matter. I just want any bootloader I use to stay away from the Windows MBR.

    I don't know what it is, but for some reason my machine wants to see the Windows MBR pointing to the C: drive. My computer's Bios LOOKS for the C: drive.

    Again, I didn't have this problem with the standard Ubuntu installation. It's Grub worked fine.

    So I am willing to try Super Grub or another bootloader altogether (I am thinking Lilo here), but I want it to stay away from the Windows drive and it's MBR...period.

    So with that smoke cleared out of the way...can Super Grub do this?

    Thanx,

    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  7. #17
    Join Date
    May 2008
    Beans
    791
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: Grub not booting error loading operating system

    Quote Originally Posted by dstew View Post
    Without doing any experiments, it seems your BIOS will only boot the IDE drive, unless you use the F12 boot menu. It is calling the IDE drive "C:" even though this is not really correct, since C: really is a name for a Windows or DOS partition, and not a proper disk name.

    The MBR (Master Boot Record) is a region of a hard disk that is set aside for a boot loader and a disk partition table. It is part of the first track on the disk, and not part of any partition. An MBR may or may not have a boot loader in it, but it will have a partition table, if there are any file systems on the disk.

    Hello dstew,

    I had another disaster this afternoon when I attempted to create 64Studio with a boot off of a floppy. I figured that when I installed it that when it came to part to install Grub, that I could tell it to set itself up on a floppy. Then I could boot my machine from the floppy and from there make my choice.

    However, once again...EVEN with a floppy boot, Grub decided to alter the Windows MBR. This time it was so bad that I had to delete the Windows partition (the repair option on the Windows installation disk wouldn't work).

    At this point now I am fed up with Grub trying to mess around with the Windows hard drive and the MBR.

    I did find out that the version of Grub isn't the same on the 64Studio install when compared to that of standard Ubuntu. Ubuntu has a better version of Grub. BUT the thing is with the 64Studio installation, you are pretty much forced to use IT's Grub.

    I didn't want to try the CD-Rom or USB methods because if I can't do a boot from a Floppy without grub messing up the Windows MBR, then I am pretty sure the other installations will mess it up too.

    So the only thing that I can think of (and it was also suggested to me by someone else), is now that I have Windows running again, is to disconnect the Windows IDE drive from my machine. Thus an install of 64Studio on my SATA drive would "FORCE" Grub to either load itself on the SATA drive or set up to boot from let's say a floppy drive. I figured once set up, Grub shouldn't touch the Windows drive anymore and I could reconnect it.

    Now I am not sure what will happen to my system Bios if it sees the SATA drive and no IDE drive. I would be hoping that it would see it as a bootable drive and as such make Grub happy.

    However, I am not totally sure what will happen after I plug my IDE drive back in. Would Grub try and take over the Windows hard drive again?

    At any rate I am willing to explore other bootloading options. I did find out that Super Grub can be set up from a floppy drive and I downloaded it and put it on a floppy, so I DO have Super Grub now.

    The only requirement I would like to make at this point is that I want ANY bootloader I use NOT interfere with the Windows drive MBR. It is working now and this is the last time I am reinstalling Windows. If that means I have to boot 64Studio/Ubuntu or whatever other version of Linux I use, I don't care. The bottom line is that I am sick of this particular version of Grub I been dealing with that constantly does what it wants to with the Windows MBR.

    So that is my main criteria right now. I don't want whatever choice of bootloader I end up using to mess with the Windows MBR.

    Thank You,

    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  8. #18
    Join Date
    Apr 2007
    Beans
    150
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: Grub not booting error loading operating system

    GRUB is the best bootloader out there hands down. You will not find a better one out there(unless GRUB2 ever comes about)

    Since it appears that you are mixing SATA and IDE drives, that could be part of the problem. I think I've seen somewhere that when you have a IDE plugged in, it tries to take the top spot.

    What dstew posted about going into a grub shell and doing the root (hd0,0)/ setup (hd0) thing is exactly correct. The only problem appears to be that it may be hd1 that you need to set up(I come to this conclusion from looking at your menu.lst).

    Other than that, once you have GRUB installed to the MBR of the correct drive, you need to make sure that your BIOS is set up to boot from that drive first. I know that it can get very confusing what drive is what if you start switching orders, but if you can get to the GRUB bootup menu, then you can edit the lines before you boot and that will definitely nail down whether it's looking at the wrong drive.

    Take a look at the links in my sig. This is how I am booting several distros at the same time by keeping GRUB in the MBR and GRUB's data in it's own partition. Once you understand what he has posted, you should never have to reinstall any bootloader ever again until your drive fails.

  9. #19
    Join Date
    May 2008
    Beans
    791
    Distro
    Ubuntu Studio 14.04 Trusty Tahr

    Re: Grub not booting error loading operating system

    Quote Originally Posted by red_team316 View Post
    GRUB is the best bootloader out there hands down. You will not find a better one out there(unless GRUB2 ever comes about)
    Well, that may be true of the newer version, but the one that comes with 64Studio isn't winning any awards with me. For one..why should it alter my Windows MBR if I want to boot from a floppy? That isn't good and it isn't fun either.

    Since it appears that you are mixing SATA and IDE drives, that could be part of the problem. I think I've seen somewhere that when you have a IDE plugged in, it tries to take the top spot.
    Yes, that would make sense, but the IDE drive IS in the top spot, it is the first drive.

    Other than that, once you have GRUB installed to the MBR of the correct drive, you need to make sure that your BIOS is set up to boot from that drive first. I know that it can get very confusing what drive is what if you start switching orders, but if you can get to the GRUB bootup menu, then you can edit the lines before you boot and that will definitely nail down whether it's looking at the wrong drive.
    Ok, on the Dell machine I have, these are my booting options (meaning when you push the power button on you have your choices of these boot optons).

    1) IDE Hard Drive C:
    2) Floppy Diskette
    3) IDE CD-Rom
    4) USB

    (You can change the boot priority though, so I can have BIOS boot from the USB first if I want and if there isn't anything there, it would move down the line until it hits a bootable operating system).

    Upon boot up you also have the option to punch in F12 and from there I get these options:

    1) Normal
    2) SATA
    3) Primary Master Drive
    4) IDE Hard Drive C:
    5) Floppy Diskette (I forgot to add this in past listings)
    6) IDE CD-ROM
    7) USB Bootable drive

    So as you can see I have many more selections from punching in F12 and using the boot menu. Notice that from the BIOS boot the ONLY hard drive selection I can make is IDE Hard Drive C:.

    While this may seem stupid for a company to make a machine that has only this kind of boot option for a hard drive...keep in mind that it was only recently that Dell was supplying machines with Linux installed. So for the longest time, Dell only had to make their machines boot into Windows.

    Now with Windows on my machine, I can boot Normal, into the C: drive via the F12 menu. Windows will also boot up upon power up.

    However, with Grub installed, it seems to want to move the MBR to the Primary Master Drive designation. Now I don't know what that is. But the thing is that Normal boot and IDE Hard Drive Boot NO LONGER WORK, and produce the No operating system error.

    However, going into F12 I can punch in the Primary Master Drive selection and Grub would come up and then I could boot into Windows or Linux.

    So I guess the point I am trying to say is that I CAN'T boot from any other hard drive BUT the one that pointing to IDE Hard Drive C:

    Now I don't know what would happen if I pull the IDE drive and just boot to the SATA drive. This option COULD change. In fact I did want to try a test by attempting to load 64Studio back on the SATA drive BUT WITH THE WINDOWS IDE DRIVE PULLED. This way Grub would have no choice but to install elsewhere AND it shouldn't mess with the Windows MBR.


    Take a look at the links in my sig. This is how I am booting several distros at the same time by keeping GRUB in the MBR and GRUB's data in it's own partition. Once you understand what he has posted, you should never have to reinstall any bootloader ever again until your drive fails.
    I will take a peek at it, but according to the way my system is set up, I have an odd-ball BIOS on my machine that wants to see something bootable on the IDE Hard Drive C:. So if there isn't something there, then I can understand why I get the error message.

    Overall, it seems to me that Grub is putting itself where it shouldn't be...in reference to my machine and it's BIOS. Of course Grub doesn't care because the assumption is that I can change my Bios to a different bootable hard drive. But the fact is I can't.

    I really think that unless there is a sure fire way I can pull this off, I really don't want Grub (or any other bootloader for that matter) even touching the Windows boot MBR any more. I would rather have a floppy boot up my Linux drive and keep away from the Windows MBR.

    Can that be done? Would the Super Grub floppy disk I made help?

    The bottom line is that I would like to fix this situation so I can get back to making music and not fighting a bootloader program that keeps knocking out my Windows partition.

    Thank You,

    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  10. #20
    Join Date
    Feb 2007
    Location
    Maryland, USA
    Beans
    3,396
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub not booting error loading operating system

    Overall, it seems to me that Grub is putting itself where it shouldn't be
    Maybe the problem is not grub itself, but the 64Studio installer. Even with regular Ubuntu, grub does not install itself, but the installer's operating system (Linux) and installation program do it. Sometimes, it is that program making the mistake. Grub itself cannot alter the MBR of a disk unless you specifically direct it to do so with the setup command.

    What I would do in your case is get away from having the installer install grub. Usually there is an option. At least in the regular Ubuntu installer, right before it installs grub, there is a sceen with an Advanced tab, and you can choose not to install the boot loader at all. That is the best way to go if the installer keeps making a mistake when installing grub. Then, boot a real plain grub floppy, and install grub from there exactly where you want it to go. Grub has an auto-complete feature that lets you get directory listings, and drive geometry, so you can figure out exactly which drive is which before you set it up.

    I am not familiar with Ubuntu 64Studio. Maybe they have a forum that you can post on.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •