Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Grub not booting error loading operating system

  1. #1
    Join Date
    May 2008
    Beans
    788
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Grub not booting error loading operating system

    Hello all,

    I was wondering if someone could help me with a situation I am having with Grub.

    First a little background. I had Ubuntu working fine on a dual boot setup with Windows XP. Everything was fine with Grub and it did what it supposed to do. However, I had a partitioning accident and lost my Windows partition. Needless to say I spent a good 6 hours or so loading everything back on to Windows. BUT (there is always a BUT), Windows decided to replace Grub with a bootloader of it's own and of course it booted fine into Windows, but left Ubuntu in the dust.

    Being that I had problems with my Ubuntu partition to begin with I decided to nix it and start over. With reinstallation complete, I booted up the system and I get this error message:

    Error: Couldn't load operating system.

    And it just sits there.

    So I decided to try a "warm boot" from the boot menu instead. I selected the first drive and Grub came up! From here I can get into Ubuntu, but not Windows.

    So I have two problems I need to fix:

    1) Get rid of the error message on bootup
    2) Fix the Windows bootup selection.

    Any assistance would be much appreciated.

    Thank You,

    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  2. #2
    Join Date
    Mar 2007
    Location
    Here & Now
    Beans
    16,549
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Grub not booting error loading operating system

    I would check the partition table with rescuecd:
    http://www.sysresccd.org/Download
    You can fix your Windows MBR with Super Grub:
    http://users.bigpond.net.au/hermanzo...bDiskPage.html

    Dr. Fernando Duran Dollenz
    Libertad 584
    6824871

  3. #3
    Join Date
    May 2008
    Beans
    788
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Grub not booting error loading operating system

    Quote Originally Posted by Pumalite View Post
    I would check the partition table with rescuecd:
    http://www.sysresccd.org/Download
    You can fix your Windows MBR with Super Grub:
    http://users.bigpond.net.au/hermanzo...bDiskPage.html
    Hello,

    Thank you for responding, but do you have a solution that doesn't involve "wasting" a disc?

    Thank You,

    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  4. #4
    Join Date
    Feb 2007
    Location
    Maryland, USA
    Beans
    3,396
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub not booting error loading operating system

    The error message "Error: Couldn't load operating system" comes from the Vista boot loader. You probably messed up the Vista bootloader configuration when you re-installed Ubuntu. If you want to use the Vista boot loader to dual-boot Vista and Ubuntu, you will have to reconfigure it.

    I am not sure what you mean by a "warm boot". Is that a BIOS program, or possibly a part of the Vista boot loader? It does not sound like part of grub.

    I would recommend installing grub to dual boot Vista and Ubuntu. You can do this using the Ubuntu live CD. Open a terminal and enter
    Code:
    sudo grub
    That should get you the grub shell, with the grub> prompt. At the grub prompt, enter
    Code:
    find /boot/grub/stage2
    That should get you the name of the grub root partition in grub-speak, say (hd0,0). Whatever it returns, use as the argument for a root statement:
    Code:
    root (hd0,0)
    Then, install the boot loader into the MBR of the first hard disk, and quit:
    Code:
    setup (hd0)
    quit
    Hopefully you will get the grub menu at boot time. Let us know if Vista will boot from the grub menu item or not. If not, we should be able to configure grub to boot Vista.

  5. #5
    Join Date
    May 2008
    Beans
    788
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Grub not booting error loading operating system

    Hello Dstew,

    I am on Windows XP and not Vista. However, I did as you instructed and it didn't work. I still have both problems. On a cold boot (which means when you first turn on the machine) I still get the "Cannot load operating system" error. On a warm boot (you are booting to someplace with the machine already turned on...in this case I am instructing the computer to pull up the boot menu), going into the boot menu if I pick Windows, it still isn't loading it up.

    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  6. #6
    Join Date
    Mar 2007
    Location
    Here & Now
    Beans
    16,549
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Grub not booting error loading operating system

    Post your menu.lst

    Dr. Fernando Duran Dollenz
    Libertad 584
    6824871

  7. #7
    Join Date
    Feb 2007
    Location
    Maryland, USA
    Beans
    3,396
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub not booting error loading operating system

    Are you sure you have your BIOS set to boot the correct disk? You might have to tell it to boot from the hard disk where you installed grub. Did you get any error messages when you installed grub?

  8. #8
    Join Date
    May 2008
    Beans
    788
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Grub not booting error loading operating system

    Update:

    Frustrated with this problem, last night I wiped both operating systems from my machine COMPLETELY.

    My main drive is an 80gig IDE and the Linux drive is a 500gig SATA.

    This is what I did:

    1) Deleted both drives and deleted all partitions on the Sata drive so Windows will not even see that it exists.

    2) Installed Windows and tested it that it boots fine from start up.

    3) Reconfigure the Sata drive and installed Ubuntu

    4) Told Grub to install on the first disk MBR.

    Now when I tested the installation I still get the confounded "Error: Couldn't Load Operating System" message.

    However, if I go into the F12 boot menu I CAN now get into both Windows and Linux without a problem. So one issue was taken care of.

    So being that Windows booted fine prior to loading up Ubuntu and I have the same problem...AGAIN, I am assuming that Grub is causing the problem.

    The problem isn't with BIOS either as I did check it and it is correctly set up. Also the fact that Windows loaded in fine prior to the Ubuntu installation is further proof that the BIOS is OK.

    So something is wrong when the machine is first turned on. Also selecting "Normal" from the boot menu will also yeild the same error message. So something must be very wrong with the first part of the boot up procedure that tells the system which drive to boot up (so I can see why many are thinking that Bios is the problem). But it is software not firmware because the problem isn't happening with Windows alone. Also because I loaded everything up separately, the Windows bootloader was out of the question this time around.

    So at this point in time if I delete everything and start over, it will probably happen again. So I think I have to get right in there on the MBR and find the problem and fix it, or perhaps I should use a different bootloader than Grub.

    Any ideas or advice?

    Thank You,

    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  9. #9
    Join Date
    Feb 2007
    Location
    Maryland, USA
    Beans
    3,396
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Grub not booting error loading operating system

    Did you try to boot Windows after you put the SATA drive back, but before you installed Ubuntu? When you go to F12 and get a boot menu, does it give you choices of disks or partitions?

  10. #10
    Join Date
    May 2008
    Beans
    788
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Grub not booting error loading operating system

    Quote Originally Posted by dstew View Post
    Did you try to boot Windows after you put the SATA drive back, but before you installed Ubuntu? When you go to F12 and get a boot menu, does it give you choices of disks or partitions?
    I actually never removed the Sata drive. I effectively 'took it out of the picture' by deleting all the partitions so this way Windows couldn't see if the drive was there. If it can't see the drive, it can't find anything that could be interpreted as another operating system (such as the presence of another bootable partition).

    I then installed Windows and tested it. It booted fine like it normally would.

    Only then did I reset up the SATA drive and install 64Studio and Grub.

    Yes, F12 does work and I get these choices:

    1) Normal (Yeilds the NOS error)
    2) SATA (Also yeilds the error)
    3) Primary Master Hard Drive (This will give me the grub menu and I can get into both Windows and 64Studio from here).
    4) IDE Primary Drive C: (This is the one that SHOULD work, but I get the error here too)
    5) Floppy Drive
    6) USB port
    7) IDE CD-Rom

    The boot up in bios allows me to point to the IDE Primary Drive C:, the floppy, the USB port, or IDE CD-Rom. It will not allow me to set boot to the Sata drive or the Primary Master Hard Drive.

    I believe Grub moved something from the C: drive to another place on the Primary Master Hard Drive and now my Bios cannot see this "something" to boot up to.

    I am wondering at this point if it is possible to examine the MBR and see if it is where it should be in the first place. Is this something that can be edited or configured?

    Finally, my patients is growing thin with this problem and I am wondering if there is perhaps another bootloader that I can use that is FULLY configurable. But then the question comes to mind with what to do with Grub? Could this be deleted?

    On my first Ubuntu disk I didn't have this problem when setting it up.

    So I don't know what is going on.

    Edit: This is my disk listing in case anyone wants to take a peek

    geo@64studio:~$ sudo fdisk -l

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 851 6835626 83 Linux
    /dev/sda2 852 60801 481548375 5 Extended
    /dev/sda5 852 1181 2650693+ 82 Linux swap / Solaris
    /dev/sda6 1182 13339 97659103+ 83 Linux
    /dev/sda7 13340 31575 146480638+ 83 Linux
    /dev/sda8 31576 46164 117186111 83 Linux
    /dev/sda9 46165 60801 117571671 b W95 FAT32

    Disk /dev/hda: 80.0 GB, 80000000000 bytes
    255 heads, 63 sectors/track, 9726 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 7333 58902291 7 HPFS/NTFS
    /dev/hda2 7334 9726 19221772+ b W95 FAT32
    geo@64studio:~$


    According to this everything LOOKS right.

    Just to make things easier hda2, sda7 through 9 are all data storage. hda1 is my Windows, and sda 1 through 6 (only 4 partitions though) are Linux. Sda2 starts the Extended partition which encompases 5 through 9. Sda1 is the Linux root/boot partition. Sda6 is the /home partition and where my Linux programs are stored.

    This is my grub menu.lst:

    # menu.lst - See: grub(8), info grub, update-grub(8)
    # grub-install(8), grub-floppy(8),
    # grub-md5-crypt, /usr/share/doc/grub
    # and /usr/share/doc/grub-doc/.

    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not change this entry to 'saved' or your
    # array will desync and will not let you boot your system.
    default 0

    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout 10

    # Pretty colours
    color cyan/blue white/blue

    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line) and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    # password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret

    #
    # examples
    #
    # title Windows 95/98/NT/2000
    # root (hd0,0)
    # makeactive
    # chainloader +1
    #
    # title Linux
    # root (hd0,1)
    # kernel /vmlinuz root=/dev/hda2 ro
    #

    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below

    ## DO NOT UNCOMMENT THEM, Just edit them to your needs

    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specific kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    ## kopt_2_6_8=root=/dev/hdc1 ro
    ## kopt_2_6_8_2_686=root=/dev/hdc2 ro
    # kopt=root=/dev/sda1 ro vga=791 splash=silent

    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd1,0)

    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ## alternative=false
    # alternative=true

    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ## lockalternative=false
    # lockalternative=false

    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=

    ## should update-grub lock old automagic boot options
    ## e.g. lockold=false
    ## lockold=true
    # lockold=false

    ## Xen hypervisor options to use with the default Xen boot option
    # xenhopt=

    ## Xen Linux kernel options to use with the default Xen boot option
    # xenkopt=console=tty0

    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ## altoptions=(single-user) single
    # altoptions=(single-user mode) single

    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ## howmany=7
    # howmany=all

    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ## memtest86=false
    # memtest86=true

    ## should update-grub adjust the value of the default booted system
    ## can be true or false
    # updatedefaultentry=false

    ## ## End Default Options ##

    title 64studio, kernel 2.6.21-1-multimedia-486
    root (hd1,0)
    kernel /boot/vmlinuz-2.6.21-1-multimedia-486 root=/dev/sda1 ro vga=791 splash=silent
    initrd /boot/initrd.img-2.6.21-1-multimedia-486
    savedefault

    title 64studio, kernel 2.6.21-1-multimedia-486 (single-user mode)
    root (hd1,0)
    kernel /boot/vmlinuz-2.6.21-1-multimedia-486 root=/dev/sda1 ro vga=791 splash=silent single
    initrd /boot/initrd.img-2.6.21-1-multimedia-486
    savedefault

    title 64studio, kernel memtest86
    root (hd1,0)
    kernel /boot/memtest86.bin

    title 64studio, kernel memtest86+
    root (hd1,0)
    kernel /boot/memtest86+.bin

    ### END DEBIAN AUTOMAGIC KERNELS LIST

    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title Other operating systems:
    root


    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1
    title Microsoft Windows XP Home Edition
    root (hd0,0)
    savedefault
    makeactive
    chainloader +1


    This is my device map to help with drive correspondence

    (hd0) /dev/hda
    (hd1) /dev/sda


    Now my personal experience is minimal with Ubuntu/Linux, but it does look to be that everthing is in place. Once I can GET to Grub, it works! I just can't boot to it on start up and that is my final issue.

    At any rate I did look into another Boot Loader such as Lilo and it looks promising, but the directions are not the easiest to follow.

    I am REALLY going to need assistance from a boot loader expert on this one because I can't move forward until this problem is fixed.


    Geo
    Last edited by jukingeo; July 25th, 2008 at 07:19 PM.
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •