Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Belkin N >MIMO< Wireless USB Adapter Driver

  1. #1
    Join Date
    Oct 2007
    Location
    USA
    Beans
    15
    Distro
    Ubuntu 8.04 Hardy Heron

    Belkin N >MIMO< Wireless USB Adapter Driver

    Hello linux users.

    This is my first thread actually giving advice instead of asking for it

    This thread is for the Belkin N (MIMO) Wireless USB Adapter. I can tell you how to easily get your belkin wireless device to work in Ubuntu! (I´m running Hardy Heron)

    Without further ado, we need to get the show on the road. Make sure you have ndisgtk (part of ndiswrapper) I believe you can get it in synaptic.
    After installation, it will be Administrator>Windows Wireless Drivers. Alternatively, you can use termanal and type ¨sudo ndisgtk¨ then your password.

    Insert your Belkin CD into your CD drive. The CD has the .inf file needed to use it. Open up ndisgtk and click add driver. Click on the folder icon and locate your CD drive. Go to the ¨InstallationDrivers¨ folder. Go to ¨XP2K¨ and open the ¨rt2870.inf¨ file. It will say that the hardware is not present, but don´t worry. Reboot your computer with your USB device already attached and DO NOT UNPLUG IT. At least mine doesn´t work if you unplug it.

    Now whenever you start your computer, you will have wireless! Use the networkmanager in your tray to choose a network.

    Hope I could help!

    -GavinRoskamp Gavinstipsandtricks@gmail.com www.GavinsTipsAndTricks.co.nr

  2. #2
    Join Date
    Oct 2008
    Beans
    127

    Re: Belkin N >MIMO< Wireless USB Adapter Driver

    OK, I'm sort of a noob when it comes to linux. But I have dabbled with it a bit years ago. I'd like to put Ubuntu on my PC I'm using now, but for now I've got it installed on an older PC til I know everything is worked out and working fine.

    I did everything you said in your post and the adapter is recognized by the system, but for some strange reason it's not connecting to the network. I've changed the SSID and the security key but nothing seems to work. Am I doing something wrong or is there a different way I can problem solve it?

  3. #3
    Join Date
    Dec 2008
    Location
    Dublin
    Beans
    22
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Belkin N >MIMO< Wireless USB Adapter Driver

    Brillant, this fixed the problem for me!! I have a Wireless G+ MIMO Usb Adaptor (Belkin) and now it works perfect after doing what GavinRoskamp said!! Thanks

    I wouldntve known what to do only for the "sudo ndisgtk" command



    Thank You

  4. #4
    Join Date
    Nov 2008
    Location
    Opelika, AL
    Beans
    998
    Distro
    Ubuntu Development Release

    Re: Belkin N >MIMO< Wireless USB Adapter Driver

    You shouldn't have to reboot. Just open a terminal and type:

    Code:
    sudo modprobe ndiswrapper

  5. #5
    Join Date
    Nov 2006
    Location
    Nottingham
    Beans
    5
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Belkin N >MIMO< Wireless USB Adapter Driver

    Thank you very much for this info. Worked perfectly and didn't even have to restart my PC!

  6. #6
    Join Date
    Feb 2009
    Beans
    1

    Re: Belkin N >MIMO< Wireless USB Adapter Driver

    Quote Originally Posted by GavinRoskamp View Post
    Hello linux users.

    This is my first thread actually giving advice instead of asking for it

    This thread is for the Belkin N (MIMO) Wireless USB Adapter. I can tell you how to easily get your belkin wireless device to work in Ubuntu! (I´m running Hardy Heron)

    Without further ado, we need to get the show on the road. Make sure you have ndisgtk (part of ndiswrapper) I believe you can get it in synaptic.
    After installation, it will be Administrator>Windows Wireless Drivers. Alternatively, you can use termanal and type ¨sudo ndisgtk¨ then your password.

    Insert your Belkin CD into your CD drive. The CD has the .inf file needed to use it. Open up ndisgtk and click add driver. Click on the folder icon and locate your CD drive. Go to the ¨InstallationDrivers¨ folder. Go to ¨XP2K¨ and open the ¨rt2870.inf¨ file. It will say that the hardware is not present, but don´t worry. Reboot your computer with your USB device already attached and DO NOT UNPLUG IT. At least mine doesn´t work if you unplug it.

    Now whenever you start your computer, you will have wireless! Use the networkmanager in your tray to choose a network.

    Hope I could help!

    -GavinRoskamp Gavinstipsandtricks@gmail.com www.GavinsTipsAndTricks.co.nr
    Hello
    After following your directions when it comes to rt2870.inf I do not see it the only ones are rt2870.cat and rt2870.sys. What can I do?

  7. #7
    Join Date
    Apr 2009
    Beans
    2
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Belkin N >MIMO< Wireless USB Adapter Driver

    I fallowed the steps but it seams that the wifi utility isn't showing any networks in range :/ though would it be a problem if I have a netgear wifi adapter in my computer aswell?

    edit
    Oh ya i'm on 8.10 64bit an it just seams that its not seeing the adapter when its plugged in :/
    Last edited by TheLastExodus; April 6th, 2009 at 12:28 AM.

  8. #8
    Join Date
    Apr 2009
    Beans
    1

    Exclamation Re: Belkin N >MIMO< Wireless USB Adapter Driver

    Ok, so here is my problem.

    it detects the adapter but shows no connections to choose from.

    What the heck do I do?


    EDIT: I know there is one because I have a wireless modem in another room and when I use my dual-booted Vista , there is a connection to choose from...
    Last edited by Dillon02003; April 24th, 2009 at 11:27 PM. Reason: clarification

  9. #9
    Join Date
    May 2009
    Beans
    3

    Lightbulb Re: Belkin N >MIMO< Wireless USB Adapter Driver

    I would like to add that it if you're using a 64 bit version of Ubuntu, you might want to select the XP64 driver instead of the XP2K one. That's what was necessary for me.

    Cheers

  10. #10
    Join Date
    Jun 2006
    Beans
    13

    Re: Belkin N >MIMO< Wireless USB Adapter Driver

    I followed these steps and it connects fine to one of my routers. A B/G one. I have a second router that is just set to N and it will not connect. Is there some way to enable N connectivity?

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •