When trying to do sudo apt-get update (in version 8.04), I'm getting this at the end:
W: GPG error: http://security.ubuntu.com hardy-security Release: Couldn't access keyring: 'Value too large for defined data type'
If I try to install any new packages, I get a warning about the package not being authenticated.

What is causing this and how can I solve it?