Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: When i installedf ubuntu from windows. Missing MBR error. Pls help

  1. #11
    Join Date
    Jul 2008
    Beans
    10

    Ubuntu install made my xp Hard drive inactive. How do i change it back?

    I nstalled ubuntu with wubi loader from windows xp, it went fine to a point.After i intalled ubuntu to sencond partition on second hard drive [E:] my first drive went inactive it still functions i can boot to xp loading screen then it says cant find autochk.exe then after disabling reboot on error i get to see the error something about value of drive should be 0 3 0000000 is 0 0 0000000 0 0 0000000. How can i fix this problem and save xp drive?

  2. #12
    Join Date
    Apr 2007
    Beans
    547

    Re: Ubuntu install made my xp Hard drive inactive. How do i change it back?

    both os are there the bootloader is confused.

    may need advanced supergrub to repair, but also there are hundreds of posts here about bootloader repair. search for them there are many ways to fix this depending on the symptoms. post your specs here according to the posts you find.

  3. #13
    Join Date
    Feb 2007
    Beans
    445
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: After install with grub i get to grub prompt. What do i do?

    Is this right after a fresh install? If so, sounds like the install didn't work correctly. Might want to try a reinstall and check the integrity of your install disc.
    check out linuxmce! It's the future of home media centers. It is flat out the most amazing piece of linux software I've ever seen.

    http://www.linuxmce.com

  4. #14
    Join Date
    Feb 2007
    Beans
    23,086
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: After install with grub i get to grub prompt. What do i do?

    Quote Originally Posted by Afkpuz View Post
    Is this right after a fresh install? If so, sounds like the install didn't work correctly. Might want to try a reinstall and check the integrity of your install disc.
    Hi and if you look at the other post by the op. installed using wubi and is having issues.
    And has multiple threads on the issue.

  5. #15
    Join Date
    Jul 2008
    Beans
    10

    When i installedf ubuntu from windows. "Missing MBR helper" error. Pls help

    I installed using wubi installer to second partition.Wubi formated and rebooted to menu. and then i get missing MBR error. Does anyone know what will correct this?

  6. #16
    Join Date
    Jul 2008
    Beans
    10

    Boatloader Fix Needed Desprately

    I installed ubuntu from xp to another hard drive and i apear to be having bootloader issues. The intall went ok rebooted into grub command prompt and i was coming here to see what to do next. So i reboot to xp it gets to XP loading screen, stops with a missing autochk.exe bypassing autochk and reboots. So from there first thing shut off reboot to get error report "Value of 0,3 is 0,0,00000 0,0,00000 maybe more zeros but you get the idea. So i use xp repair and fixmbr, fixboot and chkdsk /p, still wont take me to windows. Checked partition and it says its inactive. Can anyone offer more suggestions or an actual fix? I wouldnt really care if ubuntu would load because in order to get back up i had to install xp again and i cant activate it again (How stupid is that in a product???). Just another reason to install Linux!!!!!! I can still use grub prompt.

  7. #17
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Boatloader Fix Needed Desprately

    Boot from the ubuntu live cd and open gparted (system>admin>partition editor)

    right click on xp partition>manage flags>check 'boot' (=making it 'active')

    But not sure that will make a diff because there may be deeper probs with xp

    You can check the integrity of the partition table with testdisk

    system>admin>sofware sources>enable universe repo

    sudo apt-get install testdisk

    sudo testdisk

    (boy I've recommended that program so much lately I'm starting to sound like a one-note Johnny!)

    You might want to mount your linux root and post output of

    sudo fdisk -l

    and your /boot/grub/menu.lst (which might clue us in on why you're getting the grub command line rather than menu screen)

    Or get Super Grub Disk. It might be able to fix boot of ubuntu

  8. #18
    Join Date
    Jul 2008
    Location
    Belgium
    Beans
    17
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: When i installedf ubuntu from windows. "Missing MBR helper" error. Pls help

    You started 8 threads about the same problem. Please don't start multiple threads, there's no way you'll get better help this way since we can't see what's already been advised to you.

    Your best solution is to follow logos34's advices here but don't forget to tell him you used wubi :
    http://ubuntuforums.org/showthread.php?t=860737

  9. #19
    Join Date
    May 2007
    Beans
    7,032
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: When i installedf ubuntu from windows. "Missing MBR helper" error. Pls help

    Eight threads merged. Please refrain from cross-posting.
    I am aware of all internet traditions. | Getting the best help | Text formatting codes | My last.fm profile
    Should I PM support questions? NO!

  10. #20
    Join Date
    Feb 2005
    Beans
    5,138

    Re: When i installedf ubuntu from windows. Missing MBR error. Pls help

    As mentioned earlier, wubi would not touch the mbr. It might be that you are confusing with a fs corruption or some other side issue/hardware problem. In any case you might want to try booting off windows CD in the recovery console and run chkdsk /r and/or fixmbr

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •