Results 1 to 2 of 2

Thread: Recompile problem - no sound

  1. #1
    Join Date
    Apr 2008
    Beans
    9

    Recompile problem - no sound

    OK - I have been at this for days on and off ...

    I have made a small change to hid-quirks.c to enable the Logitech diNovo mini mouse pad and then recompiled the kernel using the recommended Ubuntu way with make-kpkg and the existing kernel config file (from /boot). Compiles fine and installed fine. Boots fine and the mouse pad even worked some where along the line - the problem is that the new kernel does not have any sound drivers loaded. I am completely stumped on this one. If I look at /lib/modules for the standard kernel (2.6.24-19-generic ) I see the following directories - initrd, kernel, madwifi, volatile plus some other files if I look at the directories for the new recompiled kernel most of these are not there including the ubuntu one which appears to have the sound drivers (amongst others).

    My question is what am I missing? It seems that some other magic is required to duplicate the standard generic set up - I can find no reference to any other steps in this process.

    Any help most appreciated ...

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: Recompile problem - no sound

    Yes. You missing drivers.
    Want ALSA - compile it.
    Want madwifi - compile it.
    Want anything else thats dependant on kernel version - compile it by hand.

    That's the way of these who compiled it's own kernel - even these who didn't do any changes in it.
    You could bear it or go back to "canonical" kernel.
    Linux Debian Sid (Minted) x86_64/3.12.10, Conky 2.0_pre, Xorg 7.7/1.15.0, KDE 4.11.5, Lenovo T61, Intel X3100, HITACHI HTS722010K9SA00 100GB, WDC_WD5000BEVT 500GB
    Linux user No.: 483055 | My Conky Pitstop corner | One4All project

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •