Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Mixxx not working with JACK, but ok with ALSA

  1. #11
    Join Date
    May 2008
    Beans
    786
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Mixxx not working with JACK, but ok with ALSA

    Quote Originally Posted by Stochastic View Post
    AHHHH, now I see, the issue is in Mixxx not seeing the sample rate that Jack is set to, automatically. It needs to be manually set in the Mixxx preferences to correspond with jack. The other setting you're talking about will be user/soundcard dependent. But without that matching audio sample rate the program says it cannot open the audio device. Out of curiosity which thread did you find your information from?

    No thread...I think I spoke to one of the Mixxx developers directly. He said that if the sample rates do not match you get the "Cannot activate Audio Device" error. I did inform him that perhaps changing the error message to read: "Cannot activate Audio Device: Application's sample frequency must match", or something like that. At least it would tell the person where to go look to correct the problem.

    The other information about changing the sample rate, frame and buffers I got right here in the Ubuntu Forum.

    Geo
    Exit Light, Enter Night, Take My Hand, We're Off To Never Never Land.
    As the Fios Flea says, "W-O-W"!

  2. #12
    Join Date
    Aug 2006
    Location
    Haarlem Netherlands
    Beans
    250

    Re: Mixxx not working with JACK, but ok with ALSA

    I've got mixxx working ok with jack, I think.
    Thing is it all depends on your hardware:





    These are the settings for a hercules rmx dj console, using jack obviously with pretty nice latency...

    Now I just need to get midi working, aaarch!!!

    I'll start a thread about that one.
    Last edited by jocheem67; August 4th, 2008 at 08:04 PM.

  3. #13
    Join Date
    Apr 2006
    Location
    Vancouver, Canada
    Beans
    1,855
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Mixxx not working with JACK, but ok with ALSA

    Quote Originally Posted by jocheem67 View Post
    I've got mixxx working ok with jack, I think.
    Thing is it all depends on your hardware:
    No, it's not based on hardware. Jukingeo had a software conflict between the jack sample rate and Mixxx's expected sample rate (set in mixxx's preferences).
    What makes a great open source contributor is not primarily the brilliance of their ideas or importance of their bug, but rather their willingness to see it through to success.

  4. #14
    Join Date
    Mar 2006
    Location
    Stockholm, Sweden
    Beans
    694
    Distro
    Ubuntu Development Release

    Re: Mixxx not working with JACK, but ok with ALSA

    For those interested, I added instructions on how to get Mixxx working with JACK (in general) in Karmic:

    Rebuild portaudio:
    https://bugs.launchpad.net/mixxx/+bu...90/comments/16

    Then change mixxx configuration:
    https://bugs.launchpad.net/ubuntu/+s...537/comments/4

    Cheers

  5. #15
    Join Date
    Feb 2009
    Location
    Texas
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mixxx not working with JACK, but ok with ALSA

    Quote Originally Posted by motin View Post
    For those interested, I added instructions on how to get Mixxx working with JACK (in general) in Karmic:

    Rebuild portaudio:
    https://bugs.launchpad.net/mixxx/+bu...90/comments/16

    Then change mixxx configuration:
    https://bugs.launchpad.net/ubuntu/+s...537/comments/4

    Cheers
    Thanks so much Motin, I've been looking for this during hours. But Iḿ having problems finding and compiling these

    Code:
    sudo dpkg -i libportaudio2_19+svn20090620-0ubuntu1_i386.deb
    sudo dpkg -i libportaudiocpp0_19+svn20090620-0ubuntu1_i386.deb
    sudo dpkg -i portaudio19-doc_19+svn20090620-0ubuntu1_all.deb
    where are those packages? My Ubuntu Studio can find them

  6. #16
    Join Date
    Jan 2010
    Beans
    104

    Re: Mixxx not working with JACK, but ok with ALSA

    Thank you! I was getting the "cannot load audio device" problem, using 11.04.

    I only had to change the sampling rate, periods and buffers to be the same in Mixxx and Jack, and I used the numbers suggested above (48000, 512 and 4.)

    Did not have to muck about with editing configuration files manually.-

    I also find that Mixxx does not list Jack as a sound option until the Jack server is started. So this is what I have to do
    1. start Jack
    2. start Mixxx
    3. Mixxx complains that it can't use the soundcard since another application is using it
    4. click "reconfigure"
    5. THEN choose Jack
    6. Mixxx appears as "Port Audio" in the Jack connections window.

    Not a big deal, as this doesn't take very long, and it works great once it's done.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •