Results 1 to 2 of 2

Thread: [SOLVED] Screen Panning

  1. #1
    Join Date
    May 2008
    Beans
    1,029

    [SOLVED] Screen Panning

    I've finally got my computer to boot up with 1024x768@75 resolution.... but now the screen is panning and I've got no clue what to do. Here is my xorg.conf file:
    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Inputdevice "Generic Keyboard"
    Inputdevice "Configured Mouse"
    screen 0 "screen1" 0 0
    EndSection

    Section "Module"
    Load "glx"
    Load "GLcore"
    Load "dri"
    Load "v4l"
    EndSection

    Section "device" #
    Identifier "device1"
    Boardname "ATI Rage 128"
    Busid "PCI:1:0:0"
    Driver "ati"
    Screen 0
    Vendorname "ATI"
    Option "MergedFB" "off"
    EndSection

    Section "screen" #
    Identifier "screen1"
    Device "device1"
    Defaultdepth 24
    Monitor "monitor1"
    SubSection "Display"
    Depth 24
    Modes "1024x768@75" "1024x768@70" "832x624@75" "1024x768@60" "800x600@60" "1152x864@75" "800x600@75" "1280x1024@75" "800x600@72" "1280x960@60" "800x600@56" "1280x1024@60" "640x480@75" "1280x960@75" "640x480@72" "1400x1050@60" "640x480@60" "1600x1200@65" "1600x1200@60"
    EndSubSection
    EndSection

    Section "monitor" #
    Identifier "monitor1"
    Vendorname "Generic CRT Display"
    Modelname "Monitor 1280x1024"
    Horizsync 31.5-81.0
    Vertrefresh 50-75
    modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
    modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
    modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
    modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
    modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
    modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
    modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
    modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
    modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
    modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
    modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
    modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
    modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
    modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
    modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
    modeline "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    Gamma 1.0
    EndSection

    Section "ServerFlags"
    EndSection
    Please help.

  2. #2
    Join Date
    May 2008
    Beans
    1,029

    Re: Screen Panning

    I fixed it by deleting all the resolutions that I didn't want in my xorg.conf file and only left the entries with 1024x768, 800x600, and 640x480 in the "Screen" and "Monitor" sections.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •