Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: sleep on Seagate external hard drive

  1. #1
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    sleep on Seagate external hard drive

    I recently got this Seagate external drive. It works great (after I formatted it as ext3 and did chmod 777), but occasionally it goes to sleep after being idle for a while. After that, I can't read or write anything on it, so I have to restart and reconnect the drive. Is there any way to fix this? I'm using Karmic. Thanks!

  2. #2
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: sleep on Seagate external hard drive

    (bump)

  3. #3
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: sleep on Seagate external hard drive

    (another bump)

  4. #4
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: sleep on Seagate external hard drive

    Or does anyone at least know how to turn sleep off on this drive? I already have "spin down hard disks when possible" unchecked in System>Preferences>Power Management. This is a total pain; the other day it caused Truecrypt to mess up a volume that had taken several days to create.

  5. #5
    Join Date
    May 2007
    Beans
    55

    Re: sleep on Seagate external hard drive

    I'm not too well-versed on the command line. But this web page might help: http://www.debianhelp.org/node/11551
    Please look at the submission by jtones on Mon, 2009-03-30 11:04. I'm fairly certain the answer lies with sdparm command, and it's relevant standby setting.

    I have a portable hard drive that I formatted to fat32 because of compatibility issues, I usually avoid the spinning down problem by connecting the hard drive only when it is used.

  6. #6
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: sleep on Seagate external hard drive

    OK, I just changed the setting with sdparm, so if I don't post in this thread again, I guess it will have worked! Thanks!

  7. #7
    Join Date
    Aug 2006
    Location
    kingsport
    Beans
    232
    Distro
    Lubuntu

    Re: sleep on Seagate external hard drive

    I have this exact drive but I dont have that issue as of yet with it. I have the problem of it starting to click with ubuntu and the movies i have on it stop or skip when it clicks if i use my windows machine its fine no clicking and no freexing with it streaming to my mac mini.
    linux lubuntu machine dell dimension 4300s 1.6 p4 with 1gb of ram runnint peppermint3 compaq 2.5 p4 1gb of ram running peppermint3 dell optiplex 620 2.8 pentium d 2.5 gb of ram running linux mint 13 maya cinnamon desktop

  8. #8
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: sleep on Seagate external hard drive

    Yeah, I noticed that almost all the reviews on Newegg mentioned clicking. I haven't gotten any clicking on mine, except one day it started doing it once or twice a second when I plugged it into a laptop, and then it continued after I reconnected it to my desktop computer. Then after a few hours it stopped, and now it hasn't made any noticeable noises for the past week or two.

  9. #9
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: sleep on Seagate external hard drive

    Wait, never mind, I found out that it does still go into standby when idle.

  10. #10
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: sleep on Seagate external hard drive

    I would be interested even if anyone knows of an ugly fix involving writing a script to read a file on the drive once every 25 minutes or so.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •