Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Will a Lexmark Z2320 printer work under 8.04?

  1. #1
    Join Date
    Nov 2007
    Location
    Europe
    Beans
    30
    Distro
    Ubuntu 8.04 Hardy Heron

    Will a Lexmark Z2320 printer work under 8.04?

    I'd like to buy a simple printer, a Lexmark Z2320. How can I find out if it is going to work?

    Lexmark does not offer an Ubuntu driver for this model and the Synaptic Packet Manger only lists one item when searching for Lexmark: "Lexmark 2050 Color Jetprinter Linux Driver". (I'm also not quite sure if this really is a printer driver since it also says "Filter to convert a Postscript file to Lexmark 2050 format." If it is a printer driver: will it work with a Lexmark Z2320?)

    So far all hardware that I tried to use with my new Ubuntu PC just worked. How is the situation with printers? The salesman said that if Linux is not listed on the printer's package then it is not going to work.

    Now if this model is not supported, where could I find a list with simple and cheap (b/w) printers that work under Ubuntu 8.04? Thanks!

  2. #2
    Join Date
    Feb 2007
    Location
    St. Louis, MO
    Beans
    4,917
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Will a Lexmark Z2320 printer work under 8.04?

    Quote Originally Posted by indiworks View Post
    I'd like to buy a simple printer, a Lexmark Z2320. How can I find out if it is going to work?

    Lexmark does not offer an Ubuntu driver for this model and the Synaptic Packet Manger only lists one item when searching for Lexmark: "Lexmark 2050 Color Jetprinter Linux Driver". (I'm also not quite sure if this really is a printer driver since it also says "Filter to convert a Postscript file to Lexmark 2050 format." If it is a printer driver: will it work with a Lexmark Z2320?)

    So far all hardware that I tried to use with my new Ubuntu PC just worked. How is the situation with printers? The salesman said that if Linux is not listed on the printer's package then it is not going to work.

    Now if this model is not supported, where could I find a list with simple and cheap (b/w) printers that work under Ubuntu 8.04? Thanks!
    The openprinting database does not even list that printer so chances are it does not work.

    Lexmark is poor when it comes to Linux support.

    If you want inexpensive b/w printing go with an HP laserjet. I have seen them for ~$100 and they typically print 3000 pages per cartridge.

    Samsung laser printers are pretty Linux friendly as well.

    The ML-2510 can be had for under $100 and works perfectly with Linux.

    http://openprinting.org/show_printer...amsung-ML-2510
    Windows XP - Excellent computer virus detector.
    Windows Vista - Most bloat for the money.

    Visit my Ubuntu Resource Website http://www.stchman.com

  3. #3
    Join Date
    Nov 2007
    Location
    Europe
    Beans
    30
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Will a Lexmark Z2320 printer work under 8.04?

    Quote Originally Posted by stchman View Post
    The openprinting database does not even list that printer so chances are it does not work.

    Lexmark is poor when it comes to Linux support.

    If you want inexpensive b/w printing go with an HP laserjet. I have seen them for ~$100 and they typically print 3000 pages per cartridge.

    Samsung laser printers are pretty Linux friendly as well.

    The ML-2510 can be had for under $100 and works perfectly with Linux.

    http://openprinting.org/show_printer...amsung-ML-2510
    The openprinting database looks just like what I need - thanks!

    Strange that some companies still ignore the Linux market - one customer less for Lexmark... This one would have been ideal, a really cheap (> € 40.-) printer currently being offered by a large electronics discounter here in Europe, cartridges can be refilled (though they don't tell you how-to do that of course).

  4. #4
    Join Date
    Aug 2006
    Location
    Smederevo/Serbia
    Beans
    175
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Will a Lexmark Z2320 printer work under 8.04?

    Here is the driver for Lexmark z2320:

    http://www.downloaddelivery.com/down...386.deb.sh.zip

    This is a link from lexmark download site. There is packages for Suse 11, Debian, Ubuntu 8.04 and Foresight distros.

  5. #5
    Join Date
    Apr 2009
    Location
    Ireland
    Beans
    31
    Distro
    Ubuntu 8.04 Hardy Heron

    Question Re: Will a Lexmark Z2320 printer work under 8.04?

    Quote Originally Posted by Milos_SD View Post
    Here is the driver for Lexmark z2320:

    http://www.downloaddelivery.com/down...386.deb.sh.zip

    This is a link from lexmark download site. There is packages for Suse 11, Debian, Ubuntu 8.04 and Foresight distros.
    I have downloaded the driver listed above from Lexmark but when I run it, during the installation I'm getting an error:

    "Package architecture (i386) does not match system (lpia)"

    And then the installation fails.

    I'm trying to install the printer on a Dell Mini-9 running 8.04 LTS can anyone offer advice?

  6. #6
    Join Date
    Apr 2009
    Location
    Ireland
    Beans
    31
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Will a Lexmark Z2320 printer work under 8.04?

    Ok, so I have contacted Lexmark and they have provided the following solution:

    In X23xx and X26xx models the only way to let the user successfully install driver on so called NETBOOKs is to do the following:

    1) You need these two scripts, and must copy these two scripts right beside where the "lexmark-inkjet.deb.sh " installer is located.(See attached file: extracter.sh) (See attached file: deb2lpia.sh)

    2) open terminal and go to the location of the Lexmark installer, and do:

    in the terminal do ---> sh ./extracter.sh lexmark-inkjet-09-driver-1.0-1.i386.deb.sh
    result, this file gets created ---> lexmark-inkjet-09-driver-1.0-1.i386.deb

    3) Rename lexmark-inkjet-09-driver-1.0-1.i386.deb to installer_i386.deb
    by issuing the following command at the terminal ---> mv lexmark-inkjet-09-driver-1.0-1.i386.deb installer_i386.deb

    4) please then do ---> sh ./deb2lpia.sh installer_i386.deb
    result is this file gets created installer_lpia.deb

    5) Finally, at last, do ---> dpkg -i installer_lpia.deb

    That's it. The driver should be successfully installed and got registered into the synaptics record database ( which means, you can open synaptics UI, and can find our driver in the group called "notfree ").

    I'm going to test this out shortly (but expect it to work) and will post to confirm if it worked.
    Attached Files Attached Files

  7. #7
    Join Date
    Jan 2010
    Beans
    3

    Re: Will a Lexmark Z2320 printer work under 8.04?

    Help me!
    I bought the Lexmark S305 and I downloaded the following driver lexmark-inkjet-09-driver-1.0-1.i386.deb.sh "because Ubuntu did not recognize.

    After the first stages of the installation you receive the following error message: "Execute: dpkg-i-Lexmark Inkjet-09-driver-1.0-1.i386.deb 2> & 1 | tee / home / nicola / lua_ixdeyG / installerror_msgs

    dpkg: error in lexmark-inkjet-09-driver-1.0-1.i386.deb (- install):
    the architecture of the package (i386) does not match that of the system (amd64)
    There were errors in:
    lexmark-inkjet-09-driver-1.0-1.i386.deb. "

    and the installation stops.
    The S.O. bit Ubuntu 9.10 and the processor is an AMD Athlon 64.
    I wonder if the procedure is also indicated in my case.
    Thank you very much.
    Last edited by brizio; January 12th, 2010 at 11:18 AM.

  8. #8
    Join Date
    Oct 2006
    Location
    Bordeaux, France
    Beans
    7

    Re: Will a Lexmark Z2320 printer work under 8.04?

    Hello brizio,

    Use the same procedure as for lpia (the one which dave66 described) with the script I have modified.

    It should work !

    Have a nice day.

    --kalon33
    Attached Files Attached Files

  9. #9
    Join Date
    Feb 2010
    Beans
    1

    Re: Will a Lexmark Z2320 printer work under 8.04?

    I just tried this with my Lexmark S305 and it worked great!! Thanks for that modified script kalon33!

    Is there a good tutorial on creating scripts out there?

    Thanks,
    Normster

  10. #10
    Join Date
    Feb 2010
    Beans
    2

    Question Re: Will a Lexmark Z2320 printer work under 8.04?

    Hi,

    I used the same for the lexmark Pro 705 as i am using ubuntu 9.10 AMD64 so i got the amd64.deb (many thanks).

    I wonder if those lexmark drivers lexmark gives are for both scanner and printer (multi features printer) or are they just for the printer part ? (can we use the scanner part with xsane ?). => i am tired to go to osx or windows via my multiboot or virtual systems to have scanner on printer useable...)

    thanks for your help.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •