Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: HOWTO: USB stops working

  1. #11
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: HOWTO: USB stops working

    Quote Originally Posted by rebeltaz View Post


    So how do you do you do this in grub2?
    No idea. I've still got Jaunty.
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

  2. #12
    Join Date
    Dec 2007
    Beans
    336

    Re: HOWTO: USB stops working

    Quote Originally Posted by lisati View Post
    No idea. I've still got Jaunty.
    That's OK... Actually the problem was with the BIOS. I am running this on a Dell Dimension E520. From a DOS boot disk, I ran the BIOS update from the Dell web site and I have not had a single problem since. So if anyone else with an E520 has a similar problem - upgrade your BIOS.

  3. #13
    Join Date
    Jan 2010
    Beans
    4

    Re: HOWTO: USB stops working

    Quote Originally Posted by lisati View Post
    One topic that crops up from time to time in these forums is what to do if devices connected by USB stop working when the computer has been turned on for a while, but come right when the computer is rebooted.

    The following solotuion is what I used when my USB mouse and USB keyboard worked fine at startup but stopped working after a while. I have successfully used it on a Toshiba A100 laptop running Ubuntu 7.04, a.k.a. "Feisty".

    Disclaimer:
    The success (or otherwise) of the following solution will depend on your hardware and possibly which version of *buntu you are using. Feel free to add your feedback to this thread and alternative solutions



    1. From a terminal, type
      Code:
      gksudo gedit /boot/grub/menu.lst
      You will be asked for your password - don't worry if your password doesn't show, this is normal. Just type in your password as usual, and it will be accepted.
    2. When the editor opens, scroll down to the line which reads and change it to read
      Code:
      # defoptions=quiet splash acpi=force irqpoll
    3. Save the file, exit the editor
    4. From the terminal, type in
      Code:
      sudo update-grub
    5. Restart your computer.
    I have a very similar problem but when i type in the first line of code above i just get a blank editor window.

  4. #14
    Join Date
    Jan 2008
    Beans
    29

    Re: HOWTO: USB stops working

    Please.

    I just installed 9.1 desktop on an old Compaq laptop on which a USB mouse worked with W2K. Now it doesn't work. How do you do this with GRUB2?

    Thanks.

  5. #15
    Join Date
    Dec 2007
    Beans
    336

    Re: HOWTO: USB stops working

    Quote Originally Posted by forestwalker101 View Post
    I have a very similar problem but when i type in the first line of code above i just get a blank editor window.
    menu.lst is not used on GRUB2...

  6. #16
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: HOWTO: USB stops working

    Quote Originally Posted by rebeltaz View Post
    menu.lst is not used on GRUB2...
    +1. I've added a note in the first post to the effect that starting with 9.10, Ubuntu uses a new version of grub.
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

  7. #17
    Join Date
    Jan 2008
    Beans
    29

    Re: HOWTO: USB stops working

    OK. Installing 9.10 desktop from the live CD on an HP/Compaq nc6000:

    1) if I click install from the first screen, and plug in a USB mouse and/or keyboard AFTER the install is complete and it's rebooted from the installed system, the USB mouse and/or keyboard DO NOT work ... but a USB drive does work
    2) if I run from the CD and install from within the running 9.10, and plug in a USB mouse and/or keyboard AFTER the install is complete and it's rebooted from the installed system, the USB mouse and/or keyboard DO NOT work ... but a USB drive does work
    3) if I first plug in a USB mouse and/or keyboard and install from the first screen, the USB mouse and/or keyboard DO NOT work ... but a USB drive does work
    4) if I first plug in a USB mouse and/or keyboard and then run from the CD and install from within the running 9.10, the USB mouse and/or keyboard WORK both before and after booting from the installed system

    This resolves my problem.

  8. #18
    Join Date
    Oct 2010
    Location
    Finland
    Beans
    3
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: USB stops working

    Quote Originally Posted by rebeltaz View Post
    So how do you do you do this in grub2?
    With Grub2 the file to edit is /etc/default/grub.

    1. From terminal type:

    Code:
    gksudo gedit /etc/default/grub
    2. Scroll down to a line which reads:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    and change it to read:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force irqpoll"
    3. Save the file, exit the editor.

    4. From the terminal update Grub configuration by typing:

    Code:
    sudo update-grub
    5. Restart your computer

  9. #19
    Join Date
    Oct 2010
    Location
    Finland
    Beans
    3
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: USB stops working

    Happy to report that adding "acpi=force irqpoll", as suggested, seems to have solved the problem on my Toshiba Satellite Pro L100. 1 hour from reboot now and USB mouse is still working (usually dies after 10 minutes or so). I was also able to format a USB memory stick with GParted, unplug it, plug it back in...

    Thank you, lisati!

  10. #20
    Join Date
    Oct 2010
    Beans
    7

    Thumbs down Re: HOWTO: USB stops working

    Hi I also have the this problem and I've tried what you wrote but I didn't work. I figured if I post all of my grub file maybe you can find something that is wrong with it:

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force irqpoll"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"





    Hopefully you can help me, I just installed Ubuntu last night and haven't got time to start playing with due to this issue.
    Thank you / J

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •