Results 1 to 10 of 30

Thread: aufs root filesystem

Threaded View

  1. #1
    Join Date
    Jul 2008
    Beans
    3

    aufs root filesystem

    Hello Everyone,
    I'm new here to the forums, bat have like a 5 year on and off experience with linux. First years mostly debian until I discovered Ubuntu, really think it's a wonderfull OS!

    But i have a problem,

    I Have Ubuntu installed on my eeepc 900, with 2gb of ram.
    /dev/sda1 is the 4gb disk where ubuntu lives
    /dev/sdb1 is the 16gb disk where my home dir lives
    I have no swap or boot partition, which is working fine for as long as i worked with it

    I read this article
    http://help.ubuntu.com/community/auf...stemOnUsbFlash
    on how to reduce writes on my flashdisk.

    I pretty much have everything configured and installed how i wanted, so i thought it might be a good idea to 'freeze' my installation like this.

    I followed every step of the tutorial and even added 'A nicer solution to add the kernel entries'.
    But after rebooting
    - I get a lot of error messages of scripts and files that are not found
    - /dev/sdb1 is not mounted (so no /home dirs)
    - X isn't started (probably in the not found files somewhere)

    When I alt+f1 to the first terminal it says in the top of the screen

    Code:
    aufs setup on /root
    
    sed: no previous regexp.
    
    ubuntu 8.04.1 binkeee tty1
    the "aufs setup on /root" is a message from the rootaufs script on the page mentioned earlier.
    So the script get started, but then sed gives an error. since i have no experience with sed i don't know what the message means (also couldn't really find it so far) nor do i know if one of the sed commands is wrong.

    forthermore;

    on the alt+f8 'status console' if i can call it that. there's mentioned
    Code:
    * Mounting local filesystems...
    mount: /dev/sda1 already mounted or /ro busy
       ...fail!
    when i execute the 'df' command i can see that
    /dev/sda1 is mounted on /ro
    aufs is mounted on /
    aufs-tmpfs is mounted on /rw

    I'm not quite sure what is causing this, i can still boot without the aufs rootfs and then everything is working again, but i would like to get it to work with the aufs rootfs

    any help would be greatly appreciated, also if there is a way how i can achieve the same on a different way

    tested with kernels:
    2.6.24-16-generic
    2.6.24-19-eeepc
    both with the exact same result

    Kind Regards,

    Mannes Brak
    Last edited by Mannes; July 9th, 2008 at 01:44 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •