Results 1 to 3 of 3

Thread: [SOLVED] Getting windows (XP) to remember Samba password

  1. #1
    Join Date
    Jun 2008
    Location
    Amsterdam
    Beans
    14
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Red face [SOLVED] Getting windows (XP) to remember Samba password

    Hiya everyone,

    Just something that's busting my nuts is the following..

    [SETUP]

    Ubuntu 7.10 desktop server with Samba server and smb user "ina" with setup password with
    Code:
    smbpasswd -a ina
    and smb user "masterdam79" with setup password with
    Code:
    smbpasswd -a masterdam79
    Windows Vista (Home Premium) desktop with windows user "masterdam79"

    Windows XP (Home) Laptop with windows user "ina"

    [PROBLEMS SOLVED]

    Am now able to access the Samba shares from my Windows Vista machine WITHOUT entering username/password for my Samba user because I made a Samba user equal to my Vista windows user "masterdam79".

    I WAS able to select the "Remember my password" checkbox on my Vista machine, first time I logged on into the Ubuntu server and now I never have to type in the credentials again on that machine.

    [PROBLEMS NOT SOLVED]

    Am able to access the Samba shares from my Windows XP machine WITH entering username/password for my Samba user which I made equal to my XP windows user "Ina"

    I was NOT able to select the "Remember my password" checkbox on my XP machine, which brings me to the target set out on the subject of this post.

    How do I make Windows XP remember my Samba password and why is Vista remembering it without a problem?

    Where is my "Remember my password" checkbox on XP?


    Much thanks!!

    P.s. I have already tried with another XP Home machine and there WAS a "Remember my password" check option when connecting to the Linux share. (Some people claim this to be a disfunctionality of the "Home" version of XP, which I here declare as a load of ____.

    P.s.P.s. Also It has nothing to do with the Linux machine as both my Vista machine and (the other) XP machine were able to remember passwords. Clearly something went wrong on the first XP machine that disabled the "Remember my password" checkbox on network login.


    In Vista I can add servers manually and it remembers the passwords without problems.
    [SCREENSHOTS]
    http://masterdamonline.nl/Vista-remembered-password.JPG
    http://masterdamonline.nl/Vista-reme...ssword-001.jpg

    In XP (virtualized) Home I am able to add servers, but it doesn't remember the passwords
    [SCREENSHOTS]
    http://masterdamonline.nl/XP-Virtualized-001.JPG
    http://masterdamonline.nl/XP-Virtualized-002.JPG
    http://masterdamonline.nl/XP-Virtualized-003.JPG

    and in the XP Home laptop I can't even add servers manually, let alone get it to remember my passwords.
    [SCREENSHOT]
    http://masterdamonline.nl/XP-Laptop.JPG
    http://masterdamonline.nl/XP-Laptop-001.JPG

  2. #2
    Join Date
    Jul 2008
    Location
    Taiwan
    Beans
    30
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Getting windows (XP) to remember Samba password

    Please use "control userpasswords2" command in windows xp.
    It will display user account for local and network and .Net passport.
    You can add user in advance --> manager password

    Regards,
    Bryan Yu
    http://www.ardoros.com/

  3. #3
    Join Date
    Jun 2008
    Location
    Amsterdam
    Beans
    14
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Lightbulb Re: Getting windows (XP) to remember Samba password

    Thanks heaps!!

    It was not the actual solution (but it lead to an acceptable one):

    [I could add useraccounts]
    http://masterdamonline.nl/XP-Laptop-...counts-001.JPG

    I checked the "Users must enter a ...", but I don't think this was such a mayor difference.

    Then I mounted a network drive and selected the option for "log on using a different user"

    http://masterdamonline.nl/XP-Laptop-...work-Drive.JPG
    Connect using a different user name
    filled in my (same) credentials and BINGO!!

    The earlier mentioned checkbox has not returned, but became obsolete.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •