Results 1 to 9 of 9

Thread: synergyc 100% cpu and not working

  1. #1
    Join Date
    Feb 2006
    Beans
    16

    synergyc 100% cpu and not working

    Has anyone had any luck getting the Synergy client working on the new 2.2.26 kernel? It immediately consumes 100% cpu and while it connects, it never accepts any input and quickly disconnects from the server machine.

    Code:
    NOTE: accepted client connection
    NOTE: new client is unresponsive
    Thanks,
    Cotton

  2. #2
    Join Date
    Apr 2007
    Location
    Ohio
    Beans
    354

    Re: synergyc 100% cpu and not working

    Guess this is a bit of a bump.

    I can confirm having the same problems.

    Server machine is running Hardy and displays (pretty much) the same output:

    Code:
    NOTE: CClientListener.cpp,127: accepted client connection
    NOTE: CClientProxyUnknown.cpp,272: new client is unresponsive
    NOTE: CClientListener.cpp,127: accepted client connection
    NOTE: CClientListener.cpp,127: accepted client connection
    NOTE: CClientProxyUnknown.cpp,272: new client is unresponsive
    NOTE: CClientProxyUnknown.cpp,272: new client is unresponsive
    Client machine is running Ibex and is unresponsive to repeated attempts to close it with Ctrl+C (running with -f argument to collect output). End up having to kill -9 it.

  3. #3
    Join Date
    Jul 2006
    Beans
    2

    Re: synergyc 100% cpu and not working

    Same problem here. I'm guessing there's still no fix?

  4. #4
    Join Date
    Sep 2007
    Location
    /dev/null/
    Beans
    1,589

    Re: synergyc 100% cpu and not working

    Wheres the bug report?
    He that will not reason is a bigot; he that cannot reason is a fool; he that dares not reason is a slave.

  5. #5
    Join Date
    Jul 2006
    Beans
    2

    Re: synergyc 100% cpu and not working

    ok, I have a fix. as per this: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/194029

    1. get synergy 1.3.1 sources
    2. apply this patch http://svn.pardus.org.tr/pardus/deve....1-gcc43.patch which will allow synergy to build in newer gcc (stricter includes now)
    3. apply this patch http://launchpadlibrarian.net/155717...hang-fix.patch
    4. do ./configure -x-libraries /usr/lib -x-xincludes /usr/include, make sure you have libxtst-dev if you get an error about missing XTest
    5. edit your cxxflags (i think? can't remember) in the lib/arch and lib/platform Makefiles to not include -Werror if you're getting errors running make

    it should make and make install properly, and synergyc should work mostly ok. i did this on intrepid alpha 5, on an intel atom 230 board (i386 kernel, not x64)

  6. #6
    Join Date
    Apr 2008
    Location
    United Kingdom
    Beans
    84
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: synergyc 100% cpu and not working

    Orrr,

    Go grab the package from Debian Sid which works perfectly anyway

    http://packages.debian.org/sid/synergy
    Last edited by damoxc; September 15th, 2008 at 01:39 PM. Reason: include link

  7. #7
    Join Date
    Sep 2008
    Beans
    1

    Re: synergyc 100% cpu and not working

    I created a bug here for a similar problem with synergys.

    https://bugs.launchpad.net/ubuntu/+s...gy/+bug/270575

  8. #8
    Join Date
    Oct 2005
    Beans
    72

    Re: synergyc 100% cpu and not working

    Quote Originally Posted by damoxc View Post
    Orrr,

    Go grab the package from Debian Sid which works perfectly anyway

    http://packages.debian.org/sid/synergy
    Thank you, that worked great!

  9. #9
    Join Date
    Mar 2005
    Location
    Netherlands
    Beans
    734
    Distro
    Ubuntu Karmic Koala (testing)

    Re: synergyc 100% cpu and not working

    Synergy in intrepid has been updated and works perfectly now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •