Results 1 to 3 of 3

Thread: [SOLVED] keyboard layout disappears on boot

  1. #1
    Join Date
    Dec 2007
    Beans
    71
    Distro
    Ubuntu 10.10 Maverick Meerkat

    [SOLVED] keyboard layout disappears on boot

    Dear community,

    I have three keyboard layouts that I use, configured to switch with left alt + shift. They work well, but every time I boot, alt + shift doesn't do anything. Clicking on the language indicator on the panel circulates between the first two layouts in the indication, but the layout doesn't actually change. Also, "show current layout" opens an empty window.

    A fix I found is the following: open the keyboard preferences and add a fourth layout (e.g. Albanian) and remove it imediately. Alt+shift works and the keyboard layouts are there.

    ...but it would be nice not to have to do this at each boot!

    Thanks a lot for any advice,
    Nikos

    P.S. It seems that adding a fourth language causes some service to restart - is it?

  2. #2
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,798
    Distro
    Ubuntu Development Release

    Re: keyboard layout disappears on boot

    Quote Originally Posted by nikosm View Post
    I have three keyboard layouts that I use, configured to switch with left
    add a fourth layout (e.g. Albanian) and remove it imediately. Alt+shift works and the keyboard layouts are there.

    ...but it would be nice not to have to do this at each boot!
    Add the following command to your startup sessions
    Code:
    setxkbmap
    ; post back if you need more detailed steps.

    Eg, if you're using gnome, click on System-Preferences-Sessions-Add, then fill in the blanks as follows:

    Name: setxkbmap (or whatever you like)
    Command: setxkbmap
    Comment: Restore keyboard layout settings (or whatever you like)
    Last edited by prshah; July 5th, 2008 at 03:16 PM.
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  3. #3
    Join Date
    Dec 2007
    Beans
    71
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: keyboard layout disappears on boot

    [QUOTE=prshah;5324374]Add the following command to your startup sessions
    Code:
    setxkbmap
    Thanks! That fixed it!

    cheers,
    Nikos

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •