Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: GLX gears not working...

  1. #1
    Join Date
    Feb 2008
    Beans
    38
    Distro
    Ubuntu 8.04 Hardy Heron

    GLX gears not working...

    I have a graphics issue and it's been driving me crazy. I tried to open glxgears through a terminal and this is what I get:
    Code:
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't get an RGB, Double-buffered visual
    When I was trying to run a game in Wine I was getting this problem as well:
    Code:
    err:wgl:X11DRV_ChoosePixelFormat No libGL on this box - disabling OpenGL support !
    I think it mainly has to do something with the OpenGL libraries than Wine though... but I have no idea what to do.

  2. #2
    Join Date
    Sep 2006
    Location
    Victoria, Australia
    Beans
    Hidden!

    Re: GLX gears not working...

    hi there,
    can you please post your /etc/X11/xorg.conf file, and the ouput of sudo glxinfo.

    AJ
    Want to find out more about your ubuntu system? see HowTO Ubuntu System
    Want to know a little more about networking? see HOWTO Ubuntu Networking
    Looking for help with something on your ubuntu? see the tutorial of the week sticky


  3. #3
    Join Date
    Feb 2008
    Beans
    38
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: GLX gears not working...

    Here is my xorg.conf, (there is a xorg.conf.1 2 3 4 as well would that be a problem?):
    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by failsafeDexconf, using
    # values from the debconf database and some overrides to use vesa mode.
    #
    # You should use dexconf or another such tool for creating a "real" xorg.conf
    # For example:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Boardname	"NVIDIA GeForce 6800 (generic)"
    	Busid		"PCI:1:0:0"
    	Driver		"nv"
    	Screen	0
    	Vendorname	"NVIDIA"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    	Vendorname	"Samsung"
    	Modelname	"Samsung 990DF"
    	Horizsync	30-96
    	Vertrefresh	50-160
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
      modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
      modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
      modeline  "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
      modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
      modeline  "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
      modeline  "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
      modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
      modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
      modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
      modeline  "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
      modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
      modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
      modeline  "1280x960@85" 148.5 1280 1344 1504 1728 960 961 964 1011 +hsync +vsync
      modeline  "1280x1024@85" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
      modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
      modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
      modeline  "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
      modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1600x1200@75" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
      modeline  "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
      modeline  "1920x1440@60" 234.0 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync
      modeline  "2048x1536@60" 266.95 2048 2200 2424 2800 1536 1537 1540 1589 -hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Configured Video Device"
    	Monitor		"Configured Monitor"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Modes		"1600x1200@75"	"1600x1200@70"	"1600x1200@60"	"1792x1344@60"	"1600x1200@65"	"1856x1392@60"	"1400x1050@75"	"1920x1440@60"	"1400x1050@60"	"2048x1536@60"	"1280x960@75"	"1280x1024@60"	"1280x1024@85"	"1280x960@85"	"1280x960@60"	"1280x1024@75"	"1152x864@75"	"1024x768@43"	"1024x768@60"	"1024x768@70"	"1024x768@75"	"1024x768@85"	"832x624@75"	"800x600@60"	"800x600@85"	"800x600@75"	"800x600@72"	"800x600@56"	"640x480@85"	"640x480@75"	"640x480@72"	"640x480@60"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen 0 "Default Screen" 0 0
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"GLcore"
    	Load		"v4l"
    EndSection
    Section "device" # 
    	Identifier	"device1"
    	Boardname	"NVIDIA GeForce 6800 (generic)"
    	Busid		"PCI:1:0:0"
    	Driver		"nv"
    	Screen	1
    	Vendorname	"NVIDIA"
    EndSection
    Section "screen" # 
    	Identifier	"screen1"
    	Device		"device1"
    	Defaultdepth	24
    	Monitor		"monitor1"
    	SubSection "Display"
    		Depth	24
    		Modes		"640x480@60"
    	EndSubSection
    EndSection
    Section "monitor" # 
    	Identifier	"monitor1"
    	Vendorname	"Plug 'n' Play"
    	Modelname	"Plug 'n' Play"
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    	Gamma	1.0
    EndSection
    Section "ServerFlags"
    EndSection
    glxinfo:
    Code:
    name of display: :0.0
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual
    
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x5c 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Thanks for the Help!!

  4. #4
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,510
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: GLX gears not working...

    Quote Originally Posted by Sneaky07 View Post
    Here is my xorg.conf, (there is a xorg.conf.1 2 3 4 as well would that be a problem?):
    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    
    Section "device" # 
    	Identifier	"device1"
    	Boardname	"NVIDIA GeForce 6800 (generic)"
    	Busid		"PCI:1:0:0"
    	Driver		"nv"
    	Screen	1
    	Vendorname	"NVIDIA"
    EndSection
    Thanks for the Help!!
    Only the 3rd party nvidia driver provides 3D.

    Go to System-Administration-Hardware Drivers and see if it is enabled.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  5. #5
    Join Date
    Sep 2006
    Location
    Victoria, Australia
    Beans
    Hidden!

    Re: GLX gears not working...

    under your device section, change the driver from nv to nvidia, (if it is not installed install via sudo apt-get install nvidia-glx-new)
    Add a new section that looks like this: (only really need this for if you want to use compiz or another composite manager)

    Section "Extensions"
    Option "Composite" "true"
    EndSection

    And also under your device section where you just changed the driver from nv to nvidia, add a new line like this:
    Option "AddARGBGLXVisuals"
    Restart X and enjoy, your glx server should be happy, and as an added bonus, you're now ready to run compiz

    AJ
    Want to find out more about your ubuntu system? see HowTO Ubuntu System
    Want to know a little more about networking? see HOWTO Ubuntu Networking
    Looking for help with something on your ubuntu? see the tutorial of the week sticky


  6. #6
    Join Date
    Feb 2008
    Beans
    38
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: GLX gears not working...

    Quote Originally Posted by dcstar View Post
    Only the 3rd party nvidia driver provides 3D.

    Go to System-Administration-Hardware Drivers and see if it is enabled.
    Nothing shows up in the box.... I have a nvidia 6800gt.... should I have chosen Geforce 6 series instead when I rebooted xserver?

  7. #7
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,510
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: GLX gears not working...

    Quote Originally Posted by Sneaky07 View Post
    Nothing shows up in the box.... I have a nvidia 6800gt.... should I have chosen Geforce 6 series instead when I rebooted xserver?
    Go into Synaptic and install the nvidia driver package.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  8. #8
    Join Date
    Feb 2008
    Beans
    38
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: GLX gears not working...

    Thanks for the help but it's still not working... I have the nvidia-glx-new driver installed. What else do mean by nvidia driver package?

  9. #9
    Join Date
    Oct 2006
    Location
    Belgrade, Serbia
    Beans
    1,325
    Distro
    Ubuntu

    Re: GLX gears not working...

    I would do the following (Applications > Accessories > Terminal):
    Code:
    sudo aptitude purge nvidia-glx-legacy nvidia-glx nvidia-glx-new
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
    sudo dpkg-reconfigure -phigh xserver-xorg
    Press "y" and enter if it asks to purge the packages.

    Now reboot your computer or just log out and log back in.
    In case something goes wrong, restore the backup file:
    Code:
    sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf
    nvidia 6800 supports nvidia-glx-new, so we'll install that:
    Code:
    sudo apt-get install nvidia-glx-new nvidia-settings
    gksudo nvidia-settings
    Then head to "X server display configuration" > Detect displays > Select your resolution and refresh rate (or just put Auto in refresh rate) > Press "Save to X configuration file" > Quit
    After that reboot your computer or log out.

    In case something goes wrong, restore the backup file:
    Code:
    sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

  10. #10
    Join Date
    Sep 2006
    Location
    Victoria, Australia
    Beans
    Hidden!

    Re: GLX gears not working...

    Quote Originally Posted by Sneaky07 View Post
    Thanks for the help but it's still not working... I have the nvidia-glx-new driver installed. What else do mean by nvidia driver package?
    did you change the driver from nv to nvidia in your /etc/X11/xorg.conf file?
    Want to find out more about your ubuntu system? see HowTO Ubuntu System
    Want to know a little more about networking? see HOWTO Ubuntu Networking
    Looking for help with something on your ubuntu? see the tutorial of the week sticky


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •