Page 53 of 64 FirstFirst ... 343515253545563 ... LastLast
Results 521 to 530 of 636

Thread: Info and help for HP TX2500 Series

  1. #521
    Join Date
    Nov 2007
    Beans
    69

    Re: Info and help for HP TX2500 Series

    Well, the mic worked... but the ALSA updates broke Skype. I get the following error when running Skype from the terminal:
    Code:
    ALSA lib pcm_dmix.c:975:(snd_pcm_dmix_open) unable to create IPC semaphore
    skype: relocation error: skype: symbol snd_pcm_hw_params_get_channels_min, version ALSA_0.9.0rc4 not defined in file libasound.so.2 with link time reference
    And, interestingly, just this when running sudo skype:
    Code:
    skype: relocation error: skype: symbol snd_pcm_hw_params_get_channels_min, version ALSA_0.9.0rc4 not defined in file libasound.so.2 with link time reference
    Not sure where to go from here

  2. #522
    Join Date
    Nov 2007
    Beans
    69

    Re: Info and help for HP TX2500 Series

    OK, I fixed it. I reinstalled libasound2 in synaptic, which subsequently broke alsa. Then I recompiled/reinstalled alsa-lib (the newest snapshot) and set up alsamixer again. Everything works. An added bonus? The new fglrx driver finally stopped compiz flickering on video! This is on skype, as well as youtube (i already had vlc set up for x11 output so it didn't flicker). Can't remember if YouTube flickered or not before, but skype definitely did. Thank you, AMD!

  3. #523
    Join Date
    Nov 2007
    Beans
    69

    Re: Info and help for HP TX2500 Series

    Has anyone done the recent kernel upgrade to 2.6.27-11? If so, does it break anything (besides Wacom, which you have to rebuild every update)?

  4. #524
    Join Date
    Apr 2007
    Beans
    9

    Re: Info and help for HP TX2500 Series

    Yes, I have without any problems. It didn't break anything (besides that wacom).

    I am experiencing another (1st for me) problem with the new alsa drivers. It broke the alacarte (menu editor)... Terminal says this:

    Code:
    /usr/lib/python2.5/site-packages/apt/progress.py: inconsistent use of tabs and spaces in indentation
    Traceback (most recent call last):
      File "/usr/bin/alacarte", line 22, in <module>
        from Alacarte.MainWindow import MainWindow
      File "/usr/lib/python2.5/site-packages/Alacarte/MainWindow.py", line 19, in <module>
        import gtk, gtk.glade, gmenu, gobject, gio, gnome.ui
      File "/var/lib/python-support/python2.5/gtk-2.0/gnome/__init__.py", line 13, in <module>
        from _gnome import *
    ImportError: /usr/lib/libesd.so.0: symbol snd_pcm_hw_params_set_rate_near, version ALSA_0.9.0rc4 not defined
    in file libasound.so.2 with link time reference
    Anyone has the same problem?

    btw - good to hear that flickering is gone!
    Last edited by mememe; February 1st, 2009 at 07:29 PM.

  5. #525
    Join Date
    Jan 2009
    Beans
    3

    Post Re: Info and help for HP TX2500 Series

    Hello everyone,

    i finally got most of my tx2650eg working thanks to this thread.

    my current OS:
    8.10 Intrepid Ibex
    Linux 2.6.27-11-generic x86_64 GNU/Linux

    audio:

    added this to /etc/modprobe.d/alsa-bas :
    Code:
    options snd-hda-intel index=0 model=toshiba position_fix=1
    sound works properly and even the mic works ootB i just have to switch between mic and front mic in Mixer->options(tab)->input source

    hibernate: ootB

    suspend:
    this worked for me: http://ubuntuforums.org/showpost.php...6&postcount=19
    without this the keyboard doesn't wake up

    wacom:
    installed it with gali's tutorial: http://ubuntuforums.org/showpost.php...47&postcount=5
    but installed linuxwacom-0.8.2-2.
    on the upgrade from 2.6.27-9 to 2.6.27-11 i made myself a little script for the installation(attached)
    i encountered a little problem but just now i found the reason:
    i could't find my wacom with
    Code:
    dmesg | grep wacom
    now i retried it for this post and i found out i just have to write Wacom with a capital letter.
    (still my eraser tip isn't working, tried it in cellwriter, xournal and gimp. i've attached my xorg.conf so if anyone knows how i can fix this please let me know.)
    Now working thanks to Favux. i just had to comment out the coordinates in the eraser section. so actually it should have worked before as i added these lines on my own to get the eraser working. now it turns out that the eraser just doesn't behave as intuitively as in vista( gimp see's it just as another pen with wich you can select a second tool in the toolbar)
    the remaining problem is that i wanted to simulate right clicks by holding down the tip with mousetweaks but that doesn't really work (in fact it just alters my mousepointer to a strange symbol so i deactivated it)

    login in tablet mode:
    added this to my /etc/gdm/Init/Default just before exit 0:
    Code:
    cellwriter --dock-window=2 --keyboard-only --read-only &
    i also had to disable the nice looking graphical login screen to make this work. is there a more elegant way for this now as the tutorial i followed was already a year old.
    the next problem is to enter the password in the unlock dialog. the cellwriter manpage says something about this. i'll try it out and post my results.
    for the sudo dialogs i had to make them normal windows in the assistive technologies dialog. is this a great problem with the security/is there a better way to do this?

    fingerprint reader: ootB with fprint-demo but i'm using a real password anyway

    webcam: works with cheese and ekiga, weird thing is that it also shows up in xsane but it doesn't work there

    remote control: ootB
    some keys send special media control events, others simple hotkey kombinations.

    wireless lan: ootB: activated the proprietary driver and network-manager applet did the rest.
    i have: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)

    rotation: i use the radion driver as rotation requires it.
    i have a rotation script wich allows me to rotate in 90° steps.
    (attached)
    what i'm missing most is a way to turn the screen accordingly to the display state (open or folded) automatically like in vista. but it doesn't send any events when i fold it with xev.

    buttons: did't really try them but sound and media buttons work

    cpu & fan: i don't know much about this topics, here's what i have found out:
    the gnome applett shows me the current clock settings and lets me configure it
    i can't get any temperatures. not with /proc/acpi/thermal_zone and not with lm-sensors.
    Code:
    cat /proc/acpi/processor/CPU0/throttling
    this tells me that my cpu is running at 100% even the gnome-applet shows it at 600Mhz. which one's right?

    my second information source beside this post was:
    http://www.pietrobattiston.it/wiki/d...avilion_tx2500

    that's all for now and thank you all for this thread

    axel
    Attached Files Attached Files
    Last edited by AxelK; February 2nd, 2009 at 06:14 PM. Reason: eraser problem fixed

  6. #526
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Info and help for HP TX2500 Series

    Hi AxelK,

    In your xorg.conf try commenting out ("#") the "TopX" to "BottomY" lines in the eraser section. Then restart X; <ctrl><alt><backspace>. See if that helps.

    Oh, and in Xournal, the side-switch is the eraser.
    Last edited by Favux; February 1st, 2009 at 10:16 PM.

  7. #527
    Join Date
    Oct 2006
    Location
    Atlanta, Georgia
    Beans
    1,869

    Re: Info and help for HP TX2500 Series

    [Disregard]
    Last edited by Dual Cortex; February 2nd, 2009 at 09:56 AM.

  8. #528
    Join Date
    Jul 2006
    Location
    New Zealand
    Beans
    9

    Re: Info and help for HP TX2500 Series

    Quote Originally Posted by tC_Crazy
    The new fglrx driver finally stopped compiz flickering on video!
    yes...but only if you're not using screen rotation, it seems.

    the new fglrx supports xrandr screen rotation (which we need, of course, for our tx2500's) as soon as you
    Code:
    sudo aticonfig --set-pcs-str="DDX,EnableRandR12,TRUE"
    to configure the settings database in /etc/amdpcsdb (or you can edit it manually).

    unfortunately, on my tablet at least, this same setting re-introduces the compositing+3d=flickering problem. EnableRandR12=TRUE=flickering 3d but rotation. EnableRandR12=FALSE=steady 3d but NO rotation. i haven't found a way to have both work simultaneously.

    despite this i've decided to stick with fglrx (i've been using radeon) for a while as the colour is so much better (radeon produces hicolor banding for some reason) and the flickering video can mostly be worked around (if you use mplayer) by setting the video output driver to unaccelerated "x11" video (i.e.
    Code:
    vo = x11
    in your .mplayer/config, or without the spaces on the command line). with xfce you can also very quickly disable compositing by attaching a button or key combination or whatever to a script with
    Code:
    killall xfwm4 && xfwm4 --compositor=off &
    (and bring it back via compositor=on) so i can keep the rotation and compositing happening, and for now i can live with working around the flicker.

    if anyone has figured out a way to wrestle screen rotation AND non-flickering compositing / accelerated video out of the new fglrx driver, i'd love to hear from them.


  9. #529
    Join Date
    Feb 2009
    Beans
    6

    Re: Info and help for HP TX2500 Series

    Hey um some people have being posting that their audio keys arn't actually changing the sound of anything. Well I think i know why that is. See I did a little looking around through all the volume sliders for all the devices for audio

    It seems, at least for me, that my audio keys are connected to the "Capture: ALSA PCM on front:0 (ALC268 Analog) via dma (Pulse Audio)"
    device.

    I'm not sure why exactly or how that happened. I'm wondering how I go about changing that.

    edit: oh wait there's a dialog box just above it.

    *sigh* never mind... that was too easy...
    Last edited by Qjet; February 11th, 2009 at 02:48 AM.

  10. #530
    Join Date
    Feb 2009
    Beans
    11

    Question Re: Info and help for HP TX2500 Series

    Hi, thanks all for the info here which really helps me to get started with my brand new tx2522au.

    I have a question related to power management. While on battery, the cpu speed is limited to 1100Mhz no matter what (my cpu variation is 500Mhz, 1100Mhz, and 2100Mhz). I have tried to set the governor to performance, or to the frequency manually to 2100Mhz (using the userspace driver), the end result is still the same - 1100Mhz is the max.

    Anybody has a clue? While on ac power - I can get to the max, no problem. (This is a new laptop so no problem with dirty fans etc), and I'm quite sure it's not a hardware/BIOS limitation because I have another distro installed in it (puppy linux) and it happily chugs alon to 2100Mhz if I ask it to.

    Not that I don't appreciate Ubuntu's power management to save my battery, but there are times that I need to run at fullspeed regardless of whether I'm on battery or on ac power.

    Thank you !

Page 53 of 64 FirstFirst ... 343515253545563 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •