Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Boot problems with 8.04

  1. #11
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Boot problems with 8.04

    Quote Originally Posted by aliusdragonfly View Post
    I have mounted as above, but when I navigate to /boot there is no /grub. There are the following:

    abi-2.6.24-16-generic
    config-2.6.24-16-generic
    initrd.img-2.6.24-16-generic.bak
    vmlinuz-2.6.24-16-generic
    memtest86+.bin
    System.map-2.6.24-16-generic

    no grub directory, no menu.lst.
    I don;t understand that, because when you ran 'find /boot...stage1' there was obviously a stage1 file in /boot/grub. well, if you're sure there's nothing there, then just do:

    cd

    sudo grub-install --root-directory=/media/sda1 /dev/sda

    (or '/media/disk' if you just clicked on root to mount)

  2. #12
    Join Date
    Jun 2008
    Beans
    7

    Re: Boot problems with 8.04

    I have done so now, but it hasn't changed anything. And I don't understand why the find command is returning a location either. The new directory I made, /media/sda1, contains a /boot and a /grub of its own, with menu.lst ensuite, but the main /boot for the whole file system doesn't have a /grub.

    Anyway, still staring at GRUB GRUB loading stage1.5. Is stage 1.5 important? I read somewhere that it might be possible to bypass it somehow.

    thanks for your patience and help with this.

  3. #13
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Boot problems with 8.04

    Quote Originally Posted by aliusdragonfly View Post
    I have done so now, but it hasn't changed anything. And I don't understand why the find command is returning a location either. The new directory I made, /media/sda1, contains a /boot and a /grub of its own, with menu.lst ensuite, but the main /boot for the whole file system doesn't have a /grub.

    Anyway, still staring at GRUB GRUB loading stage1.5. Is stage 1.5 important? I read somewhere that it might be possible to bypass it somehow.
    Then it appears grub folder with files is still there....when you say 'main /boot' you must be looking in the one on the live cd (altogether different)

    again, stage1 and/or the rest of the grub files may be corrupt...an educated guess at least. so try refresh as desribed above

  4. #14
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Boot problems with 8.04

    was windows on the other drive?

    Maybe grub is seeing the other drive as (hd0). Try switching the hard disk boot order in the BIOS

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •