Results 1 to 7 of 7

Thread: Unable to Upgrade or Install New Programs

  1. #1
    Join Date
    Sep 2006
    Beans
    3

    Unable to Upgrade or Install New Programs

    I had to rebuild my machine (an ancient 750 Mhz AMD box with about half a gig of RAM) and used the Dapper CD I had handy, figuring once I got it installed, I could update the machine to something newer. The machine locked up during the updating and I had to reboot it. When I logged in and tried to resume the process I got error messages or the various apps I used to try and install the upgrades (or new programs) would promptly crash. The error messages I'm getting are:

    A error occured, please run Package Manager from the right-click menu or apt-get on a terminal to see what is wrong. The error message was: 'Error: Opening the cache (E: Problem parsing dependency Depends, E:Error occurred while processing sound-juicer (NewVersion1). Eroblem with MergeList /var/lib/dpkg/status, E:The package lists or status file could not be parsed or opened.)'
    So how do I fix all of this? Package manager will run, but I can't figure out to find and correct the problems with it, terminal will open, but I don't know the necessary commands to correct the problem. Update Manager will launch and then promptly crash. I've tried to install individual programs via package manager, but that doesn't work.

  2. #2
    Join Date
    Jul 2007
    Location
    Midwest
    Beans
    503
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Unable to Upgrade or Install New Programs

    Try typing this in the terminal.


    sudo dpkg --configure -a
    Your TV might soon be obsolete...find out at https://www.dtv2009.gov/
    Close the Windows and "open" the "source" . 2008 is the year for Linux

  3. #3
    Join Date
    Sep 2006
    Beans
    3

    Re: Unable to Upgrade or Install New Programs

    Did that and got the following response:
    dpkg: parse error, in file `/var/lib/dpkg/status' near line 6185 package `sound-juicer':
    `Depends' field, missing package name, or garbage where package name expected

  4. #4
    Join Date
    Jul 2007
    Location
    Midwest
    Beans
    503
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Unable to Upgrade or Install New Programs

    Quote Originally Posted by Tuckerfan View Post
    Did that and got the following response:
    The only thing I could suggest from here is to do a fresh install with a newer distro. I'm sorry I can't help more.
    Your TV might soon be obsolete...find out at https://www.dtv2009.gov/
    Close the Windows and "open" the "source" . 2008 is the year for Linux

  5. #5
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Unable to Upgrade or Install New Programs

    Which version of ubuntu are you running now ?
    The description for sound-juicer is corrupt in /var/lib/dpkg/status. You can try to fix it by manually editing the file to add back the proper dependencies (back it up first).

    Quote Originally Posted by Tuckerfan View Post
    Did that and got the following response:
    dpkg: parse error, in file `/var/lib/dpkg/status' near line 6185 package `sound-juicer':
    `Depends' field, missing package name, or garbage where package name expected
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  6. #6
    Join Date
    Sep 2006
    Beans
    3

    Re: Unable to Upgrade or Install New Programs

    I'm running Dapper Drake. How do I manually edit the file?

  7. #7
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Unable to Upgrade or Install New Programs

    Here are the dependencies for sound-juicer : http://packages.ubuntu.com/dapper/sound-juicer.

    Could you please open /var/lib/dpkg/status and look for the description for sound-juicer dependencies. Please paste this part in here, so we can have a look.

    Here is mine (not suitable to you, this is the hardy version):
    Code:
    Package: sound-juicer
    Status: install ok installed
    Priority: optional
    Section: gnome
    Installed-Size: 4872
    Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
    Architecture: i386
    Version: 2.22.0-1ubuntu2
    Depends: <-- here is where yours should be corrupt
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •