Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: [SOLVED] rt2870

  1. #1
    Join Date
    Oct 2007
    Beans
    34

    [SOLVED] rt2870

    I was wondering if somebody here kind enough with experience on this driver could hold my hand on this one.

    I'm by no means senseless, but I don't quite understand the readme to the Ralink Tech 2870 driver found here.

    The parts I'm having trouble with are:

    define the linux kernel source include file path LINUX_SRC
    modify to meet your need.
    and

    In os/linux/config.mk
    define the GCC and LD of the target machine
    define the compiler flags CFLAGS
    modify to meet your need.
    ** Build for being controlled by NetworkManager
    Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.
    ** Build for being controlled by WpaSupplicant with Ralink Custom Event
    Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.
    command: #./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d
    What does it mean by define the kernel source and where can I find it if I do need to define it? And I don't even know where to begin with the second lot of quoted text, but starting off with explaining what the GCC and LD of the target machine as well as what the CFLAGS are would be a good start.

    I'm currently using Gusty with the kernel version 2.6.22-15. The only protection I have on my router is mac address filtering and the fact that the ssid is hidden which is more than enough too keep the monkeys out around here.

    Again, thanks in advance to any help provided.

  2. #2
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: rt2870

    define the linux kernel source include file path LINUX_SRC
    modify to meet your need.
    I think, if you have linux-headers-generic and build-essential installed, it will find the path without any help; it did on my system.
    In os/linux/config.mk
    define the GCC and LD of the target machine
    define the compiler flags CFLAGS
    modify to meet your need.
    ** Build for being controlled by NetworkManager
    Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.
    ** Build for being controlled by WpaSupplicant with Ralink Custom Event
    Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.
    command: #./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d
    Since you don't have WPA and may not want it, we can safely skip the latter part. If you intend to allow Network Manager handle your wireless, you should cd 2870/2008_0528_RT2870_Linux_STA_v1.3.0.0/os/linux and sudo gedit config.mk and go down to line 11 and change:
    Code:
    HAS_WPA_SUPPLICANT=n
    to:
    Code:
    HAS_WPA_SUPPLICANT=y
    Then go to line 14 and change:
    Code:
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n
    to:
    Code:
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
    Then proofread, save and close gedit. Next, cd /2870/2008_0528_RT2870_Linux_STA_v1.3.0.0 and run:
    Code:
    sudo make
    Then follow the remaining steps in the README_STA.

    Post back if you get stuck.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Oct 2007
    Beans
    34

    Re: rt2870

    Thank you kindly, sir. My Belkin Wireless N USB dongle now works with a significantly better connection than my old rtl8187 dongle chipset. The only problem I have now is when I iwconfig to see if everything is working correctly it shows that my mac address is still that of my old rtl8187 card even though it's unplugged.

    That's a minor detail though. It doesn't seem to be causing any problems at the moment.

    Again thank you for your time and support.
    It's greatly appreciated.
    Last edited by dse.37; June 23rd, 2008 at 08:37 AM.

  4. #4
    Join Date
    Jan 2007
    Beans
    160

    Re: [SOLVED] rt2870

    I'm also using this driver. The documentation is terrible from an Ubuntu point of view when it comes to loading the module at boot.

    Can you share where you copied the ko file to and how you got it loading at boot (if you have)?

    thanks

  5. #5
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: [SOLVED] rt2870

    Although it's not mentioned, that I can see, in the README, if you run:
    Code:
    sudo make install
    it puts the module in the right place. It should load after reboot, but if not, post back and I'll show it my crowbar.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #6
    Join Date
    Jan 2007
    Beans
    160

    Re: [SOLVED] rt2870

    thanks - that sorted it.

  7. #7
    Join Date
    Jan 2007
    Beans
    160

    Re: [SOLVED] rt2870

    Although the module loads at boot, I still have to do 'sudo ifconfig ra0 down' then 'sudo ifconfig ra0 up', then disable and enable networking in network manager to get the connection to come up.

    any ideas how I can automate this?

    thanks,

    lukemack.

  8. #8
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: [SOLVED] rt2870

    Try this, instead:
    Code:
    sudo /etc/init.d/networking restart
    If that works, we can automate it.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #9
    Join Date
    Jan 2007
    Beans
    160

    Re: [SOLVED] rt2870

    that doesn't work - the only way I can get it to work is the way i described above.

  10. #10
    Join Date
    May 2007
    Location
    Athens, Greece
    Beans
    25
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Question Not Solved...

    Should I post my problem here? That would be spamming, no? Still, I have a problem with my Ubuntu 8.04.

    I still don't understand how it is SOLVED..? Could you help over there?

    Thank you a lot in advance...
    Last edited by nickolasemp; July 8th, 2008 at 09:50 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •