Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

  1. #1
    Join Date
    Mar 2005
    Beans
    423

    Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    Here is a patch that makes it possible to build the 173.14.09 kernel module with the 2.6.26-1-generic kernel. Apply it with the following command:
    Code:
    sh NVIDIA-Linux-x86-173.14.09-pkg1.run --apply-patch xen.patch.txt
    Afterward run the following:
    Code:
    sudo sh NVIDIA-Linux-x86-173.14.09-pkg1-custom.run
    Note that this will have to be reinstalled (and possibly repatched) on every kernel and/or Xorg update.

    Edit: Also, compiz still works.
    Attached Files Attached Files
    Last edited by Amaranth; June 19th, 2008 at 01:13 AM.
    Travis Watkins
    Blog: Realist Anew
    Projects: Compiz

  2. #2
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    The 2.6.26-1 kernel? Am I missing something? kernel.org shows 2.6.25-7 as the latest stable version and 2.6.26-rc6 as the latest prepatch.
    Last edited by Zorael; June 19th, 2008 at 01:27 AM. Reason: typoes abound
    ...

  3. #3
    Join Date
    Mar 2005
    Beans
    423

    Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    No, 2.6.26-1. That means it is the first ABI version of our 2.6.26 kernel packages. It it based on the 2.6.26-rc6 upstream kernel.
    Travis Watkins
    Blog: Realist Anew
    Projects: Compiz

  4. #4
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    Doh, yes, -1; typo on my part. Where can this package be found? I don't see it on the updates repositories. Due to hit them soonish?
    ...

  5. #5
    Join Date
    Mar 2005
    Beans
    423

    Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    It went into the repositories about 4 days ago. Are you using intrepid? If so, your mirror might be broken. Mine was, that's why it took me 4 days to get this out.
    Travis Watkins
    Blog: Realist Anew
    Projects: Compiz

  6. #6
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    There it is, thanks. :>
    ...

  7. #7
    Join Date
    Jun 2005
    Location
    Pacific NorthWest
    Beans
    2,782
    Distro
    Ubuntu Development Release

    Question Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    Hi Travis!!
    I'm getting:

    dean@linux:~$ sh '/home/dean/NVIDIA-Linux-x86-173.14.05-pkg1.run' --apply-patch xen.patch.txt
    Verifying archive integrity... OK
    Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 173.14.05......................................... .................................................. .................................................. .................................................. .................................................. ............................................
    patching file usr/src/nv/conftest.sh
    patching file usr/src/nv/nv-linux.h
    Hunk #2 FAILED at 139.
    Hunk #3 succeeded at 712 (offset -10 lines).
    Hunk #4 succeeded at 865 (offset -10 lines).
    1 out of 4 hunks FAILED -- saving rejects to file usr/src/nv/nv-linux.h.rej
    patching file usr/src/nv/nv.c
    Hunk #1 succeeded at 2020 (offset -20 lines).
    Hunk #2 succeeded at 2032 (offset -20 lines).
    Hunk #3 succeeded at 3903 (offset -16 lines).
    Hunk #4 succeeded at 4040 (offset -16 lines).
    patching file usr/src/nv/os-interface.c
    Failed to apply patch file "/home/dean/xen.patch.txt".


    I'm not seeing a /usr/src/nv/nv-linux.h.rej file or even a /usr/src/nv folder?
    "Let's nobody be dead today----Looks very bad on my report" One of my favourite lines from AVATAR
    Linux User#395230
    Ubuntu User# 13498

  8. #8
    Join Date
    Mar 2006
    Beans
    4,373
    Distro
    Ubuntu Development Release

    Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    is the patch for the xen kernel only ? I tried it with 2.6.26-1-generic (x86_64) and ended up back in failsafe graphics mode . the installer (NVIDIA-Linux-x86_64-173.14.09-pkg2.run) pactched ok and the custom.run installed ok , no clue in the installer log , but did not load when I restarted gdm .
    if it ain't broke you haven't tweaked it enough

  9. #9
    Join Date
    Jun 2005
    Location
    Pacific NorthWest
    Beans
    2,782
    Distro
    Ubuntu Development Release

    Post Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    I looked at the patch & it excludes xen kernels--no idea why I'm getting the error I got--I would guess that your problem has to do with the 64bit issue...
    "Let's nobody be dead today----Looks very bad on my report" One of my favourite lines from AVATAR
    Linux User#395230
    Ubuntu User# 13498

  10. #10
    Join Date
    Mar 2005
    Beans
    423

    Re: Patch for NVIDIA 173.14.09 and 2.6.26-1-generic

    I have only tested this on x86 kernels as I have no x86_64 hardware available. Also, this is for the 173.14.09 driver, not the 173.14.05 driver. The latter doesn't even support 2.6.26 kernels.

    Also, the regular generic kernel is a xen kernel, they've merged the two together. I dunno if it supports Dom0 or just DomU (I know fedora only supports DomU) but there is some kind of Xen support in there.
    Travis Watkins
    Blog: Realist Anew
    Projects: Compiz

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •